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Chapter 1: Introducing CHARM Version 9 

Radian's Complex Hazardous Air Release Model (CHARM®) is a modeling 

software program that calculates and predicts: 

• the movement and concentration of airborne plumes from released 

chemicals; 

• mechanical overpressures from pressurized vessels and explosion 

overpressures from ignition of vapor clouds; 

• thermal radiation footprints associated with jet fires, pool fires, and 

boiling liquid expanding vapor explosions (BLEVE); and 

• population impacts associated with any one of the footprints 

described above. 

The CHARM program is useful for preparing for or responding to the 

occurrence of an accidental release, designing response plans, and 

implementing training programs.  Whether you are developing an 

emergency response plan or responding to an actual event, the CHARM 

program provides a quick and accurate method for assessing the 

potential impacts of airborne chemical releases, overpressures, and 

thermal radiation. 

Planning Mode 

Planning for emergency response involves describing the potential 

release.  You can define maps with the CHARM Editor for use in CHARM 

displays.  In the planning mode, CHARM guides you through a list of 

input fields that describe a particular release and the present 

meteorological conditions.  When you request a Plume display, CHARM 

requests a release time to use in the calculations which enable 

simulation of the release.  The various graphic displays can be altered 

with a variety of options, and the release information can be stored in a 

scenario file for use with CHARM's emergency response mode. 

Emergency Response Mode 

In the emergency response mode, CHARM quickly accesses pre-stored 

input in one or more scenario files. To save time in an emergency 

situation, CHARM enables you to define and store a base map that will 
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be displayed automatically whenever the CHARM program is started.  

Ideally, the map display will have icons that can be selected to show 

release scenarios and other maps.   

CHARM generates plume displays, radiation and overpressure footprint 

displays, plots, tables, and site information.  Emergency response 

procedures for a particular chemical release, local sources of help, and 

important phone numbers stored in the CHARM Editor (CHARMED) can 

be retrieved quickly in the emergency response mode.  

CHARM Input 

The Main CHARM Input Window guides you through a list of 

characteristics that describe the release and the meteorological 

conditions.   The selected species and release type determine which data 

fields are displayed for input.  Although default data values are provided 

for the input fields, any data in the input window can be changed, 

including all of the default values (see “CHARM.INI File Description” in 

Chapter 3). 

To assess the effects of an actual or potential accident, CHARM needs 

information about the toxicity of the released substance and how it 

disperses under different conditions.  CHARM provides data on the 

physical, chemical, and toxic properties of over 180 chemical 

compounds.  The chemical database can be expanded or modified 

through the CHARM editor (CHARMED).  If you are unable to locate 

those chemical properties associated with a desired chemical which is 

not in CHARM’s chemical database, Radian does provide services to 

gather necessary data to be used with CHARM. 

A release can be described as a liquid or gas escaping from a container, 

or a liquid pool/lagoon.  In either case, the conditions are defined right at 

or just prior to the release.  CHARM also has the capability of defining 

release conditions right at or after the release has occurred, called “User-

Specified After-Release Condition”.  You can describe a release that is 

heavier or lighter than air, a ground-level or elevated release, and the 

type of surface on which a spill occurred.  CHARM also allows you to 

describe liquid pool fires, Boiling Liquid Expanding Vapor Explosions 

(BLEVE), and jet fires.  For a flammable vapor cloud, overpressures from 

the detonation or deflagration of the cloud can be estimated.  In addition 

to explosion overpressures, CHARM can calculate mechanical 

overpressures from failures of pressurized vessels.  Once an impacted 

area from any one of the available footprints has been identified, CHARM 

can estimate population impacts based on U.S. Census Bureau 
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Tiger/Line
TM

 1992 Data. 

Meteorological data for input to CHARM can be obtained from 

instruments brought to the site, from a nearby meteorological station(s), 

or from estimates prepared by a remote weather center.  CHARM can 

also be set up permanently as part of a facilities operation to 

automatically receive continuous data from a meteorological station, or 

from multiple data collection sites.  For automatic meteorological data 

retrieval, CHARM requires an additional program called METINTER 

which is custom designed to integrate with the protocol sent by your met 

station hardware. 

Map Displays 

Maps cannot be created in CHARM or CHARMED.  Drawings must be 

created with some type of third-party software and then defined in the 

Map Definition Editor in CHARMED before the map can be utilized in 

CHARM.  The Map Definition Utility in CHARMED can import properly 

scaled, site-specific or area maps created with the Microsoft® Windows 

Paint Program or other more sophisticated Windows-compatible drawing 

programs.  Detailed maps of areas may be found on and downloaded 

from the internet.  Maps can be read from the clipboard or from files.  

Maps must be read and edited with the CHARM Editor before they can be 

used in CHARM.  During a CHARM run, you can overlay displays of 

concentration, thermal radiation, and overpressure levels on a selected 

map to identify local impact areas.  Icons representing release locations 

and other maps can also be defined on a map display.   

Population Impacts 

CHARM has the ability to calculate the number of people affected by 

footprints of desired concentrations, radiation fluxes, or overpressures.  

The number of people is determined from the population information 

available on U.S. Census Bureau Tiger/Line
TM

 1992 Data.  To use 

population data with CHARM, the U.S. Census Bureau data files must be 

preprocessed with the CHARM TigerMap Utility.  After preprocessing, the 

data files must be defined in the CHARM Editor.  Once a footprint is 

displayed, CHARM uses one of three different methods to calculate 

population impacts.  For more information defining and displaying 

population data, see “Population Data” in Chapter 4.  To order Census 

Bureau data, contact: 

 U.S. Department of Commerce 

 BUREAU OF THE CENSUS 

 Data User Service Division 
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 Washington, DC 20233-8300 

 301-673-4100 

CHARM Calculations 

When the required input has been entered, CHARM calculates the 

radiation footprint, overpressure footprint, or concentration of a chemical 

plume, and predicts the dispersion of the release.  CHARM is a Gaussian 

puff model that considers any release to be a series of puffs.  CHARM 

determines the number of puffs in a release and the initial 

characteristics of each puff.  

CHARM creates a source term based on the user input then proceeds to 

generate the transport/dispersion, radiation, or overpressure 

calculations to describe an impact.  The resulting displays simulate the 

release according to the specified input and the calculations.  For 

information on CHARM algorithms, refer to the “CHARM Technical 

Reference Documentation.” 

Graphic Displays 

CHARM provides plume displays to show the locations, shapes, and up 

to three concentration isopleths of the chemical plume resulting from a 

release.  Footprint displays show up to three values each for thermal 

radiation and overpressures.  Any footprint display may overlay a map.  

Vertical cross-sections, tables, and two-dimensional plots are also 

provided. 

The CHARM displays include: 

• An instantaneous plume view showing the concentrations at the 

specified time since release; 

• An integrated plume view showing a minute-by-minute (or second-by-

second) time history of the impact area; 

• A time-averaged plume based on a user-defined averaging interval 

and a user-defined grid size; 

• A dose display showing the time history of concentration at any 

point; 

• A vertical cross-section of the plume or footprint; 

• Thermal radiation footprints from liquid pool and jet fires; 
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• Overpressure footprints resulting from mechanical failure of a 

pressurized vessel; 

• Overpressure footprints resulting from ignition of a vapor cloud at a 

specified time; 

• A table showing the location of maximum concentrations as a 

function of time; 

• A plot and table showing the maximum downwind distance from the 

source of a specific concentration level as a function of time; 

• A plot and table showing the concentrations through the centerline of 

the plume; 

• A plot and table showing the maximum crosswind width of a user-

specified concentration as a function of time; 

• A plot and table showing the crosswind half-width down the 

centerline of the plume as a function of concentration; 

• A 3-Dimensional view of a single user-specified concentration; 

• Population impacts of a plume or footprint (requires 1992 Tiger/Line 

Census Bureau Data); 

• Circular Population impacts associated with a radial distance from 

the source (requires 1992 Tiger/Line Census Bureau Data); 

• A plot and table illustrating emission rates from both the container 

and the pool; 

• A detailed report (Source/Puff Calculation) showing the output of the 

source term calculation performed by CHARM. The data consists 

mainly of the numbers used to describe the source term, emission 

out of the container, emission of each puff into the atmosphere 

during the release, etc.; 

• Displays showing chemical data and emergency response action to be 

taken in association with the species being modeled; and 

• User-definable site specific information. 
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The CHARM Environment 

CHARM operates in the Microsoft Windows environment.  The Windows 

program comes with thorough documentation for using the menus and 

dialog boxes with and without a mouse.  CHARM  menus and dialog 

boxes follow the same style.  CHARM comes with a complete on-line help 

system.  A help command is available for every CHARM window and 

dialog box.  The on-line help screens provide additional information to 

describe the window or explain the type of data requested. 

Within the Windows environment, a single CHARM run can display 

several scenarios of the same or a different chemical under different 

meteorological and/or time-release conditions simultaneously.  In 

addition, both text and graphic displays can be sent to the clipboard for 

use with Windows-compatible word processors. 

Hardware Requirements 

The hardware requirement for the CHARM program depends on the type 

of processor (CPU) in the computer. 

The minimum hardware requirements are a computer with a 80486 CPU 

and 8 megabytes (M) RAM. 

In addition, the hardware requirements include: 

• A 20M hard disk; 

• A 1.44M, 3.5 inch diskette drive; 

• Graphics card/monitor with a Microsoft Windows software driver; 

(Many drivers come with Windows.  Some manufacturers supply 

drivers with their products.  You may have to check with the 

manufacturer.) 

• A math co-processor; 

• A mouse is highly recommended, although not required.  The mouse 

requires a Windows driver; 
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Software Requirements 

CHARM 9 requires Microsoft Windows95 or WindowsNT as the operating 

system.  CHARM does not include a run-time version of the Windows 

program; it must be purchased separately. 

About This Manual 

The CHARM User's Manual is divided into the following sections: 

Chapter 1 "Introducing CHARM" is an overview of the features of the 

CHARM program. It also includes the hardware and 

software requirements, and a description of the contents 

of this book. 

Chapter 2 "Installing CHARM" provides the steps for installing 

CHARM and information for updating a previous CHARM 

version.  This chapter also explains how CHARM is 

protected from unauthorized use and how to solve 

insufficient memory problems. 

Chapter 3 "Getting Started" describes how to start and stop the 

CHARM program and provides general conventions for 

running the program. 

Chapter 4 "Using the CHARM Editor" explains how to use the editors 

to modify CHARM file location information; modify and 

update the chemical database; enter site-specific 

information;  specify 1992 Tiger/Line Census Bureau data 

for determining population impacts;  and set the 

parameters for communication with a meteorological 

tower(s).  This chapter also describes how to edit the maps 

you want to use with CHARM. 

Chapter 5 "The Main CHARM Input Window" explains how to use 

CHARM in the planning mode and describes the input for 

creating a release scenario. 

Chapter 6 "Understanding CHARM Displays" describes the displays 

that CHARM generates for a release scenario. 

Chapter 7 "Using CHARM for Emergency Response" describes how to 

use CHARM in the emergency response mode.  

Chapter 8 "Using the TigerMap Utility" explains how to preprocess 

U.S. Census Bureau Tiger/Line
TM

 1992 Data for 
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preparation for use with the CHARM Editor and CHARM 

in determining population impacts. 

Chapter 9 "Menus and Commands Reference" is an alphabetical 

listing of the CHARM menus and their commands.  This 

chapter functions as a reference for quickly accessing 

detailed information in the CHARM User's Manual. 

This manual also provides a list of figures for each screen in the manual 

and an index for locating specific information quickly. 

Manual Conventions 

This manual uses the conventions for terminology and typography 

discussed in the following paragraphs. 

Key Names 

The names of keys on the computer keyboard appear capitalized and 

enclosed in angle brackets.  For example, the Enter key is represented as 

<Enter> in this manual.  The actual key names seen on your particular 

keyboard may be a little different. 

Key Combinations 

In some cases, two keys must be pressed at the same time to achieve the 

intended result.  In these cases, the two key names are hyphenated.  For 

example, <Ctrl-Del> means hold <Ctrl> while pressing <Del>. 

Arrow Keys 

The four arrow keys on the computer keypad refer to the directions in 

which you can move the selection, the pointer, or the insertion point on 

your screen.  The arrow keys are also used to position icons on a map 

display.  These keys are particularly useful if you are using the keyboard 

instead of the mouse. 

Menu and Command Names 

The names of menu commands and their commands are capitalized in 

this manual.  They appear in text just as they appear on the screen. 

What You Type 

Whenever this manual presents something you should type verbatim, the 

characters are shown in bold typeface.  If the letter case is significant, 

uppercase or lowercase information is specified in the directions. 
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Terms 

Many of the computer terms used in this manual are equivalent to the 

terms used by Windows documentation.  When a term is defined, it 

appears in bold typeface.  Italics indicate emphasis. 

Notes and Cautions 

A note provides information that is specific to certain circumstances or is 

of special interest.  A caution contains information about actions that 

can cause you to lose or damage your data.  Notes and cautions are 

shown in italics. 

Figures 

CHARM windows are shown as numbered figures throughout this 

manual.  A complete list of figures is provided immediately following the 

Table of Contents.  The appropriate dialog box is shown for each CHARM 

data entry field.  These graphics are not numbered, but the field names 

are listed in the Table of Contents.  Window examples are generated from 

Windows95, and may differ if you are running another Windows 

Operating System 
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Chapter 2:  Installing CHARM 

The initial steps to use for installation depend on whether you are 

installing CHARM for the first time or updating a previous version of 

CHARM.  After installation, you must install the parallel port key to 

indicate to CHARM that this license of CHARM is authorized for use.  

This chapter also contains suggestions for handling insufficient memory 

problems. 

Updating a Previous CHARM Version 

CHARM is backward compatible as far as reading scenario and 

meteorological files from a previous version of CHARM.  However, you 

may have added chemical data to the chemical database, in which case 

you do not want to overwrite CHMDAT8 files.  Be sure to backup 

CHMDAT8 files before installating CHARM version 9, or simply install 

CHARM version 9 in another directory. (see “Updating Chemical 

Database from a Previous Version” in Chapter 3). 

Installing CHARM for the First Time 

Use the following steps to install CHARM for the first time: 

1. Turn on or boot your computer. 

2. If a Microsoft Windows operating system is not already installed on 

your PC, install Microsoft Windows version Windows95 or 

WindowsNT. 

3. If Microsoft Windows is not already running, start MS Windows by 

typing the following command at the DOS prompt:  

WIN 

 

4. Select the ‘Run’ option from the appropriate Windows OS.    The 

following window is  displayed: 
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5. Place the CHARM diskette labeled “Disk 1” in the diskette drive, and 

enter the following command at the Command Line prompt of the 

‘Run’ window: 

A:\SETUP 

If you are using a diskette drive other than A, use its name in place of 

the A shown in the command above.  Alternatively, you may initiate 

the CHARM installation procedure by executing My Computer or 

Windows Explorer from the desktop, and executing SETUP.EXE from 

your floppy drive. 

6.  Once the Setup program is running, follow the instructions on the 

screen to continue or exit the installation. 

Handling Insufficient Memory Problems 

Several conditions may cause a "Not enough memory" message to be 

displayed.  Some conditions to check for and their possible remedies are 

described here. 

1. The Windows program must be started before the CHARM program is 

started.  CHARM requires Microsoft Windows to run.  This means 

that CHARM cannot be started from the DOS command prompt like 

other DOS programs.  If you enter CHARM at the command prompt, 

an insufficient memory message is generated because the size of the 

CHARM program is greater than 640K.  

2. Start Windows as described in the Windows documentation for your 

computer system.  CHARM can then be started by selecting the 

CHARM icon from the CHARM group in the Program Manager. 
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3. Other programs may be running and taking up memory needed by 

CHARM.  These programs are called Terminate but Stay Resident 

(TSR) programs, and they reduce the amount of memory available to 

CHARM.  For example, the programs necessary for computer 

networking require memory.  Another example is a utility program, 

such as Sidekick, that requires memory.  A mouse driver need not be 

loaded, because Windows provides its own.  TSRs and some drivers 

are normally loaded with the AUTOEXEC.BAT file.  Most drivers are 

loaded with the CONFIG.SYS file. 

4. The AUTOEXEC.BAT and the CONFIG.SYS files must always allow 

Windows and CHARM to operate.  Some sample AUTOEXEC.BAT and 

CONFIG.SYS files that represent the simplest cases are provided 

below.  It is possible that other directives have been added to these 

files to the extent that memory is no longer available for completing a 

CHARM run. 

Example 1 shows the contents of one of the simplest AUTOEXEC.BAT 

files that can be used.  The example creates a prompt of the default 

directory and identifies the PATH directive.  The PATH directive tells 

the computer where to look for programs named in a command that 

are not in the default directory (the directory from which the 

command is issued). 

Example 1: 

ECHO OFF 
PROMPT $P$G 
PATH C:\WIN;C:\DOS;C:\BIN;C:\UTIL;C:\CHARM 

Example 2 shows the minimum requirements for a  CONFIG.SYS file 

to operate correctly with Windows. 

Example 2: 

FILES=30 
BUFFERS=10 
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Protecting CHARM from Unauthorized Use 

The CHARM software is protected from unauthorized use by a hardware 

device called a key, which is supplied as a part of the purchase of 

CHARM.  This key must be installed before CHARM is run or the 

program will not perform any calculations.  If no key is present, a 

warning is displayed, and calculation is halted, and CHARM terminates. 

The type of key CHARM uses is a parallel port (LPT) key.  The standard 

key being sent with CHARM Version 9 software is the printer port key.  

This key connects in line with the parallel port and the printer cable. 

Use the following steps to install the printer port key: 

1. Disconnect any cable connected to the designated LPT output 

(printer) port of your computer.   

2. Connect the parallel port key to the designated LPT output port.   

3.  Connect the printer cable to the other side of the key.  The male end 

of the key attaches to the female end of the LPT port. 

You are now ready to execute CHARM. 
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Chapter 3:  Getting Started 

This chapter provides information for starting and stopping the CHARM 

program and CHARM utilities, and understanding the general 

conventions used throughout the CHARM program. 

Starting and Stopping the CHARM Program 

After the CHARM program is installed as described in Chapter 2, use the 

following steps to start CHARM. 

5. Turn on the computer, if necessary. 

6. Start Microsoft Windows, if necessary. 

7. Double click the CHARM icon in the CHARM Group of select CHARM 

from the Start menu. 

To stop CHARM or a CHARM utility program, select the Exit command 

from the File menu.  CHARM can also be stopped by double-clicking the 

icon at the upper left corner of the CHARM window, or by single-clicking 

the X icon at the upper right corner of the window. 

General CHARM Conventions 

The general conventions used by the CHARM program involve file names, 

on-line help, dialog boxes, and the search function.  Familiarity with the 

Windows program is helpful in understanding these features. 

CHARM uses a Windows application style that is common for large-scale 

software programs.  This application style is called a Multiple Document 

Interface, or MDI.  This particular style allows the application to display 

multiple windows in a single CHARM window.  The user can view and 

move among multiple windows, but every window is bounded by the 

extents of the single larger CHARM window frame.  A standard MDI 

window frame usually contains a menu bar, an optional toolbar, and 

microhelp in the lower left portion of the window.  Using the MDI 

application style also dictates that only the single larger CHARM window 

frame contain the menu bar, the toolbar, and the microhelp; that is, the 

multitude of windows that may be generated in the MDI frame do NOT 

contain menus, as the menu bar and the toolbar on the MDI frame 

dynamically change when a child window is selected. 
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CHARM Menus and Commands 

All CHARM commands are organized in menus on the menu bar on the 

CHARM MDI frame.  A menu lists all the available commands for a 

selected window, but only those that are not grayed are executable at a 

particular time.  Since CHARM operates in the Microsoft Windows 

environment, many of the conventions are similar.  For example, CHARM 

provides drop-down menus, icons, and the choice of using the mouse, 

the keyboard, or both. 

The File, Edit, and Window menus represented in the CHARM program 

are similar to the Windows menus of the same names.  Refer to the 

Microsoft Windows User's Guide for a more detailed description of the 

standard Windows menus and commands.  The CHARM program 

provides additional menus and commands. 

CHARM provides menus for displaying and altering text and graphics.  

These menus include the File, MetFile, Options, and Displays menus.  

The commands on these menus change depending on the currently 

displayed window and user input.   Refer to Chapter 8, "Menu and 

Command Reference" for a complete listing of all CHARM menus and 

commands.  

The CHARM editor (CHARMED) has special menus and commands that 

are described in Chapter 4, "Using the CHARM Editor." 

CHARM File Names 

When you save a file in CHARM or CHARMED, you can assign the base 

file name and let CHARM assign the default extension, or you can assign 

the base name and the extension.  CHARM uses the file name extension 

for identifying the names to display for selection lists.   

CHARM uses several default file name extensions that are assigned 

according to the file type.  Some file type extensions are user-definable 

(see “CHARM.INI File Description” in this chapter).  The default 

extensions used by CHARM and a brief description of each file type 

follows: 

.IND A file containing subdirectory information 
that CHARM uses to locate .EMG files.  
Files with .IND extensions are created by 
the user with a text editor and are only 
used in accordance with the Scenario 
command under the File menu. 
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.EMG A file containing release scenario data.  
When you save a release scenario without 
specifying a file name extension, CHARM 
assigns the .EMG default extension. 

.MET A file containing meteorological data.  
When you save met data without 
specifying a file name extension, CHARM 
assigns the .MET default extension. 

.MAP A file containing a map.  When you save a 
map without specifying a file name 
extension, CHARM assigns the .MAP 
default extension. 

.MFD A file containing a map definition.  
CHARM automatically creates this file 
when you save a map.  A file with the 
.MFD extension should not be deleted 
unless its corresponding .MAP file is also 
deleted.  Likewise, if the .MAP file is 
moved to a different location (subdirectory) 
on the PC disk, the .MFD file should also 
be moved to the same location. 

.TPY A file containing population information to 
be used in determining population 
impacts for a plume or footprint.  This file 
is initially generated from the TIGERMAP 
Utility program.  The user then specifies in 
CHARMED under ‘Edit/Select Population 
Files’ which population files are to be used 
to calculate population impacts in 
CHARM. 

.TGR A map file initially generated from the 
TIGERMAP Utility program.  The file is 
merely graphic information processed 
from 1992 Tiger Line Census Bureau data.  
The format is not readable from within 
CHARM or CHARMED, and is only 
displayed in the TIGER MAP Utility. 

.PLM An ascii text file that contains the 
Cartesian x, y, and z coordinates and 
other pertinent information that define the 
extents of a plume or footprint. 
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.SHP A file which describes a footprint of impact 
(concentration, thermal radiation, or 
overpressure) which can be transferred to 
ArcView for display. An ArcView shape file 
is actually three files: the main file, an 
index file, and a dBase file with attributes.  
These three files all have the same names 
and locations except for their extensions.  
The main file extension is .SHP. The index 
file extension is .SHX and the dBase file 
extension is .DBF. 

 

Files with .EMG, .MET, .MAP, TPY, TGR, and PLM extensions are used in 

selection lists when no other extension is specified. Files with .IND and 

.MFD extensions have exclusive purposes in CHARM.  Files with the .IND 

extension are user-created ascii files that identify the locations of certain 

.EMG files.  Files with .MFD extensions are created by CHARM to 

accompany a .MAP file and provide the necessary map definition 

information specified with the map editor.  These file name extensions 

should not be used for other purposes. 

Creating .IND Files 

Files with the .IND extension are index files that point to subdirectories 

containing .EMG files.   You can create .IND files with a text editor.  

When the Scenarios command is selected from the File menu in the Main 

CHARM Input Window, CHARM initially searches the initial lookup 

directory for files that have the .EMG extension.   This initial lookup 

directory is defined in CHARMED under the File Locations command of 

the Edit menu labeled ‘Scenario Files’.  If no .EMG files are found, 

CHARM searches for an .IND file for directions.  Files with .EMG and 

.IND extensions should not exist in the same directory, because only the 

.EMG files will be accessed.  Additionally, only the first. IND file CHARM 

encounters in a directory is used and any others are ignored.  Therefore, 

only one .IND file should exist per directory. 

An .IND file can have multiple pairs of subdirectory listings.  Each 

subdirectory can have subdirectories.  A subdirectory that has .EMG files 

can multiple .EMG files associated with that subdirectory. 

To create an .IND file, use a text editor to open a new file.  Enter a pair of 

lines for each subdirectory. The first line of the pair can have up to 60 

characters naming the subdirectory.  Full path names are not required, 

because the named subdirectory is added to the full path name of the 
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previous directory searched.  The second line of the pair provides 

CHARM with a detailed description of the subdirectory when the 

directory is listed to the user for selection. 

Steps for creating IND Files: 

1) The user must define the location of the initial .IND file under the File 

Locations command in the CHARM editor (CHARMED) in the field labeled 

‘Scenario Files’. 

2) From Windows Explorer, create subdirectories which layout, for 

example, geographical aspects of possible release sites.  Other 

alternatives for organizing your data may be by process or chemical 

inventory. 

 

3) From Notepad (or some other text editor), create a file with the .IND 

extension and format the file as follows: 

Format 

  <Subdirectory Name> 

  <Description associated with subdirectory name> 

  <Subdirectory Name> 

  <Description associated with subdirectory name> 

  <Subdirectory Name> 

  <Description associated with subdirectory name> 

 

Example 

The EXAMPLE.IND would read as follows and reside in the 

C:\CHARM\PLANT subdirectory: 

   EAST 

   Relase occurred in east side of plant 

   NORTH 

   Relase occurred in north side of plant    

 SOUTH 
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   Relase occurred in south side of plant 

   WEST 

   Relase occurred in west side of plant 

 

NOTE: The above file should reside in the initial Emergency Response file 

location defined by the CHARM editor (CHARMED).  No prestored data files 

(.EMG) should reside in the same directory as .IND files.  CHARM attempts 

to locate EMG files first.  If EMG files are located and read, no attempt is 

made to locate IND files. 

4) Repeat Step 3 for all directories. 

Creating .EMG Files 

CHARM creates files with the .EMG extension when you save the release 

input data.  Initially, this file type extension is .EMG.  However, refer to 

“CHARM.INI File Description” later in this chapter for information about 

redefining this default extension.  You must specify a base name for the 

file.  Unless you specify a different file name extension, CHARM 

automatically adds the default extension.  Files with the default 

extension can be created with the Save and Save As commands on the 

File menu.  

On-line Help 

CHARM provides on-line help that explains each window and field in the 

program.  On-line help is available in both CHARM and CHARMED.  

Press <F1> for a description of the contents of the current window or 

dialog box.  When you select a field for data input, the dialog box 

contains a Help command button that displays field information and the 

data entry requirements.  To select help on a menu or topic, select 

<Shift-F1>.  The cursor will change to a pointer with a question mark.  

Simply point to the menu item or the editable text and click the left 

mouse button.  CHARM will attempt to locate on-line help for the 

selected menu or topic.  If CHARM cannot locate the menu or topic, it 

will display an index into on-line help. 

Dialog Boxes 

CHARM displays a dialog box whenever it needs additional information to 

carry out a command.  Dialog boxes typically contain text, lists of 

available choices, command buttons, and option buttons.  You may be 

required to make a selection or enter text or values.  Normally, default 

values are provided.  Any units of measure that are acceptable for the 

entry are available in drop-down lists.  The OK, Cancel, and Help 

command buttons are also available in dialog boxes. 
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Many of the values solicited in a CHARM dialog box require you to make 

an entry.  If you try to select the OK command button when the entry 

field is blank, CHARM displays a message saying an entry is required.  

However, in some cases, it may be OK to leave the field blank, whereby 

CHARM will accept the blank entry. 

CHARM often accepts only those values that are within certain limits.   

For example, relative humidity must be less than or equal to 99.  If you 

try to enter an unacceptable value, CHARM displays a message showing 

the acceptable range of values. 

Default Input Values 

On some occasions, you may need to estimate a release incident about 

which you have little data.  In an emergency situation, you may not only 

have little data, but you need to enter the data quickly.  To address this, 

CHARM provides default values for data fields that are essential to the 

calculations.  Default values appear on the screen as already entered 

data.  In some cases, these default values may be user-definable (see 

“CHARM.INI File Description” in this chapter). These values may 

represent the worst-case conditions or some typical situation.  You can 

accept the default values or replace them with more accurate data.   

CHARM.INI File Description 

The file CHARM.INI is used to store information which CHARM reads and 

uses as defaults upon starting the program.  The file is divided into two 

sections: [Directories] and [Default settings]. The [Directories] section 

associates types of files with physical subdirectory locations on your 

hard disk.  Currently, CHARM differentiates between fifteen types of files.  

Initially, upon installation, all subdirectories default to the setup 

directory.  Thirteen of these fifteen subdirectories may and should be 

modified from CHARM or CHARMED.  The two file types (HelpDir and 

WinchDir) can only be changed by modifying the CHARM.INI file itself. In 

order to do this, use the following instructions: 

1) Exit CHARM. 

2) Open your CHARM.INI file using a text editor such as Notepad. 

3) Find the [Directories] section of the file.  It should be the first section. 

4. Change the subdirectory associated with any one of the following: 

(NOTE: Make sure the subdirectory truly exists.) 
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HelpDir - this subdirectory will contain CHARM help files (.HLP files). 

 For example, HelpDir=c:\charm\help\; 

WinchDir - this subdirectory will contain your encrypted hidden 

password file for access to the CHARM Editor. 

 For example, WinchDir=c:\charm\winch\; 

NOTE: Any other modifications to the following should be made from 

within CHARM or CHARMED. 

DataDir - this subdirectory will contain CHMDAT*.* files (chemical 

database files). 

 For example, DataDir=c:\charm\data\; 

SiteDir - This subdirectory will contain site specific information in the a 

file labeled USRMSG. 

 For example, SiteDir=c:\charm\site\; 

CommDir - this subdirectory contains files (METINTER.EXE, 

METINTER.INI, and METDAT*.*) necessary to establish and maintain 

communication with a data logger (if available). 

 For example, CommDir=c:\charm\comm\; 

ScenDir - this subdirectory contains a *.IND file or *.EMG files. 

 For example, ScenDir=c:\charm\scenario\; 

MapDir - this subdirectory is the default for saving or displaying map 

files with the extensions associated with the keyword MapExt under the 

section labeled [Default settings] in CHARM.INI. 

 For example, MapDir=c:\charm\maps\; 

EmgDir - this subdirectory is the default for saving or displaying pre-

stored scenario data files with the extensions associated with the 

keyword EmgExt under the section labeled [Default Settings] in 

CHARM.INI. 

 For Example, EmgDir=c:\charm\emgs\; 
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MetDir - this subdirectory is the default for saving or displaying pre-

stored met data files with the extensions associated with the keyword 

MetExt under the section labeled [Default settings] in CHARM.INI. 

 For Example, MetDir=c:\charm\mets\; 

AsciiDir - this subdirectory is the default for storing data files  

containing real-world coordinates of plume, thermal radiation, or 

overpressure footprints generated by CHARM.  The default extension for 

listing these data files is associated with the keyword AsciiExt under the 

section labeled [Default settings]. 

 For Example, AsciiDir=c:\charm\ascii\; 

ShapeFileDir - this subdirectory is the default for storing ArcView shape 

files containing plume, thermal radiation, or overpressure footprints 

generated by CHARM.  The default extension for listing these data files is 

associated with the keyword ShapeFileExt under the section labeled 

[Default Settings].  A set of files for an ArcView shape file also consist of 

files containing the SHX and DBF extensions. 

 For Example, ShapeFileDir=c:\charm\shapes; 

DIPPRDir - this subdirectory is the default where CHARMED looks to 

find the DIPPR database for importing chemical data into CHARM’s 

chemical database. 

 For Example, DIPPRDir=c:\charm\dippr\; 

PopFiles - this keyword contains a list of comma delimited files 

(including paths) of those population files that were processed from 

CHARM’s TIGERMAP Utility for use with population impacts. 

 For Example,      

 PopFiles=c:\charm\popfiles\county1.tpy,county2,tpy; 

RelDir - this subdirectory is the default from which CHARMED displays 

scenario data files when using the BROWSE button upon selecting files 

associated with a release icon.  The default extension for listing these 

scenario files is associated with the keyword RelExt under the selection 

labeled [Default settings]. 

 For Example, RelDir=c:\charm\emgs\; 

PopDir - this subdirectory is the default where CHARMED displays 

population files when using the BROWSE button upon selecting files 

used for population impacts.  The default extension for listing these 
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population files is associated with the keyword PopExt under the 

selection labeled [Default settings]. 

 For Example, PopDir=c:\charm\popdata\; 

5) Save your CHARM.INI file. 

6) Restart CHARM. 

The [Default settings] section contains default values for variables within 

CHARM itself.  DO NOT CHANGE ANY OF THESE VALUES AS THEY 

ALL MAY BE CHANGED FROM WITHIN CHARM.  CHANGING A 

VALUE MAY CAUSE CHARM TO RUN IN AN INCORRECT MANNER OR 

POSSIBLY CRASH THE SYSTEM.  You may change some variables 

without having severe effects on CHARM: MapExt, EMGExt, MetExt, 

AsciiExt, ShapeFileExt, PopExt, and RelExt.  MapExt contains the 

default extension for map files; EMGExt contains the default extension 

for prestored scenario files; MetExt contains the default extension for met 

data files; AsciiExt contains the default extension for text files that 

contain x,y, and z real world coordinates of a plume or footprint;  

ShapeFileExt contains the default extension for plume or footprint 

datafiles formatted to import into ArcView; PopExt contains the default 

extension to browse for when selecting population files in CHARMED; 

RelExt contains the default extension to browse for when associating 

emergency response files with release icons in Map Definition in 

CHARMED. 

Search Function 

When the chemical selection list is being displayed, you can perform a 

forward or backward search through the chemical database.  First, select 

Set String and enter the character string for which you want to search.  

Then, select Up to search backward or Down to search forward through 

the database. 

When you specify the character string, you can use the wild card 

characters, * (asterisk) and ? (question mark).  The * represents zero or 

more characters.  The ? represents a character location within the string 

rather than a special character. 

Using the Mouse 

The mouse can be used to move icons, expand and shrink windows, and 

select menus and commands.  The mouse techniques used in CHARM 

include pointing, dragging, clicking, and double-clicking.   
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The CHARM program responds to left mouse button clicks and 

combining keys (e.g. Shift, Ctrl, and Alt) with left mouse button clicks.  

Menus and commands are selected in the same manner in CHARM as in 

the Windows program.  Clicking the left mouse button highlights a field 

or selects a location pointed to by the cursor.  Double-clicking the left 

mouse button on a field displays a dialog box for data input. 

The CHARM dialog boxes display command buttons that can be selected 

with the mouse.  You can select the OK command button to complete an 

action, or select the Cancel command button to ignore the attempted 

action.  These are standard techniques for Windows applications. 

Using the Keyboard 

The keyboard can be used to achieve the same results as the mouse.  

The following keys are standard for the CHARM application: 

<Alt> Moves the inverse video bar to the 

menu bar.  Use the arrow keys to 

position the inverse video bar. 

<Esc> Clears a menu from the screen. 

Arrow keys  Move the inverse video bar 

(highlighted selection) up, down, 

right, or left.  In CHARM and 

CHARMED, the arrow keys can 

also be used to move the crosshair 

cursor on graphic displays, define a 

zoom area, define a map scale, and 

reposition plumes, footprints, and 

icons. 

<Enter> Selects the highlighted item or map 

location represented by the cursor.  

On a map display, <Enter> can be 

used to select an icon or generate a 

dose display at a specific location.  

In a dialog box, <Enter> directs 

CHARM to accept the displayed 

values or cancel the operation, 

depending on which command 

button is highlighted. 
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Page Up Scrolls a window display up.  In 

CHARMED, after an option from 

the Define menu of the Map 

Definition window is selected, 

<Page Up> moves the cursor 

instead of the map display. 

Page Down Scrolls a window display down.  In 

CHARMED, after an option from 

the Define menu of the Map 

Definition windows is selected, 

<Page Down> moves the cursor 

instead of the map display. 

<Ctrl-Arrow key> Changes the position of the plume, 

overpressure, or radiation footprint 

within the viewport by virtually 

moving the solid circle on the CHARM 

display. 

<Shift-Enter> In CHARM, when the cursor is on a 

map location icon on a snapshot 

footprint view, <Shift-Enter> displays 

the enlarged map represented by the 

icon.  When the cursor is on a release 

icon, <Shift-Enter> displays a 

selection list of release scenarios for 

the location.  In CHARMED, <Shift-

Enter> selects an icon to be 

repositioned. 

<Shift-Arrow  key> In CHARMED, <Shift-Arrow key> 

moves an icon that has been selected 

with <Shift-Enter>. 
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Chapter 4:  Using the CHARM Editor 

Use the CHARM editor (CHARMED) to identify the locations of the files 

that CHARM uses; add, modify, or delete data from the chemical 

database; update chemical data from a previous version of a CHARM 

database; enter site-specific information; set up communication with a 

meteorological tower(s); select population data files to determine 

population impacts; and define maps for display with the CHARM 

program. 

Use the following steps to run the CHARM editor: 

1. Double click the CHARMED icon in the CHARM Group in Program 

Manager, or 

Select CHARMED.EXE from the CHARM installation directory using 

the Windows Explorer or My Computer from the desktop. The 

CHARMED window is displayed.   

The CHARMED window shown in Figure 4.1 is displayed. 

 

 

The CHARMED Window 

The main CHARM editor window has several menus, the most significant 

one where the user will spend most of the time is the Edit menu.  The 

Edit menu provides a command for each of the following CHARM editors: 

Chemical Database Add, modify, or delete data in 

the chemical database. 

Figure 4.1 
Main CHARM 
Editor 
Window 
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Import Previous 

Database 

Displays a dialog box 

requesting the path to the 

previous version of the CHARM 

database.  Once the path is 

entered, CHARM will attempt to 

update the current database 

from those records in the 

previous database.  The user 

will be prompted to add or 

modify any data that exists in 

the previous database and not 

in the most recent database. 

Update Plot 

Concentrations 

Displays a dialog box 

requesting the path to the 

previous version of the CHARM 

database.  Once the path is 

entered, CHARM will attempt to 

update the default plot 

concentrations in the current 

database from those records in 

the previous database.  The 

user will be prompted for 

verification. 

Pack Chemical 

Database 

Physically removes logically 

deleted records from the 

chemical database.  Records 

are logically deleted from 

within the Chemical Database 

editor using the Delete button. 

Local Met Comm 

Parameters 

Sets the parameters for 

communications with a 

meteorological tower.  Another 

Radian software program 

(METINTER.EXE) is required 

for the implementation of 

communication with a tower. 
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Network Met Server 

Location 

Sets the logical name of the 

server to where a network 

version of the Meteorological 

Interface (METINTER.EXE) will 

reside for LAN/WAN access. 

File Location Specifies where CHARM can 

find necessary files. 

Site Information Specifies site-specific 

information for a release in a 

file labeled USRMSG. 

Map Definition Reads maps and provides 

commands to edit them for use 

with CHARM. 

Select Population 

Files 

Select population files to be 

used in determining population 

impacts for a plume or 

footprint.  These files are 

initially generated from the 

TIGERMAP Utility program. 

Change Password Defines CHARM/System 

password to regulate 

CHARMED entry.  This menu 

item may be grayed and 

optional to the user.  Contact 

Radian to allow password 

access. 

Exit Exits CHARMED. 

 

Only one editor can be used at a time.  When you exit from an editor, you 

are returned to the CHARMED window. 

Editing File Locations for CHARM 

Use the File Location command on the Edit menu of the CHARMED 

window to identify the directory locations for the chemical database, site 

specific information, meteorological communication parameters, as 

well as the location of the emergency response files.  Emergency 

response files have  default .EMG extensions, unless you specify a 
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different extension (see Chapter 3: CHARM.INI File Description).  CHARM 

uses this directory information to locate necessary files.  Figure 4.2 

shows the CHARMED File Location Editor. 

 

 

To identify directory locations: 

1. Run the CHARM editor by selecting the CHARMED.EXE file.  The 

CHARMED window is displayed. 

2. Select the File Locations command on the Edit menu of the 

CHARMED window. 

3. Enter the full path names for the directories containing the Chemical 

Database, Site Specific Information, Meteorological Communication 

Parameters, and Scenario files.  Alternatively, use the Browse button 

associated with each file directory to input full path names. 

4. Select OK or press <Enter>. 

Maintaining the Chemical Database 

The chemical database provides over 180 chemical species and their 

characteristics for use with the CHARM program.  Information from the 

chemical database is displayed in the Chemical Selection and Chemical 

Editor windows of the CHARM editor. 

The Chemical Selection Window 

After you select the Chemical Database command from the Edit menu, 

the Chemical Selection window shown in Figure 4.3 is displayed.  This 

window contains a list of all the chemicals in the database.  The 

Figure 4.2 
File Location 
Editor 
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Change Name, Delete, and Modify commands require you to select the 

chemical name first.  To select a chemical, simply highlight the desired 

compound by left mouse clicking on the chemical name.  You can use 

the search or scroll functions to look for a particular chemical species. 

 

Using the Search Function 

Use the Search function to look for a particular chemical in the chemical 

database.  This function can be used to find entire chemical names 

quickly or to find a chemical whose name is only partially known.  The 

Search function is also available in CHARM when the chemical species is 

selected for input.  The following dialog box is displayed when you select 

the Set Search String command button from the Chemical Selection 

window. 

 

To perform a search on the list of chemical names: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Chemical Database command on the Edit menu.  The 

Figure 4.3 
Chemical 
Selection 
Window 
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Chemical Selection window is displayed. 

3. Select the Set string radio button from within the Search group box.   

4. Type a character string for the search and include one of the wild 

card characters, * (asterisk) or ? (question mark). 

The * represents zero or more characters. The ? represents the 

position of a character in the string, rather than a particular 

character. 

A search allows for multiple order-dependent strings to be used.  For 

example, a search for the character string "di*meth*e?e" retrieves all 

strings with the substrings "di," followed by "meth," and then followed 

by "e?e."  The ? represents any character with an "e" on either side. 

5. Select OK or press <Enter>. 

6. Specify whether to search backward or forward from the currently 

highlighted species by selecting the Up or Down button.  Either the 

highlight bar moves to the first name that matches the search string, 

or a message displays saying no matches were found. 

Chemical Species 

The chemicals available with CHARM are listed below.  (NOTE:  Your copy 

of CHARM may actually contain more than the names listed below, since 

new chemicals are periodically added to this list). 

Acetaldehyde 
Acetic Acid 
Acetone 
Acetonitrile 
Acetylene 
Acrolein 
Acrylic Acid 
Acrylonitrile 
Aerozine (50% solution) 
Allyl Alcohol 
Allylamine 
Allyl Chloride (3-Chloropropene) 
Ammonia 
Ammonia 25% 
Ammonia (15% solution) 
Ammonia (20% solution) 
Ammonia (29% solution) 
Ammonia (3.6% solution) 
Ammonia (49.9% solution) 
Ammonia (5% solution) 
Aniline 
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Arsine 
Benzene 
Benzyl Chloride (Tolyl Chloride) 
Benzyl Cyanide 
Boron Trichloride 
Boron Trifluoride 
Bromine 
2-Bromoproprionic Acid 
1,3-Butadiene 
Butane 
1-Butene(a-Butylene) 
2-Butene-cis 
2-Butene-trans 
Carbon Dioxide 
Carbon Disulfide 
Carbon Monoxide 
Carbon Tetrachloride 
Chlorine 
2-Chloroethanol 
Chloroform 
Chloromethly Ether 
Chloromethly Methyl Ether 
2-Chloropropolene 
Crotonaldehyde, (E) 
Cyanogen Bromide 
Cyanogen Chloride 
Cyclohexylamine 
Cyclopropane 
Diallylamine 
Diborane 
Dibutyl Phthalate 
2,3 Dichloropropene 
Dichlorosilane 
Diethylene Triamine 
Difluoroethane 
Diisopropylaminoethanol 
Diisopropylcarbonate 
Dimethylamine 
Dimethyldichlorosilane 
Dimethyl Disulfide 
2,2-Dimethylpropane 
Dimethyl Sulfate 
Di-tert-butylethyldiamine 
Epichlorohydrin 
Ethane 
Ethanol 
Ethyl Acetylene 
Ethyl Acrylate 
Ethylamine 
Ethyl Chloride 
Ethylene 
Ethylenediamine 
Ethylene Dibromide(1,2-Dibromoethane) 
Ethylene Dichloride(1,2-Dichloroethane) 
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Ethylene Glycol 
Ethyleneimine 
Ethylene Oxide 
Ethyl Ether 
2-Ethyl-1-Hexanol 
Ethyl Mercaptan 
Fluorine 
Formaldehyde 
Formaldehyde (37% solution) 
Formaldehyde (56% solution) 
Formic Acid 
Freon 12 (Dichlorodifluoromethane) 
Freon 14 (Carbon Tetrafluoride) 
Freon 16 (Hexafluoroethane) 
Furan 
Furfural 
Hexamethylenediamine 
37% Hydrochoric Acid 
Hydrazine 
Hydrazine Monohydrate (35% Solution) 
Hydrazine (54% Solution) 
Hydrochloric Acid (30% Solution) 
Hydrogen 
Hydrogen Bromide 
Hydrogen Chloride 
Hydrogen Cyanide 
Hydrogen Fluoride 
Hydrogen Fluoride (30% Solution) 
Hydrogen Selenide 
Hydrogen Sulfide 
IRFNA (Inhibited Red Fuming Nitric Acid) 
Isoamylene (2-Methyl-2-Butene) 
Isobutane 
Isobutyronitrile 
Isopentane 
Isoprene 
Isopropanol 
Isopropylamine 
Isopropyl Benzene (Cumene) 
Isopropyl Chloride 
Isopropyl Ether 
Mesityl Oxide 
Methacrylonitrile 
Methane 
Methanol 
2-Methyl-1-Butene 
3-Methyl-1-Butene 
Methyl Chloride 
Methyl Diisocyanate 
Methylene Chloride (Dichloromethane) 
Methyl Ether 
Methyl Ethyl Ketone 
Methyl Formate 
Methyl Hydrazine 
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Methyl Isobutyl Ketone 
Methyl Isocyanate 
Methyl Mercaptan 
Methyl Methacrylate 
Methyl Phosphonic Dichloride 
Methyl Phosphonic Difluoride 
2-Methylpropene 
Methyltrichlorosilane 
Morpholine 
Mustard Gas 
m-Xylene 
n-Butane 
n-Butyl Acetate 
n-Butyl Acrylate 
n-Butyl Alcohol (1-Butanol) 
n-Decane 
n-Hexane 
Nitric Acid (70% Solution) 
Nitric Acid (98Solution) 
Nitric Oxide 
Nitrogen Dioxide 
Nitrogen Dioxide/ Dinitrogen Tetroxide 
Nitrogen Tetroxide 
Nitrogen Trifluoride 
N,N-DimethylFormamide 
o-Cresol 
o-Dichlorobenzene 
Oleum (35%) 
Oxygen 
Parathion 
Pentane 
1-Pentene 
2-Pentene,(E) 
2-Pentene,(Z) 
Phenol 
Phosgene 
Phosphine 
Phosphorous Oxychloride 
Phosphorous Trichloride 
Pinacolyl Alcohol 
Piperidine 
Propadiene 
Propane 
Propionic Acid (Methylacetic Acid) 
Propionitrile 
Propylene 
Propyleneimine 
Propylene Oxide 
Sarin 
Silane 
Soman 
Styrene 
Sulfur Dioxide 
Sulfuric Acid (98% solution) 
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Sulfur Trioxide 
tert-Butyl Alcohol (2-Methyl-2-Propanol) 
tert-Butylamine 
Tetrachloroethylene (Perchloroethylene) 
Tetraethyl Lead 
Tetrafluoroethylene 
Tetrahydrofuran 
Tetramethylsilane 
Tetranitromethane 
Thionyl Chloride 
Thiophenl (Benzenethiol) 
Toluene 
Toluene Diisocyanate 
Toluene 2,4-Diisocyanate 
1,1,1-Trichloroethane (Methyl Chloroform) 
Trichloroethylene 
Trichlorosilane 
Trifluorochloroethylene 
Trimethylamine 
TriMethylChloroSilane 
Unsymmetrical Dimethyl Hydrazine 
Vinyl Acetate 
Vinyl Chloride 
Vinyl Ethyl Ether 
Vinyl Fluoride 
Vinylidene Choride 
Vinylidene Fluoride 
Vinyl Methyl Ether 
VX 

The Chemical Editor Window 

The Chemical Editor Window contains the thermodynamic data that 

define the chemical in the database.  The window shown in Figures 

4.4,4.5, and 4.6 is displayed when you select the Add or Modify 

command buttons in the Chemical Selection window. 

 

Figure 4.4 
Chemical 
Editor 
Window (top) 
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To edit chemical data, move the highlight bar over the field and double-

click the left mouse button or press <Enter>.  A dialog box is displayed in 

which you can change the value.  When you edit chemical data, the 

database is updated only if you select Close or Save from the File menu.  

If you select Close after making changes to the data, CHARMED will 

prompt the user to save changes to the chemical database. 

Figure 4.5 
Chemical 
Editor 
Window 
(Temperature 
Dependent 
Equations) 

Figure 4.6 
Chemical 
Editor 
Window 
(Bottom) 
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When you are running the CHARM program, you can display chemical 

data for the selected species by selecting the Chemical Data command on 

the Displays menu of the Main CHARM Input Window and the Displays 

menu of plan view windows.  You can also display the Emergency 

response text from the database by selecting the Emergency Response 

command on the Displays menu. 

File Menu 

The File menu in the Chemical Editor closes the chemical data window, 

saves any changes to the database, edits emergency response text, prints 

the text in a window, previews the data before printing, configures the 

printer, or exits the CHARM Editor. 

Edit Menu 

The Edit menu in the Chemical Editor window allows the user to export 

the chemical data currently displayed in the window.  To accomplish 

this, select the Copy Data command from the Edit Menu.  The chemical 

data are copied to Window’s Clipboard in an ordered, comma delimited 

format.  Likewise, chemical data may be imported in the same manner.  

Once comma delimited data exists in the Clipboard, select the Paste Data 

command from the Edit menu, and the data is copied from the Clipboard 

into the Chemical Database window into the appropriate data fields. 

Another method of importing data involves CHARM’s interface to the 

DIPPR database.  For this option, select Import From DIPPR under the 

Edit menu.  CHARMED displays a selection list of all the species in the 

DIPPR chemical database (see Figure 4.7).  The display window is much 

like the CHARM Chemical Species selection window.  The user may build 

a search string containing wild card characters * (asterisk) or ? (question 

mark).  The * wild card character represents zero or more character, and 

the ? wild card character represents the position of a single character 

(see Using the Search Function in this chapter). 

The user may search by name or by CAS number.  After selecting a 

chemical, the DIPPR database is read and the data in the original data 

display window is replaced.  To exit the Chemical Selection window 

without choosing a chemical, select the Cancel command button.  

CHARMED will inform the user if any values required by CHARM were 

not located in the DIPPR database.  The missing data values will be 

reported as zeros (0.00) in the CHARMED Chemical Data sheet. 

The Copy menu item simply copies the contents of the Chemical 

Database window, including field description text, into the clipboard. 
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Chemical Data 

The chemical database includes the following thermodynamic data for 

each chemical:  

Molecular Weight 

The molecular weight (grams per mole) of the species. 

 

Normal Boiling Point (NBP) 

The temperature (Kelvin) at which the vapor pressure of the liquid is 

equal to one atmosphere. 

 

Melting Point 

Figure 4.7 
DIPPR 
Selection 
Window 
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This is the temperature (Kelvin) at 1 atmosphere of pressure at which the 

solid phase of the species changes to liquid. 

 

Triple Point Temperature 

This is the temperature (Kelvin) at the triple point pressure which all 

three phases (solid, liquid, and vapor) of the species exist. 

 

Triple Point Pressure 

This is the pressure (atmospheres) at the triple point temperature which 

all three phases (solid, liquid, and vapor) of the species exist. 

 

Critical Temperature 

The temperature (Kelvin) above which a gas cannot be liquefied, 

regardless of pressure. 
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Critical Pressure 

The lowest pressure (atmospheres) required to liquefy the gas at the 

critical temperature. 

 

Critical Volume 

The molar volume (cubic centimeters) at the critical point.  The critical 

point is the temperature and pressure at which the liquid and vapor 

states of a material have the same density. 

 

Heat of Vaporization at Normal Boiling Point  

The heat of vaporization (Joules per kilogram) at normal boiling point 

(NBP).  This value is used to determine the heat required (ambient air to 

be entrained) to evaporate any droplets of the released species. 
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Surface Tension of Liquid Phase at NBP 

A measure (Newtons per meter) of the lateral elasticity of a liquid surface.  

This is a measure of the resistance of a fluid to flow. 

 

Viscosity of Liquid Phase at NBP 

A measure (kilograms per meter seconds) of the resistance of a fluid to 

flow. 

 

Gamma (Cp/Cv) 

The ratio of the vapor state heat capacity at constant pressure to the 

vapor state heat capacity at constant volume.  This is a dimensionless 

value. 
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Energy of Molecular Interaction 

Energy divided by the Boltzman constant (hence Kelvin units).  The value 

can be estimated with the following equation: 

E/K = 1.15 TB 

where Tb is the normal boiling point.  The energy of molecular interaction 

is used in calculating the rate at which molecules of an evaporating 

liquid leave the surface.   

 

Effective Diameter of Molecule 

The diameter (Angstroms) of an average molecule.  This diameter is 

determined from the volume of an average molecule, which is the molar 

volume divided by Avogadros number, and then solved for the diameter.  

Normally, the liquid molar volume used is at normal boiling point.  The 

diameter can be computed from the liquid molar volume (V) at the 

normal boiling point using the following equation: 

D = 1.18 (V / N)(1/3) 

where N is Avogadros number. 
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Liquid Heat Capacity Equation 

This is the form of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  Two forms are allowed.  After selecting the form, 

the parameters in the equation must entered.  The two forms of the 

equation are: 

Cp = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2 

Cp = A
2
/T+B-2*A*C*T-A*D*T

2
-C

2
*T

3
/3-C*D*(T

2
)
 2
/2-D

2
*T

2
*T

3
/5 

where 

T = temperature (K)  

A, B, C, D, and possibly E = parameters to be input. 

 

Liquid Heat Capacity Coefficient A 

This is the A term of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  The equation takes one of the two forms described 

in the section above labeled ‘Liquid Heat Capacity Equation’.  Depending 

on the form of the Liquid Heat Capacity Equation, the coefficients A, B, 

C, D, and possibly E are required to be input.   
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Liquid Heat Capacity Coefficient B 

This is the B term of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  The equation takes one of the two forms described 

in the section above labeled ‘Liquid Heat Capacity Equation’.  Depending 

on the form of the Liquid Heat Capacity Equation, the coefficients A, B, 

C, D, and possibly E are required to be input.  

 

Liquid Heat Capacity Coefficient C 

This is the C term of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  The equation takes one of the two forms described 

in the section above labeled ‘Liquid Heat Capacity Equation’.  Depending 

on the form of the Liquid Heat Capacity Equation, the coefficients A, B, 

C, D, and possibly E are required to be input.  

 

Liquid Heat Capacity Coefficient D 

This is the D term of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  The equation takes one of the two forms 

described in the section above labeled ‘Liquid Heat Capacity Equation’.  
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Depending on the form of the Liquid Heat Capacity Equation, the 

coefficients A, B, C, D, and possibly E are required to be input.  

 

Liquid Heat Capacity Coefficient E 

This is the E term of the equation used to calculate the liquid phase heat 

capacity (J/kmole K).  This coefficient is only required if the form of the 

Liquid Heat Capacity Equation described in the section above labeled 

‘Liquid Heat Capacity Equation’ is of the form 

Cp = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2 

The coefficients A, B, C, and D are required to be input. 

 

Liquid Density Equation 

This is the form of the equation used for calculation of liquid density (d).  

Three forms are allowed.  After selecting the form, the parameters in the 

equation must be entered.  The three forms of the equation are: 

d = (MW/Vc)*(1+A*(1-Tr)
(1/3)

+B*(1-Tr)) 
d = A/B^(1 + (1-T/C)

D
) 

d = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2
 

where 

MW = molecular weight (kg/kmole) 

Vc = critical volume (m
3
/kmole) 

T = temperature (K) 

Tr = T / Tc 

Tc = critical temperature (K) 
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A, B, and possibly C, D, and E = parameters to be input, depending 

on the form of the equation chosen. 

 

Liquid Density Equation Coefficient A 

This is the A term (units depend on the equation form) of the equation 

used to calculate the liquid density (d).  The equation takes one of the 

three forms described in the section above labeled ‘Liquid Density 

Equation’.  In any form of the Liquid Density Equation, the coefficient A 

is required.   

 

Liquid Density Equation Coefficient B 

This is the B term (units depend on the equation form) of the equation 

used to calculate the liquid density (d).  The equation takes one of the 

three forms described in the section above labeled ‘Liquid Density 

Equation’.  In any form of the Liquid Density Equation, the coefficient B 

is required.   

 

Liquid Density Equation Coefficient C 

This is the C term (units depend on the equation form) of the equation 
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used to calculate the liquid density (d).  The equation takes one of the 

three forms described in the section above labeled ‘Liquid Density 

Equation’.  If the Liquid Density Equation is of the form 

d = A/B^(1 + (1-T/C)
D
), or 

d = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2
, 

the coefficient C is required.  Otherwise, set C=0.   

 

Liquid Density Equation Coefficient D 

This is the D term of the equation used to calculate the liquid density (d).  

The equation may only take one of three forms described in the section 

above labeled ‘Liquid Density Equation’.  If the Liquid Density Equation 

is of the form 

d = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2
, 

the coefficient D is required.  Otherwise, set D=0.   

 

Liquid Density Equation Coefficient E 

This is the E term of the equation used to calculate the liquid density (d).  

The equation may only take one of three forms described in the section 

above labeled ‘Liquid Density Equation’.  If the Liquid Density Equation 

is of the form 

d = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2
, 

the coefficient E is required.  Otherwise, set E=0.   
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Vapor Phase Heat Capacity Equation 

This is the form of the equation used for calculation of vapor phase heat 

capacity (Cp).  Three forms are allowed.  After selecting the form, the 

parameters in the equation must be entered.  The three forms of the 

equation are: 

Cp = A + B*exp[-C/T
E
] 

Cp = A + B*[C/T*sinh(C/T)]
2
 + D*[E/T*cosh(E/T)]

 2
 

Cp = A + B*T + C*T
2
 + D*T

3
 + E*(T

2
)
 2
 

where 

T = temperature (K) 

A, B, C, D, and possibly E = parameters to be input, depending on 

the form of the equation chosen. 

 

Vapor Phase Heat Capacity Equation Coefficient A 

This is the A term of the equation used to calculate the vapor phase heat 

capacity (J/kmole K).  The equation takes one of the three forms 

described in the section above labeled ‘Vapor Phase Heat Capacity 

Equation’.  In any form of the Liquid Density Equation, the coefficient A 

is required.   
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Vapor Phase Heat Capacity Equation Coefficient B 

This is the B term of the equation used to calculate the vapor phase heat 

capacity (J/kmole K).  The equation takes one of the three forms 

described in the section above labeled ‘Vapor Phase Heat Capacity 

Equation’.  In any form of the Liquid Density Equation, the coefficient B 

is required.   

 

Vapor Phase Heat Capacity Equation Coefficient C 

This is the C term of the equation used to calculate the vapor phase heat 

capacity (J/kmole K).  The equation takes one of the three forms 

described in the section above labeled ‘Vapor Phase Heat Capacity 

Equation’.  In any form of the Liquid Density Equation, the coefficient C 

is required.   

 

Vapor Phase Heat Capacity Equation Coefficient D 

This is the D term of the equation used to calculate the vapor phase heat 

capacity (J/kmole K).  The equation takes one of the three forms 

described in the section above labeled ‘Vapor Phase Heat Capacity 
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Equation’. If the Vapor Phase Heat Capacity Equation is of the form 

Cp = A + B*[C/T*sinh(C/T)]
2
 + D*[E/T*cosh(E/T)]

 2
 

   or 
Cp = A + B*T + C*T

2
 + D*T

3
 + E*(T

2
)
 2
, 

the coefficient D is required.  Otherwise, set D=0.   

 

Vapor Phase Heat Capacity Equation Coefficient E 

This is the E term of the equation used to calculate the vapor phase heat 

capacity (J/kmole K).  The equation may takes two of the three forms 

described in the section above labeled ‘Vapor Phase Heat Capacity 

Equation’.  If the Vapor Phase Heat Capacity Equation is of the form 

Cp = A + B*[C/T*sinh(C/T)]
2
 + D*[E/T*cosh(E/T)]

 2
 

   or 
Cp = A + B*T + C*T

2
 + D*T

3
 + E*(T

2
)
 2
, 

the coefficient E is required.  Otherwise, set E=0.   

 

First Default Concentration for plotting 

The first of three isopleth concentrations (parts per million) to be used as 

defaults for plotting the plume.  The defaults can be changed while you 

are running or storing a scenario. 
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Second Default Concentration for plotting  

The second of three isopleth concentrations (parts per million) to be used 

as defaults for plotting the plume.  The defaults can be changed while 

you are running or storing a scenario. 

 

Third Default Concentration for plotting 

The third of three isopleth concentrations (parts per million) to be used 

as defaults for plotting the plume. The defaults can be changed while you 

are running or storing a scenario. 

 

Reported Fraction 

If the emission entering the atmosphere as a gas is actually a mixture 

this parameter allows you to allocate only part of the concentration to a 

single species.  If 20% of the emission were species A and 40% species B, 

two chemicals could be added to the database.  All the parameters would 

be the same for the two species except the name and this parameter.  For 

species A to be reported correctly, this parameter should be 0.20.  For 

species B it should be 0.40.  Most species will have this parameter as 
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1.0.  If it is set to zero, it is assumed to be 1.0. 

 

Parameter A for Concentration Probit Equation 

The A term in the probit equation, which has the following form: 

P = A + B log N(TCN) 

where C is the concentration (parts per million) and T is the exposure 

time (minutes).  The probit is used to determine the probability of 

fatality. 

 

Parameter B for Concentration Probit Equation 

The B term in the probit equation shown previously for Parameter A for 

Concentration Probit Equation. 

 

Parameter N for Concentration Probit Equation 

The N term in the probit equation shown previously for Parameter A for 

Concentration Probit Equation. 
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Net Heat of Combustion 

The amount of energy released (Joules per gram) when the material is 

burned. 

 

Flash Point Temperature 

The lowest temperature (degrees Kelvin) at which the vapor in air can be 

made to ignite momentarily. 

 

Upper Flammability Limit 

The highest concentration (percent) at which the vapor will burn. 
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Lower Flammability Limit 

The lowest concentration (percent) at which the vapor will burn. 

 

Auto-Ignition Temperature 

The lowest temperature (Kelvin) at which the vapor in air can be made to 

ignite and burn. 

 

Free Energy of Formation at 25°C 

The amount of energy (kilocalories per mole) required to bring together 

the individual atoms in the molecule. 
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Flame Speed 

The speed (Mach) at which the flame will spread if a vapor cloud of the 

material is ignited.  If the speed is greater than Mach 1, it is assumed to 

be a detonation.  If the speed is less than Mach 1, it is assumed to be a 

deflagration. 

 

Below is a table of flame speeds from Quentin A. Baker, Ming Jun Tang, 

Ephraim Scheier, and Gustavo J. Silva, Vapor Cloud Explosion Analysis, 

Process Safety Progress, Vol. 15, No. 2, Summer 1996. 

Type of Flame 

Expansion 

Mixture 

Reactivity 

 Obstacle 

Density 

 

  High Medium Low 

 High 5.2 5.2 5.2 

1-D Medium 2.265 1.765 1.029 

 Low 2.265 1.029 0.294 

 High 1.765 1.029 0.588 

2-D Medium 1.235 0.662 0.118 

 Low 0.662 0.471 0.079 
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 High 0.588 0.153 0.071 

3-D Medium 0.206 0.100 0.037 

 Low 0.147 0.100 0.037 

Table Explanation 

Type of Flame Expansion refers to the geometry associated with the 

propagating (expanding) flame front.  Propagation of the flame front in a 

long pipe corresponds to 1-D.   

Propagation of the flame front between two flat plates corresponds to 2-

D.  Propagation of the flame front in three dimensions corresponds to 3-

D.  Note: Multi-deck, open framework structures should be treated as 2-

D. 

Reactivity is classified as low, average (medium), or high according to the 

recommendations of TNO (Methods for the Calculation of Physical Effects 

Resulting from Releases of Hazardous Materials (Liquids and Gases), 

CPR 14E, Second Edition 1992.)  Ammonia, carbon monoxide, methane, 

and natural gas are the only materials regarded as having low reactivity.  

Hydrogen, acetylene, ethylene, ethylene oxide, and propylene oxide are 

considered highly reactive.  All other fuels (ethane, propane, propylene, 

butane, isobutane, etc.) are classified as average (medium) reactivity. 

Obstacle Density refers to the presence of obstacles that may enhance 

flame propagation.  Low obstacle density is applicable when there are few 

obstacles in the flames path, or the obstacles are widely spaced (blockage 

ratio [see below] < 10 %) and only 1 or 2 layers of obstacles are present.  

High obstacle density is applicable when there are 3 or more fairly 

closely-spaced layers of obstacles with a blockage ratio of > 40 % per 

layer (e.g., closely-spaced structural members, pipes, valves, and pipe 

racks). Medium obstacle density is that which falls between the low and 

high categories. 

This table assumes that the vapor cloud explosion is initiated from soft 

ignition sources.  Soft ignition sources include open flames, spark, or hot 

surfaces (i.e., sources that do not significantly affect the flame speed).  

The above table would not apply to ignition of highly turbulent jets or to 

high energy ignition sources (i.e., high explosives); the maximum flame 

speed (Mach number 5.2) should be assumed for these situations. 

Blockage ratio is defined as the ratio of the are blocked by obstacles to 

the total cross-sectional area. 
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Explosion Efficiency 

The fraction of material actually consumed if a vapor cloud is ignited.  

The explosion efficiency is normally about 0.10. 

 

Flame Temperature 

The temperature (Kelvin) at which the flame will burn when a vapor 

cloud is ignited.  Typical values are 2000°K to 2500°K. 

 

Number of Carbon Atoms 

This is the number of carbon atoms in a single molecule of the species. If 

-1 is entered, CHARM ignores this material as being flammable for liquid 

pool fires.  

 

Number of Hydrogen Atoms 

The number of hydrogen atoms in a single molecule of the species. 
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Number of Oxygen Atoms 

The number of oxygen atoms in a single molecule of the species. 

 

Number of Halogen Atoms 

The number of halogen atoms in a single molecule of the species. 

 

Halogen Atoms Being Chlorine 

This field indicates whether the halogen atoms are chlorine.  If the 

halogen atoms are chlorine, an emission rate of phosgene gas will be 

calculated for the burn.  The phosgene emission rate and concentration 

are reported in the Source/Puff Calculation display. These values can be 

used in a separate run. 
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Editing the Chemical Database 

Use the Chemical Database command on the Edit menu of the 

CHARMED window to edit the chemical database.  You can add a 

chemical and its data, change a chemical name, modify the chemical 

data, or logically/physically delete a chemical.  You can also edit the 

Emergency Response Text for the selected chemical.  On-line help is 

available for each CHARMED window and input field to guide you 

through entering the appropriate information. 

Adding a Chemical to the Database 

Use the Add command button in the Chemical Selection window to add 

new chemicals to the database.   

To add a chemical species: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Chemical Database command on the Edit menu.  The 

Chemical Selection window is displayed. 

3. Select the Add command button.  A dialog box requesting the name 

of the chemical is displayed. 

 

4. Type the name of the chemical to add and select OK or press 

<Enter>.  The Chemical Editor window is displayed. 
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5. Enter the requested data for the chemical. 

To do this, place the highlight bar over the desired field, and double-

click the mouse or press <Enter>.  Then type the appropriate value in 

the dialog box, and select OK or press <Enter> to close the dialog 

box. 

6. Select Save and then Close from the File menu to save the addition.  

The Chemical Selection window is again displayed. 

Changing a Chemical Name 

Use the Change Name command button in the Chemical Selection 

window to change the name of a chemical species in the database.  The 

dialog box for changing a chemical name is the same as the dialog box 

for adding a new chemical. 

To change the name of a chemical: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Chemical Database command on the Edit menu.  The 

Chemical Selection window is displayed. 

3. Place the highlight bar over the name of the chemical in the list to 

change.  You can use the scroll or search function to locate the 

chemical name. 

4. Select the Change Name command button.  A dialog box requesting 

the new name is displayed. 

 

5. Type the new chemical name, and select OK or press <Enter>.  The 

Chemical Selection window is again displayed. 

Modifying Chemical Data 

Use the Modify command button in the Chemical Selection window to 

modify chemical data and emergency response text stored in the 
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database.  The chemical data window is shown in Figures 4.4,  4.5, and 

4.6 earlier in this chapter. 

To modify the data for a chemical: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Chemical Database command on the Edit menu.  The 

Chemical Selection window is displayed. 

3. Place the highlight bar over the name of the chemical in the list.  You 

can use the scroll or search function to locate the chemical name. 

4. Double-click the left mouse button or select the Modify command 

button.  The Chemical Editor window is displayed with data for the 

selected chemical. 

5. Move the highlight bar over the field you want to modify and select it.  

A dialog box showing the current value is displayed. 

6. Change the value in the dialog box.   

7. Select OK or press <Enter> to close the dialog box. 

8. If you want to edit the emergency response information for a 

chemical, select the Emergency Response Text command from the 

File menu while the chemical data are displayed.  The text editor 

window is displayed and you can change the text. Select Save and 

Close from the File menu to return to the Chemical Editor window. 

9. Select Save and Close from the File menu of the Chemical Editor 

window to save the changes.  The Chemical Selection window is 

displayed. 

Modifying Emergency Response Text 

Use the Emergency Response Text command on the File menu of the 

Chemical Editor window to display the text editor window.  Emergency 

response text is provided for each chemical species in the database.  You 

can add, delete, or modify this information using the text editor. 
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The text editor is similar to the Windows Notepad.  Use the Print 

command from the File menu to print all the text in a window.  To return 

to the Chemical Editor window, select the Save and Close commands 

from the File Menu.  Use the Edit menu to undo the most recent action, 

cut and paste text, clear selected text, and select all text in the file.  

Unlike other windows in the application, the File menu has no New, 

Open, or Save commands, because the file being edited is known and 

specific to CHARM. 

The Emergency Response Text command and the Site Information 

command use the same text editor.  However, the methods for saving 

emergency response text and site information text are different.  If you 

use the Save command on the File menu of the Emergency Response 

Text window, the text changes are flagged.  The changes are not saved 

until you select the Exit command on the File menu of the Chemical 

Editor window. 

To edit the Emergency Response Text: 

1. Run the CHARM editor by selecting the CHARMED.EXE file.  The 

CHARMED window is displayed. 

2. Select the Chemical Database command on the Edit menu of the 

CHARMED window. 

3. Place the highlight bar over the name of the chemical whose 

information you want to change.  You can use the scroll or search 
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function to locate the chemical name. 

4. Select the Modify command button.  The Chemical Editor window is 

displayed. 

5. Select Emergency Response Text from the File menu.  The text editor 

window is displayed. 

6. Modify the Emergency Response Text as needed.   You can enter a 

maximum of 32,000 characters of information.  

7. Select Save and Close from the File menu of the text editor window. 

8.  Select Save and Close from the File menu of the Chemical Editor to 

save the changes.  The Chemical Selection window is displayed. 

Deleting a Chemical 

Use the Delete command button on the Chemical Selection window to 

logically delete a chemical.  Deleting a chemical does not actually remove 

the data from the database; it simply flags the data in the database and 

does not display the chemical name in CHARM selection lists.  To 

physically remove the data from the database, delete the chemical and 

then run the Pack Database command. 

To delete a chemical: 

1. Run the CHARM editor by selecting the CHARMED.EXE file.  The 

CHARMED window is displayed. 

2. Select the Chemical Database command on the Edit menu of the 

CHARMED window.  The Chemical Selection window is displayed. 

3. Place the highlight bar over the chemical name in the list and select 

the name.  You can use the scroll or search function to locate the 

chemical name. 

4. Select the Delete button.  CHARM will prompt the user to verify 

deletion of the desired chemical. 

 

If you inadvertently delete a chemical from the database with the 

Delete command button, you can retrieve the data by adding the 
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chemical.  Use the Add command button in the Chemical Selection 

window and enter the chemical name.  CHARMED displays the chemical 

data for that chemical as they appeared before the delete operation.  In 

fact, any chemical that was logically deleted using the Delete button from 

the Chemical Selection window can be retrieved simply by adding 

chemicals back into the database.  The rule that CHARM follows is 

simply this:  The last chemical that was logically deleted from the 

Chemical Selection window is the data which is used as the default data 

when a chemical is added. 

Packing the Chemical Database 

Packing the chemical database actually removes from the database all 

records that have been previously deleted.  Figure 4.6 shows the 

confirmation window for packing the chemical database. 

To pack the database: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Pack Chemical Database command on the Edit menu of 

the CHARMED window.  CHARMED displays a dialog box that asks 

you to confirm the deletion. 

 

3. To confirm the deletion, select the Yes command button or press 

<Enter>.  All deleted records are removed from the database and the 

CHARMED window is displayed. 

To cancel the deletion, select the No command button.  No changes 

are made to the database and the CHARMED window is displayed. 

Entering Site Information 

Use the Site Information command on the Edit menu of the CHARMED 

window to enter and edit site-specific information such as names and 

telephone numbers.  This information can be displayed while you are 

running CHARM.  Figure 4.8 shows an example of a site information 
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text editor window. 

 

The Site Information command and the Emergency Response Text 

command use the same text editor.  However, the method by which the 

information is saved is different.  Site information is saved when you 

select Save and Close from the File menu of the text editor window.  If 

you select Exit from the File menu after making changes to the text, 

CHARMED will prompt you to save the changes, and then proceed to exit 

the CHARM Editor.  Conversely, emergency response text is not saved 

until you select Save and Close from the Chemical Editor Window (See 

‘Modifying Emergency Response Text’ previously mentioned in this 

Chapter). 

The text editor is similar to the Windows Notepad.  Use the File menu to 

print all the text in a window, save changes to the text, or close the 

window.  Use the Edit menu to Undo the most recent action, or Copy, 

Cut and Paste text in the file.  Unlike Windows, the File menu has no 

New, Open, or Save commands, because the file being edited is known 

and specific to CHARM. 

When you are running the CHARM program, you can display site 

information for the current release by selecting the Site Information 

command on the Displays menu of the Main CHARM Input Window, or 

any subsequent footprint display. 

To enter site information: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Site Information command on the Edit menu of the 

CHARMED window.  The text editor window is displayed. 

Figure 4.8 
Site 
Information 
Editor 
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3. Enter up to 32,000 characters of site-specific information. 

4. Select Save and Close from the File menu in the text editor to save 

the site information.  The CHARMED window is displayed. 

Setting the Communication Parameters 

Use the Communications Parameters command on the Edit menu of the 

CHARMED window to define the communications port, the polling 

interval, and other configuration items for communication with a 

meteorological tower.  This editor is only useful if the CHARM 

meteorological interface program (supplied by Radian) is on the 

computer.  The meteorological  interface program (METINTER.EXE) 

provides the tower-specific interface to CHARM.  Figure 4.9 shows the 

Communications Parameters Editor window. 

 

 

The communications parameters consist of defining and configuring the 

Automatic Met Interface Port, specifying the Met Polling Interval, saving 

Data Daily, and defining station connectivity.  The choices for 

communication ports are COM1, COM2, COM3, and COM4.  One of 

these specifies connection with the meteorological tower.  Accurate port 

specification is required for proper information exchange. Select the Port 

Configuration button to specify additional information, including the 

baud rate, data bits, parity, stop bits, and flow control type for the 

selected communication port. 

Figure 4.9 
Communica-
tions 
Parameters 
Editor 
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The Met Polling Interval defines the frequency with which meteorological 

tower communications take place.  The time interval should be the same 

as the averaging time interval for the data. 

To set the parameters for communication with a meteorological tower: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Local Met Comm Parameters command on the Edit menu 

of the CHARMED window.  The text editor window is displayed. 

3. Specify the communications port (COM1, COM2, COM3, or COM4) to 

use. 

4. Select the Port Configuration button to specify additional port 

configuration information.  Select OK or press <Enter>. 

5. Enter the interval for polling the met tower in minutes. 

6. Check the Save Data Daily checkbox if you want CHARM to archive 

meteorological data from your data logger on a daily basis into a file 

which timestamped with a Julian date.  [NOTE: This feature is strictly 

for archival purposes.  CHARM cannot read these files back into the 

model as a source for meteorological data input.  This feature is simply 

an add-on feature as some data loggers are not capable of archiving 

data.] 

7. Select OK or press <Enter>.  The CHARMED window is displayed. 

Defining Station ID’s 

Select the Station ID button to define multiple station names and means 

of communication (i.e. direct connection with the PC or remote 

connection via modem).  Input up to 30 characters describing a 
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meteorological station to be used by CHARM to acquire real-time met 

data.  Also, type in a phone number that will be used to access the met 

tower remotely if communications between the PC and the datalogger are 

to be connected via dial-up modems.  The phone number is optional.  If 

no phone number is specified, CHARM will assume direct connection 

between the PC and the data logger. 

 

Adding a Station ID 

Upon entering the Station ID and Phone Number (optional), press the 

Add button to enter the Station ID/Phone Number input into the list of 

possible stations.  Currently, the user may define up to 100 stations. 

Deleting a Station ID 

Select the Delete button to delete the highlighted Station ID from the list 

of possible stations.  All associated sites and their information will also 

be deleted.  Select the Delete All button to delete all Station IDs and 

associated Phone Numbers in the list of possible stations.  Again, all 

associated sites and their information will also be deleted. 

Modifying a Station ID 

Select the Change button to change the highlighted Station ID character 

name or associated phone number.  The highlighted information will be 

placed in the Station ID and Phone Number input boxes.  Make the 

appropriate changes and then select the Save Change button.  The 

changes will be reflected in the list of stations. 

Site ID 

Select the Site ID button to define multiple site names associated with 

the highlighted station. 

Defining Site ID’s 

Input up to 30 characters describing a site associated with the 
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specified station. 

 

Adding a Site ID 

Upon entering the Site ID, select Add to enter the Site ID input into the 

list of possible sites.  Currently, the user may define up to 100 sites. 

Deleting a Site ID 

Select the Delete button to delete the highlighted Site ID from the list of 

possible sites.  All associated site information will also be deleted.  Select 

the Delete All button to delete all Site IDs and associated site information 

from the list of possible sites. 

Modifying a Site ID 

Select the Change button to change the highlighted Site ID character 

name.  The highlighted information will be placed in the Site ID input 

boxes.  Make the appropriate changes and then select Save Change.  The 

changes will be reflected in the list of possible sites. 

Specifying Site Information 

Select the Site Information button to display the Cartesian coordinates 

(x,y,z) and some default parameters associated with the highlighted site. 

Defining Site Information 

Define default parameters specific to a site. 
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Defining Site Coordinates 

Input the site location in Cartesian coordinates (x,y,z) and the associated 

units.  Accurate site location relative to the source will ensure proper met 

conditions will be utilized correctly in CHARM. 

Defining Relative Humidity 

Enter the default ambient relative humidity in percent.  Acceptable 

values are greater than 0 and less than 99.  If relative humidity is not 

available to CHARM real-time, CHARM will use this value as the default. 

Defining Ambient Pressure 

Enter the default ambient atmospheric pressure at ground level.  The 

pressure can be entered in atmospheres, pounds/square inch, inches of 

Mercury, millimeters of Mercury, or millibars.  If pressure is not available 

to CHARM real-time, CHARM will use this value as the default. 

Normal atmospheric pressure at sea level has the following equivalents: 

• 1 atmosphere (atm) 

• 14.7 pounds/square inch (psi) 

• 1013.25 millibars (mb) 

• 29.92 inches of Mercury (in Hg) 

• 760 millimeters of Mercury (mm Hg) 

Defining Surface Roughness 

Surface roughness is a measure of the interaction between the wind and 

surface.  It affects wind speed with altitude and thus the amount of 

mixing that can occur.  The units are inches, feet, centimeters, or 

meters.  If the field is left blank, no surface roughness is assumed and 
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the wind is assumed constant with height.  See “Surface Roughness” in 

Chapter 5 “The Main CHARM Input Window” for some examples of 

surface roughness. 

Defining Maps for Use With CHARM 

Use the Map Definition command on the Edit menu of the CHARMED 

window to read a map from the clipboard or a file.  After the map is 

displayed, you must define a scale and location with respect to some 

point of origin.  You can also define release locations and map locations.  

You can define an area to zoom or unzoom, and name a larger-scaled 

map that will replace the current map in CHARM.  You can also 

associate textual information to, perhaps, indicate when the map was 

created, evacuation routes, etc. 

All maps used in CHARM are assumed to be created outside of 

CHARMED but accessible by CHARMED.  The map definition editor can 

read maps from the clipboard, from Windows metafiles, Tagged 

Information File Format (TIFF} files, device independent bitmap (DIB) 

files, or from previously edited and stored files. 

Improved internet browsing and downloading allows you to examine and 

extract map files directly from the internet.  In many cases, you can 

simply download a file into a form that CHARM can read directly.  In 

other instances, however, you may have to read the file into third-party 

software, copy the map to the clipboard, and then paste the image into 

the Map Definition Editor. 

Reading Maps From the Clipboard 

The Map Definition command can be used with other Windows programs 

that create metafiles, picture files, or bitmaps and place them on the 

clipboard.  For example, MicroGrafx Draw Plus, MicroGrafx Designer, 

and Microsoft Windows Paint programs can generate maps for use with 

CHARM.  AutoCAD's DXF (drawing interchange) file formats can be read 

into a program such as Designer or Hijaak, copied to the clipboard, 

and then read into the CHARM map editor.  Refer to the Microsoft 

Windows user's guide for details on sending a drawing to the clipboard. 

When a map has been created and placed on the clipboard, it can be 

accessed and displayed by the Map Definition Editor.  Simply use the 

Paste command from the Edit menu and the map will be displayed. 

Reading Maps From Files 

The Map Definition command can also read previously stored files.  For 

example, the map editor can read files stored in the Micrografx Draw 

Plus or PageMaker format directly instead of reading them through the 
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clipboard.  These files must have the Windows metafile, TIFF, or windows 

bitmap format.  Maps that have been edited and saved in CHARMED can 

also be read again. 

To read a file into the Map Definition Editor, use the Open command on 

the File menu and select the name of the file to display.  The Open 

command works the same in CHARM as in other Windows applications. 

Caution:  When you edit a metafile or TIFF file, be sure to rename the 

edited version when saving the map or the original file will be overwritten.  

Map information, such as scaling and map location, requires CHARM to 

use a different file format. 

The Map Definition Command 

Use the Map Definition command to edit maps for use in CHARM.  After 

a map has been displayed in the Map Definition Editor either by opening 

a file or pasting an image in from the clipboard, you must perform a 

minimum of two operations before the map can be used from within 

CHARM proper.  Select the Define Point command or the Define Scale 

command from the Define menu.  It is irrelevant which operation is 

performed first, but a point of reference and scale must be defined to 

ensure that a footprint is overlayed properly on the map when displayed 

in CHARM proper.  Other options include defining detailed map and 

release location icons, associating textual information with the map, and 

associating an expanded map to use with the Auto Map Change and 

Larger Scale Map options in CHARM.  The map must be saved for recall 

when running CHARM  

While a map is displayed, you can move the cursor with the mouse or the 

keyboard.  To scroll the map, use the mouse and the scroll bars or use 

<Page Up>, <Page Down>, and the arrow keys.  The keys are used to 

move the map until an option from the Define menu is selected.  After a 

define option is selected, the keys move the cursor. 

Figure 4.8 shows a sample map display.  The sample shows three map 

location icons,  

 

which can be selected to display a smaller scaled, or more detailed, 

version of the map area.  Likewise, the sample illustrates three possible 

release sites with release locations icons 
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. 

 

 

The Define Menu 

Use the Define menu in the Map Definition window to define a point and 

scale.  After the Map Definition Editor displays a map from the clipboard 

or a file, you must define a point location and a map scale.  The point 

and scale together identify the point of origin.  The origin should be the 

same for all maps that you intend to use with the Zoom or Automap 

functions.  You can also use the Define menu to define zoom area, 

detailed map location, release location, map description, default size, 

and/or an expanded map name. 

Using the Zoom Command 

Use the Zoom command on the Define menu to define an area (zoom box) 

on the displayed map for enlargement.  Notice that the cursor is 

transformed to a magnifying glass.  The size of the zoom box determines 

the degree of zoom.  The upper left corner of the box is used to determine 

the region that will be displayed.  There may not be a one-to-one 

correspondence between the box and the displayed zoom area since the 

x,y aspect is maintained.  To return a zoomed map to its original size 

when the window was opened, use the Unzoom command on the Define 

menu. 

After you decide on the area to zoom in on, follow these steps: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The 

Figure 4.8 
Map Definition 
Editor 
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CHARMED window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The map editor window is displayed.   

Use the Open command on the File menu or use the Paste command 

on the Edit menu to select and display a map. 

3. While the map is displayed, select the Zoom command on the Define 

menu. 

4. Move the cursor to the location of one corner of the area to be 

zoomed.  This location represents one corner of the zoom box. 

5. Define the zoom box by creating a rubberband box around the 

intended area to zoom.  This can be done by using the mouse, or by 

using keyboard strokes. 

If you are using a mouse, hold the left mouse button down, drag the 

cursor to the opposite corner of the box, and release the button.   

If you are not using a mouse, press <Enter> to define the first corner 

of the zoom box.  Next, use the arrow keys to draw the zoom box, and 

press <Enter> again to complete the drawing. 

To return the map to its initial size when the window was opened, select 

the Unzoom command on the Define menu. 

Defining a Point 

Use the Define Point command on the Define menu to define a point of 

reference for a map.  Notice that the cursor is transformed to an axial 

representation of a 3D coordinate system.  You must define a point and 

scale for each map you use.  To ensure proper placement of the plume on 

the map, the origin should be the same for all related maps.  You can 

redefine the point location by repeating the steps for defining a point. 

Defining a point involves identifying the location for the point on the 

displayed map and specifying the X and Y coordinates for the point.  

Use the following steps to define a point: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 
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CHARMED window.  The Map Definition window is displayed.   

Use the Open command on the File menu or use the Paste command 

on the Edit menu to select and display a map. 

3. While a map is displayed, select the Define Point command on the 

Define menu. 

4. Move the cursor to the location for the point on the map. 

If you are using a mouse, click the left button to identify the point 

location. 

If you are not using a mouse, press <Enter> to identify the point 

location.   CHARMED prompts the user for the point of reference. 

 

5. Enter the X and Y coordinates for the point in the dialog box.  The 

units are feet, miles, kilometers, or meters.  A positive (+) X number 

is East of the origin and a negative (-) X number is West.  A positive Y 

number is North of the origin and a negative Y number is South. 

6. Select the OK command button or press <Enter>. 

Defining a Scale 

Use the Define Scale command on the Define menu to define a map 

scale.  Notice that the cursor is transformed into a scale pointer.  

CHARM uses this scale to automatically expand or contract the map 

when a plume is displayed.  You must define a point and scale for each 

map you use.  You should use the measurement between two known 

points, which are preferably as far apart as possible. 

A scale definition involves drawing a line on the displayed map and 

specifying the length of the line.  After the line is drawn, CHARMED 

prompts the user to specify the line length. 
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Use the following steps to define a scale: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The Map Definition window is displayed.   

Use the Open command on the File menu or use the Paste command 

on the Edit menu to select and display a map. 

3. While a map is displayed, select the Define Scale command on the 

Define menu. 

4. Draw a line between two points on the map. 

To draw the line with a mouse, move the cursor to the beginning 

point for the line.  Press and hold the left mouse button,  drag the 

cursor to the end point of the line, and then release the button.   

To draw the line with the keyboard, move the cursor to the beginning 

point for the line.  Press <Enter> to mark the beginning point of the 

line, extend the line with the arrow keys, and press <Enter> again to 

mark the end point of the line.   CHARMED prompts the user for the 

length of the line. 

NOTE: Bitmaps only allow a horizontal line to be drawn.  Vector maps 

allows the user to draw the line at any angle. 

 

5. Enter the length of the line in the dialog box.  The units are feet, 

miles, kilometers, or meters.  Alternatively, if latitude/longitude 

coordinates are known at the line endpoints, you may enter those 

coordinates by selecting the Lat/Long button. 
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6. Select the OK command button or press <Enter>.  CHARMED returns 

to the Scale Length dialog box.  Select the OK command button or 

press <Enter>.  CHARMED returns to the Map Definition window. 

Defining a Map Location 

Use the Define a Map Location command to define and edit the location 

of an icon that represents another map.  The icon looks like boxes within 

boxes on the map. 

 

Notice that the cursor is transformed to a representation of this icon.  

The map is a smaller-scaled map to be used with the zoom feature in 

CHARM.  Defining a map location involves positioning the icon on the 

map and specifying the name of the map to be displayed when the icon is 

selected in CHARM. 

Use the following steps to define a map location: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The Map Definition window is displayed.   

Paste an image from Windows clipboard, or use the Open command 

on the File menu to select and display a map. 

3. While a map is displayed, select the Define Map Location 
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command on the Define menu. 

4. Move the cursor to the point at which you want to place the icon on 

the displayed map.   

If you are using a mouse, press the left or right mouse button to 

locate the icon.  If you are not using a mouse, press <Enter> to locate 

the icon.  CHARMED prompts the user for complete path and file 

name of the associated map file. 

 

5. In the dialog box, enter the file name for the map that is represented 

by the icon.  Include the full path name, including the drive, so that 

the file can be located  anywhere in the system.  Alternative, use the 

Browse button to scan and select the desired map file.   

6. Select the OK command button or press <Enter>.  CHARMED returns 

to the Map Definition window. 

Defining a Release Location 

Use the Define Release Location command on the Define menu define 

and edit the location of an icon that represents the location of one or 

more release scenarios.  The icon looks like a plume within a box. 

 

The release scenarios must be created and stored in CHARM using the 

Main CHARM Input Window.  Defining a release location involves 

positioning the icon and specifying the scenarios whose titles will be 

displayed when the icon is selected in CHARM. 

To define a release location, use the following steps: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 
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2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The Map Definition window is displayed.   

Paste an image from Windows clipboard, or use the Open command 

on the File menu to select and display a map. 

3. While a map is displayed, select the Define Map Location command 

on the Define menu. 

4. Move the cursor to the point at which you want to place the icon.   

If you are using a mouse, press the left or right mouse button to 

locate the icon.   

If you are not using a mouse, press <Enter> to locate the icon.  

 

5. In the dialog box, enter the file name(s) for the release  represented 

by the icon.  Include the full path name, so that the file can be 

located anywhere in the system.  If you want to specify more than one 

release, separate the file names by commas.  The Browse button may 

be used to examine and select files currently stored on your system.  

DOS wildcards can be used in file names. 

6. Select the OK command button or press <Enter>. 

Once a map or release location is defined, you can edit the file 

information for an icon, reposition an icon, or delete an icon.   

Map Description 

Use the Map Description command on the Define menu and CHARMED 

displays a text window from which the user may describe pertinent 

information associated with a map.  For example, the user may identify 

the sensitive receptors that exist beyond the fenceline.  The description 

may be viewed from CHARM when the map is displayed.   

The Map Description command, Emergency Response Text command, 

and Site Information command all use the same text editor.  However, 

the method by which the information is saved is different.  Site 

information and Map Definition information is saved when you select 
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Save and Close from the File menu of the text editor window.  If you 

select Exit from the File menu after making changes to the text, 

CHARMED will prompt you to save the changes, and then proceed to exit 

the CHARM Editor.  Conversely, even though you may have saved Map 

Description text, the Map Description text is not really saved until you 

select Save and Close from the Map Definition Window. 

To use the Map Description command, use the following steps: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The Map Definition window is displayed.   

Paste an image from Windows clipboard, or use the Open command 

on the File menu to select and display a map. 

3. While a map is displayed, select the Map Description command on 

the Define menu.  The following window is displayed. 

 

4. In the Map Description text window, input or modify text that is 

pertinent to information associated with the map.  Use selections 

from the Edit menu to copy, cut, or paste information from other 

Window’s applications. 

5. Select Save and Close from the File menu of the text editor window to 

save the information.  Selecting Exit from the file menu closes 

CHARMED. 

Editing Icon File Information 

The file information for an existing map or release icon can be edited.  If 

you are using a mouse, move the cursor over the icon and double-click 

the left mouse button.  If you are using the keyboard, select the Define 

Map Location or Define Release Location command to allow the cursor 

to move the desired icon.  Then, position the cursor over the icon and 
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press <Enter> (or click the left mouse button).  A dialog box containing 

the current file information is displayed.  Make the necessary changes 

and select OK or press <Enter>. 

Use the following steps to edit the file information for a map or release 

location icon: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The map editor window is displayed.   

Use the Open command on the File menu to select and display a 

map. 

3. Using the mouse, you can move the cursor over the icon and double-

click the left mouse button; or, select the desired type of icon to edit 

from the Define menu, move the cursor over the desired icon and 

click the left mouse button. 

If you are using the keyboard, you must select the Define Map 

Location or Define Release Location command on the Define menu 

before you can move the cursor over the icon.  When the cursor is 

over the icon, press <Enter> to select it. 

A dialog box containing the file information is displayed. 

4. Edit the file information and select OK or press <Enter>. 

Repositioning an Icon 

You can relocate an existing map or release icon.  If you are using a 

mouse, move the cursor over the icon, hold the left mouse button down, 

drag the mouse to reposition the icon, and release the left mouse button.  

If you are using only the keyboard, you cannot simply move the icon.  

You must delete the icon and then redefine the icon using the Define 

Map Location or Define Release Location commands. 

Use the following steps to relocate a map or release location icon: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The 

CHARMED window is displayed. 
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2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The map editor window is displayed.   

Use the Open command on the File menu to select and display a 

map. 

3. To move the icon with the mouse, position the cursor over the desired 

icon, press the left mouse button and reposition the icon by dragging 

it.  Then, release the mouse button. 

Deleting an Icon 

To delete an icon, move the cursor over the icon and press the Delete 

key.  Select Yes in the dialog box to confirm the deletion. 

Use the following steps to delete a map or release location icon: 

1. While the map containing the icon is displayed, move the cursor over 

the icon and press <Delete>.  CHARMED will verify the deletion. 

 

2. Select Yes in the dialog box or press <Enter> to confirm the deletion. 

Naming an Expand Map 

Use the Expand Map Name command on the Define menu to specify the 

name of a larger-scaled map than the one being defined.  Figure 4.9 

shows the window in which to enter the map name.  The specified map is 

displayed automatically by CHARM if the Auto Map Scale option is 

checked and the currently displayed map covers a percentage of the 

footprint display area which is less than the percentage defined by the 

Auto Map Fraction.  The rectangular area used for comparison is the 

area in which the viewport circle is inscribed.  If the current map covers 

less than the Auto Map Fraction of the rectangular area, CHARM will 

attempt to display a larger scaled map, if one has been defined.  The 

value must be between 0.05 and 0.95.  The default is 0.25. 

The Auto Map Scale and Auto Map Fraction options are on the Options 

menu of a Plan Display window in CHARM proper. 

Figure 4.9 
Expand Map 
Window 
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To name an expanded map: 

1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Map Definition command on the Edit menu of the 

CHARMED window.  The Map Definition window is displayed.   

Paste an image from Windows clipboard, or use the Open command 

on the File menu to select and display a map. 

3. Select the Define Expand Map Name on the Define menu. 

4. Enter the full path name for the expanded map, or use the Browse 

button to display files on your disk for selection. 

5. Select OK or press <Enter>.  The map editor window is displayed. 

Saving a Map Definition 

Once you edit a map with the map definition editor, you must store it as 

a file for later retrieval.  To save a map definition, use the Save or Save 

As commands on the File menu.  The Save and Save As commands work 

the same in CHARM as in other Windows applications.   

You can enter a base name and allow CHARMED to assign the default 

extension.  CHARM uses specific extensions to identify files for selection 

list displays.  If you do not assign an extension to the file name, 

CHARMED automatically assigns the default .MAP extension to the base 

name.  When you save a map definition, another file is created with the 

same base name but with the .MFD extension.  This file contains the 

map definition information. 

Caution:  Since files with the .MFD extension contain the map definition 

information, this extension should not be used for other CHARM file 

names.  Also, a file with the .MFD extension must not be deleted, unless 
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its corresponding map is also deleted. 

If you want a base map to display automatically when the CHARM 

program is started, assign the file name BASEMAP.MAP (and the 

associated BASEMAP.MFD file ) to one of the maps you define.  This 

feature is especially useful for running CHARM in the emergency 

response mode.  When CHARM is started, if no file named 

BASEMAP.MAP is found, the main input window displays.   

For maps from the clipboard, you must assign a base name to the edited 

map.   For maps from files, you should assign a new and unique base 

name to the edited map.  If you use the same base name, the original file 

will be overwritten, thereby destroying the original metafile, TIFF, or 

bitmap file.   

Defining Population Files for Use With CHARM 

Use the Select Population Files command on the Edit menu of the 

CHARMED window to identify one or more population files which will be 

used to determine the approximate number of people impacted by a 

footprint.  The population file is created from Radian’s TIGERMAP Utility 

in the CHARM group. 

 

The program reads U.S. Census Bureau Tiger/Line
(TM)

 1992 data and 

creates maps and/or population files.  An icon for starting TIGERMAP is 

in the CHARM group box.  Tiger/Line
(TM)

 1992 data (available on CD-

ROM) is required before the population files can be created.  Contact the 

U.S. Census Bureau directly for ordering the data files needed.  Their 

number is (301) 457-4100. 

Multiple files can be entered.  If a full path name is given to a file, the 

subsequent files are assumed to be in the same subdirectory until the 

next full path name is given.  Wild cards may be used.  If no extension is 

given (including no ‘.’ at the end of the file name) on a file, then the 

default extension (normally .TPY) will be used.  If you want to select pre-

existing files press the Browse button.  A window allowing the multiple 

selection of files will appear.  Any files selected will be appended to the 

existing list. 

To define population files use the following steps: 
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1. Run the CHARM editor by selecting the CHARMED icon from the 

CHARM group or by executing the CHARMED.EXE file from the 

Windows Explorer or My Computer on the desktop.  The CHARMED 

window is displayed. 

2. Select the Select Population Files command on the Edit menu of the 

CHARMED window. 

3. In the dialog box, enter the file name(s) for those desired population 

files. 

Include the full path name, so that the file can be located anywhere 

in the system.  If you want to specify more than one release, separate 

the file names by commas.  The Browse button may be used to 

examine and select files currently stored on you system.  DOS 

wildcards can be used in the file names. 

4. Select the OK command button or press <Enter>. 

Inputting Data for Mixtures into the Chemical Database 

CHARM is capable of modeling only a single substance at a time, 

independent of whether the substance is pure or suspended in a 

mixture.  If a substance is a constituent within a mixture, there are three 

ways to model this from within CHARM. 

1) The best approach for handling a mixture is to add a new chemical to 

the CHARM Chemical Database which contains the bulk properties of the 

liquid and the bulk gas properties of the mixture.  The boiling point of 

the mixture is defined when the sum of all of the partial pressures of the 

constituents of the mixture equals one atmosphere.  For CHARM to 

report the concentration of the constituent of interest, set the Reported 

Fraction field to the molar fraction of the constituent in the mixture. For 

example, if 20% of the emission were species A and 40% species B, two 

chemicals could be added to the database.  All the parameters would be 

the same for the two species except the name and the Reported Fraction 

parameter.  For species A to be reported correctly this parameter should 

be 0.20. For species B it should be 0.40. Most species will define the 

Reported Fraction as 1.0.  If it is set to zero it is assumed to be 1.0. 

 

2) The next best approach is to add a new chemical to the CHARM 

Chemical Database that contains the bulk properties of the liquid and 

the gas properties of the species in equilibrium with the liquid 

mixture.  The critical values, triple point values, and the boiling point 
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should be representative of the vapor pressure curve of the constituent of 

interest in equilibrium with the liquid mixture.  The Reported Fraction 

field should be set to 1.0. 

3) The last method for handling mixtures in a liquid release is to use the 

data for the pure species and the CHARM model.  Simply enter a 

"pseudo" pool diameter in the Pool/Lagoon release type by making the 

size of the pool proportionate to the percentage of constituent within the 

mixture.  Use the emission rate from that CHARM calculation (see 

Source/Puff Calculation Display in CHARM) as input in the User 

Specified After-Release type.  The puff diameter should be set to the 

actual pool size, not the pseudo pool size.  The molar fraction of the 

constituent of interest in the gas state in equilibrium with the pool 

mixture should be subtracted from 1.0 and the result entered in the 

molar air fraction field (i.e. all other constituents will be assumed to be 

air).  This method allows you to specify the initial concentration as well 

as the emission rate.
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Chapter 5:  The Main CHARM Input Window 

The Main CHARM Input Window provides the data that CHARM needs to 

simulate a chemical release.  When you initially run the CHARM.EXE 

program, the Main CHARM Input Window is displayed, unless there is a 

stored map file with the name BASEMAP.MAP.  In the planning mode, 

CHARM uses the input window to solicit release and meteorological data. 

If a map file has been defined using the CHARM Editor and stored with 

the BASEMAP.MAP name, the map is displayed when CHARM is started. 

The Main CHARM Input Window will still be present, but behind the Map 

Window.  It can be made active by selecting the Input Window from the 

Window menu. 

Note:  The purpose of the BASEMAP.MAP file is to save time when using 

CHARM in the emergency response mode as described in Chapter 7, 

"Using CHARM for Emergency Response." 

CHARM input consists of the release description in the top portion of 

the window and the meteorological data in the lower portion.  Figures 

5.1 and 5.2 show the release description portion of the window and 

Figure 5.3 shows the meteorological data portion. 
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Figure 5.1 
Main CHARM 
Input Window 
(top) 

Figure 5.2 
Main CHARM 
Input Window 
(middle) 

Figure 5.3 
Main CHARM 
Input Window 
(bottom) 
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The Main CHARM Input Window guides you through the data fields that 

describe the toxicity of the release and the conditions under which the 

chemical species will disperse.  Many of the input fields require an entry 

in order for CHARM to simulate the release.  CHARM provides default 

values for the input fields that you can accept or change.  If you leave a 

required field blank and try to close the dialog box, CHARM displays a 

message saying the field requires an entry.   

The release description fields that appear in the input window vary 

according to the selected species and release type.  Some of the fields in 

the input window contain default values.  CHARM uses the data entered 

in the input window to calculate and predict 1) the dispersion, 

concentration, and movement of the plume; 2) thermal radiation from a 

jet fire, liquid pool fire, or boiling liquid expanding vapor explosion 

(BLEVE); and/or 3) mechanical/explosion overpressures. 

Each release that is described in the input window and simulated in a 

CHARM run is called a scenario.  To create a scenario, CHARM 

determines the number of puffs in a release and the initial characteristics 

of each puff.  CHARM creates a variety of displays, such as the Snapshot 

Plan Plume View, based on the information entered in the input window.  

Whether you are using CHARM for emergency planning or emergency 

response, each scenario can be saved for later retrieval. 

Scrolling the Input Window 

To view the contents of the entire window, the CHARM input screen can 

be scrolled with a mouse or the keyboard.  To scroll with a mouse, use 

the vertical scroll bar to scroll up or down, and the horizontal scroll bar 

to scroll right or left.  With a mouse, you can scroll one line at a time, 

one window full of information, or to a relative location.  Refer to the 

Windows User's Guide for more details on scrolling with a mouse.  To 

scroll with the keyboard, move the inverse video bar to the next item off 

the screen, press an arrow key until the screen moves, or use <Page Up> 

and <Page Down>. 

Selecting an Input Field 

To select a field with the mouse, move the cursor over the field and 

double-click the left or right mouse button.  To select a field with the 

keyboard, use the arrow keys to move the inverse video bar to the field 

and press the Enter key.   
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When you select a field, CHARM displays a dialog box in which you enter 

the requested information.  On-line help is available from within the 

dialog box for each field. 

Modifying CHARM Input 

To change the values for any of the data fields in the Main CHARM Input 

Window, use the following steps: 

1. Move the inverse video bar to the desired field. 

To move the bar with the mouse, position the cursor over the field 

and click the left mouse button.    

To move the bar with the keyboard, use the arrow keys to position 

the bar over the field. 

2. Select the field. 

To select the field with the mouse, double-click the left mouse button 

while the bar is over the field.   

To select the field with the keyboard, press <Enter> while the bar is 

over the field.  

3. Make the necessary changes to the value(s) in the dialog box. 

To display the on-line help that provides additional information for 

the requested data, select the Help command button in the dialog 

box. 

4. Select OK to return to the Main CHARM Input Window.  

Alternatively, the user has the option of viewing the input data in a folder 

format.  For more information on inputting the release scenario and 

meteorological data in this form, see the Option Menu description under 

Main CHARM Input Window Menus later in this Chapter. 
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Main CHARM Input Window Menus 

The File, Edit, View, Window, and Help menus on the Main CHARM 

Input Window include the standard Windows commands plus some 

additional commands.  The Options, MetFile, and Displays menus are 

exclusive to the CHARM program.  Only those menu commands that are 

appropriate for the current release description are available for selection. 

View Menu 

Use the Status Bar command to display and hide the Status Bar, which 

describes the action to be executed by the selected menu item, and 

keyboard latch state.  A check mark appears next to the menu item when 

the Status Bar is displayed. 

Window Menu 

The Window menu offers the following commands, which enable you to 

arrange multiple views of multiple windows in the application window: 

COMMAND SUMMARY 

Cascade Arranges windows in an 

overlapped fashion. 

Tile Arranges windows in non-

overlapped tiles. 

Arrange Icons Arranges icons of closed 

windows. 

Window 1, 2, ... Goes to specified window. 

 

Help Menu 

The Help menu offers the following commands, which provide you 

assistance with this application: 

COMMAND SUMMARY 

Help Offers you help on the current 

task or command. 

Index Provides general instructions 

on using help. 
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Using Help Offers you an index to topics on 

which you can get help. 

Search for Help on Displays a list of keywords used 

in CHARM from which a list of 

related topics may be. 

About Displays the version number 

and copyright notice for 

CHARM. 

 

File Menu 

The File menu on the Main CHARM Input Window provides the standard 

Windows file commands for creating, opening, saving, renaming, 

printing, and exiting CHARM.  The CHARM File menu also provides a 

command for selecting a previously stored scenario. 

The File menu of the Main CHARM Input Window has the following 

commands: 

 

COMMAND SUMMARY 

New Restores all the fields on the Main 

CHARM Input Window to their 

initial values when the CHARM 

program began.  These default 

values may be changed via the 

CHARM.INI file (see CHAPTER 3: 

CHARM.INI File Description) or by 

selecting Save As Default under the 

File menu (see Save As Default 

command description below). 

Open Displays a dialog box requesting the 

name of an input file to open.  The 

dialog box contains a selection list of 

the drives and any file names that 

match the file specification.  The 

default extension is .EMG, which 

may be changed via the CHARM.INI 

file (see Chapter 3: CHARM.INI File 

Description). 
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Scenarios Displays a selection list of release 

scenario titles stored previously in 

CHARM with the .EMG default file 

name extension or other file name  

that matches the currently specified 

extension.   To create the list, 

CHARM first searches the directory 

specified for emergency response 

files in the File Location Editor of 

CHARMED.  CHARM displays the 

selected scenario.  For more 

information on this menu item, see 

the  “Scenarios Command” topic 

below.   

Save Saves the input data from the Main 

CHARM Input Window.  If no file 

name has been assigned, a dialog 

box is displayed in which you enter 

a file name. 

Save As Displays a dialog box in which you 

can enter the name of the file being 

saved.  

Save As 

Default 

Automatically saves the current 

scenario described in the CHARM 

Input Window as the default 

scenario stored in a file labeled 

CHRMDFLT.EMG;  that is, upon 

first entering CHARM or selecting 

New from the File menu, the 

parameters stored in CHRMDFLT 

file are displayed. 

Print Print the entire contents of a 

window 

Print 

Preview 

Display the window contents on the 

screen as it would appear printed. 

Printer Allows the user to change the 

current printer configuration and 

connection. 
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Exit Exit the CHARM MDI.  All windows 

are closed and exit the CHARM 

program. 

 

New Command 

The New command on the File menu restores all the fields on the Main 

Input Window to their initial values when the CHARM program began.  If 

any   modifications were made to the current scenario and the current 

scenario has not yet been saved, CHARM will prompt the user to save 

changes before resetting the release input parameters back to the default 

values.  These default values may be changed via changing the CHARM 

initialization file CHARM.INI (see CHAPTER 3: CHARM.INI File 

Description) or by simply selecting the Save As Default command from 

the file menu. 

Open File Command 

The Open command on the File menu displays a dialog box requesting 

the name of an input file to open. 

 
 

The dialog box contains a selection list of the drives and any file names 

that match the file specification.  The default extension is .EMG, which 

may be changed via the CHARM.INI file (see Chapter 3: CHARM.INI File 

Description).  Alternatively, the default extension may be changed by 

simply specifying a new extension in the Open or Save dialog boxes. 

Scenarios Command 

The Scenarios command on the File menu displays a selection list of the 

run titles for release scenarios that have been previously stored.  Unless 

you specify a different extension, release scenario files are assigned the 
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default .EMG file name extension by CHARM.  The default may be 

changed via the CHARM.INI file (see Chapter 3: CHARM.INI File 

Description). 

 

When you select a title, CHARM displays the input window containing 

the data for that scenario.  Multiple selections, one after the other, may 

be required to completely select the desired scenario.  The number of 

selections depends on the setup and location of the .IND and .EMG files.  

The first subdirectory in which CHARM searches for .EMG and .IND files 

is the directory specified for the emergency response files in the File 

Location editor of CHARMED.  CHARM displays lists until you make the 

last level of selections.  Then, CHARM displays the input window for the 

scenario described in the selected .EMG file.  You can move back and 

forth through the scenarios as desired. 

IND File 

A file containing subdirectory information that CHARM uses to locate 

.EMG files in the emergency response mode.  Files with .IND extensions 

are created by the user with a text editor.  Using the combination of .IND 

file and .EMG files allows the user to organize prestored data files by 

geography, chemical species, etc.  IND files are strictly used with the 

Scenarios command under the file menu in CHARM proper. 

Steps for using IND Files: 

1) The user must define the location of the initial .IND file under File 

Locations in the CHARM editor (CHARMED). 

2) From File Manager or Windows Explorer, create subdirectories which 

layout, for example, geographical aspects of possible release sites. 
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3) From Notepad or some other text editor, create a file with the .IND 

extension and format the file as follows: 

LINE          TEXT 

1 Subdirectory Name. 

2 Description of information associated with subdirectory name. 

3 Subdirectory Name. 

4 Description of information associated with subdirectory name. 

5 Subdirectory Name. 

6 Description of information associated with subdirectory name. 

etc... 

Example IND File 

The EXAMPLE.IND would read as follows and reside in the 

C:\CHARM\PLANT subdirectory: 

EAST 

Release occurred in east side of plant 

NORTH 

Release occurred in north side of plant 

SOUTH 

Release occurred in south side of plant 

WEST 

Release occurred in west side of plant 

 

NOTE: The above file should reside in the initial Emergency Response file 

location defined by the CHARM editor (CHARMED).  NO prestored data 

files (.EMG) should reside in the same directory as .IND files.  CHARM 

attempts to locate EMG files first.  If EMG files are located and read, no 

attempt is made to locate IND files. 

4) Repeat Step 3 for all directories. 

Save/Save As Commands 
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The Save command will save the current release description information 

into the currently opened file.  If no current file is defined, then invoking 

the Save command will invoke the Save As command and display a 

dialog box requesting the name of an input file to save the currently 

defined release scenario. 

 
 

Print Preview Command 

The Print Preview command on the File menu displays a dialog box 

illustrating how the information displayed from the Main Input Window 

will be printed.  The user has options to zoom in or out, display the next 

page of information, print the existing data, or close the preview and 

return to the CHARM Main Input   Window. 

 

 
 

Print Setup Command 
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The Print Setup command on the File menu displays a dialog box 

requesting printer configuration information.  The user has options to 

specify the desired printer, portrait or landscape orientation, and paper 

size and source.  Other options may also be available. 

 

 
 

Edit Menu 

The Edit menu of the Main CHARM Input Window has only one 

command.  Use the Copy command to send text from the input window 

to the Windows clipboard where it can be retrieved by other programs.  

All text in the window, visible or not, is sent to the clipboard.   

MetFile Menu 

Use the Metfile menu of the Main CHARM Input Window to create, open, 

save, and rename files containing meteorological data.  These commands 

are similar to the standard Windows functions.  If you are set up to 

receive automatic information from a meteorological tower, the Metfile 

menu also provides the Automatic Poll command. 

The Metfile menu includes the following commands: 

COMMAND SUMMARY 
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New Restores all met data to the values 

that existed when the program 

began.  These default values may be 

changed via the CHARM.INI file (see 

Chapter 3: CHARM.INI File 

Description) or by selecting the Save 

As Default command under the 

MetFile menu. 
 

Open Displays a dialog box requesting the 

name of a met file to open.  The 

dialog box contains a selection list of 

the drives and any file names 

matching the file specification.  The 

default extension is .MET, which 

may be changed via the CHARM.INI 

file (see Chapter 3: CHARM .INI File 

Description). 

Save Saves the met data.  If no file name 

has been assigned, a dialog box is 

displayed in which you enter the file 

name.  You can enter a base 

extension name for the file and allow 

CHARM to assign the extension, or 

you can assign the entire name. 

Save As Displays a dialog box in which you 

enter the new file name and saves 

the met data in that file.  
 

Save As 
Default 

Automatically saves the current met data 

described in the CHARM Input Window as 

the default met data stored in a file labeled 

CHRMDFLT.MET; that is, upon first entering 

CHARM or selecting New from the File 

menu, the parameters stored in CHRMDFLT 

file are displayed. 

Solar 
Radiation 
Worksheet 

A worksheet provided to aid the user 

in the estimation of solar radiation. 
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Automatic 
Poll 

Initiates conversation between 

CHARM and the meteorological 

interface (METINTER.EXE) to 

automatically read stored met data.  

This menu item may be grayed 

(unavailable) if you do not have real-

time met capabilities.  

Stop Poll Signals CHARM to stop real-time 

data acquisition.  This option is only 

available after Automatic Polling has 

been invoked. This menu item may 

be grayed (unavailable) if you do not 

have real-time met capabilities. 
 

Use Inverse 
Square 

Available only if more than one met 

site is available to CHARM for real-

time data acquisition.  Selecting this 

method allows CHARM to determine 

meteorological conditions at a given 

site, using an algorithm that weights 

each met parameter as a function of 

the met parameter at every other site 

and their relative distances. 

Calculate 
Solar 
Radiation 

Calculate the solar radiation as real-time 

met data is acquired.  A check beside this 

option indicates that CHARM will calculate 

the solar radiation based on user input into 

the Solar Radiation Worksheet.  This option 

is only available if CHARM is configured to 

do real-time met data acquisition. 

 

Open MetFile Command 

The Open command on the File menu displays a dialog box requesting 

the name of an input file to open containing meteorological data 

previously stored in CHARM. 
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Save/Save As MetFile Commands 

The Save command will save the current meteorological data into the 

currently opened file.  If no current file is defined, then invoking the Save 

command will invoke the Save As command and display a dialog box 

requesting the name of an input file to save the currently defined 

meteorological data. 

 

Automatic Poll Command 

Use the Automatic Poll command on the Metfile menu of the Main 

CHARM Input Window to read met data automatically for up to 24 hours 

from the specified time of release.  To use this option, your system must 

be set up with the appropriate software program (METINTER.EXE) and 

communication parameters for receiving automatic data from a 

meteorological tower.  The communications parameters can be set using 

the CHARM editor. 

Solar Radiation Worksheet Command 

Use the Solar Radiation worksheet to estimate the amount of solar 

radiation as a function of the time of day, the day of the year, and 

location.  Solar radiation is a function of latitude/longitude, cloud 
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cover, time of day, and the day of the year.  The user must specify the 

+/- offset from local time to Greenwich Mean Time (GMT).  CHARM will 

use the calculated solar radiation value to aid in the determination of the 

stability class if so desired.  Likewise, if the user elects to let CHARM 

calculate the solar radiation value, it will be displayed in the meteorology 

conditions at the bottom of the Main CHARM Input Window.  An example 

of the worksheet is illustrated below. 

 

Options Menu 

The Options menu offers the following commands: 

COMMAND SUMMARY 

Prompt at 

Exit 

Toggle switch to prompt or not to 

prompt the user before exiting 

CHARM.  A check by this menu 

item indicates that the user will 

be prompted before exiting; 

otherwise, no check indicates the 

user will not be prompted by the 

exit dialog box. 

Time is 

Minutes-

Seconds 

Toggle switch to run CHARM in 

Minutes-Seconds mode or Hours-

Minutes mode.  A check by this 

menu item indicates that CHARM 

will run in Minutes-Seconds 

mode; otherwise, no check 

indicates that CHARM will run in 

Hours-Minutes mode. 
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Default 

Metric Units 

Toggle switch to default CHARM 

to report units in metric terms or 

English units.  A check by this 

menu item indicates that CHARM 

will use metric units; otherwise, 

no check indicates that CHARM 

will report units in English terms. 

Description 

Dialog Input 

Provides a means of viewing the 

release input data in a tabbed 

folder format. 

Met Dialog 

Input 

Provides a means of viewing the 

meteorological input data in a 

tabbed folder format. 

 

Prompt At Exit Command 

Use this command to turn on/off the prompt to exit CHARM. A check by 

this menu item indicates that the user will be prompted before exiting 

CHARM; otherwise, no check mark indicates that the user will not be 

prompted by the exit dialog box. 

Time is Minutes-Seconds Command 

Use this command to toggle between CHARM’s two time modes.  A check 

by this menu item indicates CHARM is running in Minutes-Seconds 

mode; i.e. CHARM will model a maximum of 24 minutes of dispersion.  

Likewise, all output will be in terms of minutes and seconds. 

On the other hand, no check indicates that CHARM is running in Hours-

Minutes mode; i.e. CHARM will model a maximum of 24 hours of 

dispersion.  All output will be in terms of hours and minutes. 

On output displays, this is differentiated by the following: 

Hours-Minutes mode uses a colon (:) to delimit hour and minutes; 

Minutes-Seconds mode uses equals (=) to delimit Minutes-Seconds. 
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For example, when CHARM is in the seconds mode all times will be 

displayed with the separator “=“ instead of “:” or whatever the local time 

indicator is.  So fifteen seconds into the release will appear as 00=15 

rather than 00:15, which indicates fifteen minutes into the release.   All 

time labels and columns will appropriately indicate seconds rather than 

minutes. 

Default Metric Units Command 

Use this command to default CHARM to report units in metric terms or 

English units.  A check by this menu item indicates that CHARM will use 

metric units; otherwise, no check indicates that CHARM will report units 

in English terms. 

Description Dialog Input Command 

Use this command as an alternative means to view release input data 

rather than displaying the information from the single Main Input 

Window.   Depending on the release type chosen from the basic 

information tab, the data is categorized appropriately.  The basic, 

location, and building information tabs are always requested for any one 

of the three release types. 

Basic Tab 

On the Basic tab of the folder, CHARM requests the following:  

• title of the scenario; 

• the release type (Container/Surface Description, Pool/Lagoon 

Description, or User-Specified After-Release Conditions); 

• the species being modeled; 

• the desired isopleth concentrations for dispersion; and 

• the type of output to be displayed when/if the stored scenario is used 

in CHARM’s emergency response mode of operation.  The type of 

output available depends on the scenario definition. 
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Location Tab 

On the Location tab of the folder, CHARM simply requests the x,y 

Cartesian coordinates associated with the source location.  This is only 

required if the footprint generated by CHARM is to be overlayed on a 

map, or population impact calculations are to be performed.  However, 

this location may be changed once the footprint has been calculated by 

CHARM. 
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Building Tab 

On the Building tab of the folder, CHARM requests the dimensions of the 

building (height and width) and the distance and direction to the source. 

Enter the direction you would be facing if you were at the release site 

looking at the building. If the release site is not downwind of the 

building, the building is ignored. The direction can be entered in degrees 

or points of the compass. Degrees refer to the 360-degree directional 

compass, where North is 0 or 360, East is 90, South is 180, and West is 

270. Points of the compass refer to North (N), East (E), South (S), West 

(W), and the points between, such as Northeast (NE) and South 

Southeast (SSE).  Also, Enter the distance from the release site to the 

center of the building. The units are feet or meters. If the release site is 

more than ten times the minimum dimension of the building (height or 

width), the building is ignored. 

 

For a Container/Surface Description or Pool/Lagoon Description release 

types, the folder is additionally categorized by pool and surface 

information. 

Pool Tab 

On the Pool tab of the folder, CHARM requests the following: 

• Enter the height above ground of the liquid-air interface. The units 

are feet or meters. Normally a released liquid falls to the ground. 
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• Enter the total area or equivalent circular diameter of the pool size. 

The units are inches, feet, centimeters, or meters. The diameter is 

used to calculate the surface area from which the liquid will 

evaporate. Larger areas tend to evaporate more rapidly than smaller 

areas. CHARM will calculate the pool diameter/area if given the 

amount released and pool depth. 

• Enter the time from the beginning of the release when the pool is 

assumed to be covered or drained. The evaporation from the pool will 

stop at the Pool Mitigation Time. The time can be in units of hours, 

minutes, or seconds. If no mitigation time is desired the entry can be 

left blank or enter zero. 

 

 

Surface Tab 

On the Surface tab of the folder, CHARM requests the following: 

• Enter the fraction (by volume) of the spill surface that is water. This 

is the amount of water in the surface soil of the area that immediately 

surrounds the release site. The water fraction is used to determine 

whether freezing ground water may alter the heat flow into the spill.  

• A value less than 0.1 is dry. A value of 0.6 indicates mud. A value of 

1.0 is water. The suggested average value is 0.15. An entry is 

required. 
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• Select the type of surface on which the spill occurred. If you select 

User-defined surface type, you must enter values for the specific 

heat, thermal conductivity, density, relative pore volume, and Darcy’s 

constant. If you select dirt, asphalt, concrete, or steel, CHARM 

assigns default values for the surface parameters. You can accept or 

change the default values.  Otherwise, making a change to any of the 

surface parameters automatically changes the Surface Type to User-

Defined. 

 

 

 

For a Container/Surface Description release type, the folder is 

additionally categorized by container, storage, hole, pipe, and 

fire/droplets information. 

Container Tab 

On the Container tab of the folder, CHARM requests the following: 

• the container type (horizontal tank or pipeline, vertical tank, or 

spherical tank); 

• the appropriate dimensions based on the selected container type; 

• a mitigation time indicating that the release has been mitigated by 

some circumstance in which the release has been halted; 

• the amount of liquid in the container either by volume, weight, or 

depth. 
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Storage Tab 

On the Storage tab of the folder, CHARM requests storage temperature 

and pressure conditions just prior to release.   

The storage temperature can be specified in Fahrenheit, Celsius, 

Rankine, or Kelvin units.  Use a storage temperature that is greater than 

the melting point of the chemical released.  The user can specify a value 

for the temperature, use the ambient condition specified in the 

meteorological conditions, or let CHARM calculate the temperature if the 

storage pressure is NOT calculated.  

The storage pressure can be either gauge or absolute. The units are 

atmospheres, pounds/square inch, inches of Mercury, or millimeters of 

Mercury. An absolute pressure of less than one atmosphere is treated as 

one atmosphere in the release rate calculation. The user can specify a 

value for the pressure, use the ambient condition specified in the 

meteorological conditions, or let CHARM calculate the pressure if the 

storage temperature is NOT calculated. 

CHARM will inform the user if the given temperature and pressure define 

a solid phase or if no liquid should exist but a liquid depth is specified.  

However, this is only a warning, and the user may proceed with the 

erroneous input. 
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Hole Tab 

On the Hole tab of the folder, CHARM requests the following: 

• Enter the hole height above the ground of the release from the 

container.  The units are feet or meters.  For a gas release, enter the 

height where the gas enters the atmosphere.  For most heavier-than-

air gas releases, where the release height is less than 50 feet (15 

meters), the release can be set to zero without loss of accuracy. 

• Enter the height of the hole from the bottom of the container. The 

units are inches, feet, centimeters, or meters. The hole height is used 

to determine when the liquid release may stop and the pressurized 

gas release begin. It is also used to determine the amount of liquid 

that can be left in the tank for boil-off at a later time. An entry is 

required. 
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• Enter the equivalent area or circular diameter of the hole, or the 

desired release time whereby CHARM will calculate the hole size 

required to dump the entire liquid contents of the container.  When 

specifying the hole size directly, the units are inches, feet, 

centimeters, or meters.  When determining the hole size indirectly by 

specifying the release time, the units are hours, minutes, or seconds.  

An entry with a value greater than zero is required.  Alternatively, 

CHARM will calculate the hole size if the user specifies a release 

duration for the material in the container. 

• Enter the horizontal direction you would be facing if you were inside 

of the tank looking out of the hole. The direction can be entered in 

degrees or in points of the compass. Degrees refer to the 360-degree 

directional compass, where North is 0 or 360, East is 90, South is 

180, and West is 270. Points of the compass refer to North (N), East 

(E), South (S), West (W), and the points between, such as Northeast 

(NE) and South Southeast (SSE). An entry is required.  

For a gas release, the hole direction determines the initial direction 

the plume takes. It is possible for the plume to travel upwind for 

some period of time. 

CHARM can be told to assume that the hole is facing the same 

direction that the wind is blowing toward. Note that wind direction is 

specified as the direction the wind is blowing from. This reduces the 

turbulence that may occur as the release enters the atmosphere. 

Reduced turbulence generally leads to higher concentrations 

reaching further downwind. 

• Enter the vertical angle of the hole.  This is the angle that your line of 

sight would make with the horizon if you were inside the tank looking 

out through the hole.  For example, if you are looking straight up, the 

value is 90 degrees.  If you are looking straight down, the value is -90 

degrees.  A hole that is parallel to the horizon has a value of 0 

degrees.  The vertical angle of the hole can effect the plume rise of a 

gas release. 
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Pipe Tab 

On the Pipe tab of the folder, CHARM requests the following: 

• the pipe dimensions (length and diameter) as well as relative 

roughness factor.  The Relative Roughness Factor (e/D) is a measure 

of the resistance to flow by friction from the interior surface of the 

cylindrical pipe where the Roughness Factor e is a function of the 

piping material, and D is the diameter of the pipe.  Some examples of 

the Roughness Factor e are given below. 

Material Roughness Factor e (mm) 

Drawn Tubing 0.0015 

Commercial Steel or 
Wrought Iron 

0.045 

Asphalted Cast Iron 0.12 

Galvanized Iron 0.15 

Cast Iron 0.26 

Wood Stave 0.3 

Concrete 0.9 

Riveted Steel 3 

 

NOTE: Remember, the above Roughness Factors (e) must be divided by 

the diameter of the pipe to determine the Relative Roughness Factor. 
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• the number of pipe/vessel connections for each pipe type (Flush, 

Borda, Round); 

• the number of valves; 

• the number of elbows/tees. 

 

 

 

Fire/Droplets Tab 

On the Fire/Droplets tab of the folder, CHARM requests the following: 

• Specify whether the tank vents during a pool fire. 

 Specifying that the tank will vent during pool fire signals CHARM to 

use 50% of the wetted tank surface area to calculate heat transfer to 

the stored liquid that may be released due to an increase in tank 

pressure and venting. The Liquid Pool Fires release type provides the 

information for heat calculation. 

 Specifying that the tank will NOT vent merely signals CHARM that no 

additional mass will be added to the primary source. 

• Enter the efficiency (or fraction of material burned) in the BLEVE.  

CHARM can calculate an efficiency based on the vapor pressure of 

the material. 
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• Enter the fraction (0.0-1.0) of the total mass released that is assumed 

to be suspended as droplets.  The default in CHARM is to assume 

that the same amount of mass that flashes also forms as droplets. 

  

 

For a Pool/Lagoon Description release type, the folder is additionally 

categorized by pool temp/fire information.   

Pool Temp/Fire Tab 

On the Pool Temp/Fire tab of the folder, CHARM requests the following: 

• Enter the temperature of the pool or lagoon of liquid. The 

temperature can be specified in Fahrenheit, Celsius, Rankine, or 

Kelvin units.  If selected, CHARM will assume a value for the 

temperature, using the ambient condition specified in the 

meteorological conditions, or using the boiling point of the species, 

whichever temperature value is lower. 

• Specifying a number greater than 0 indicates that a nearby tank will 

vent during a pool fire.  CHARM uses the user-specified tank surface 

area which is wetted by the chemical of interest to calculate heat 

transfer to the stored liquid that may be released due to an increase 

in tank pressure and venting. The Liquid Pool Fires release type 

provides the information for heat calculation. 

Specifying 0 indicates that no venting will occur and signals CHARM 

that no additional mass will be added to the primary source. 
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Finally, for User-Specified mode, the additional categories are emission 

rate, puff, velocity, and makeup. 

Emission Rate Tab 

On the Emission Rate tab of the folder, CHARM requests the following: 

• Click on the checkbox (if available) labeled “CHARM will calculate 

(vertical velocity and molar air fraction given)” if you desire CHARM to 

calculate the emission rate, so long as the vertical velocity under the 

Velocity tab and the molar air fraction under the Makeup tab are 

user-defined. 

• If CHARM is not to calculate the emission rate, the user must specify 

an instantaneous release rate, or a continuous release rate (of which 

may be defined as constant release rate, linearly decaying release 

rate, or exponentially decaying release rate), or a user-defined 

schedule of release rates at different times since release. 

• Finally, the user must specify a duration time for CHARM to use as a 

cut-off time for material to get into the air. 
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Puff Tab 

On the Puff tab of the folder, CHARM requests the following: 

• Enter the height above the ground of the release from the container. 

The units are feet or meters. For a gas release, enter the height where 

the gas enters the atmosphere. For most heavier-than-air gas 

releases, where the release height is less than 50 feet (15 meters), the 

release height can be set to zero without loss of accuracy. 

• Enter the equivalent circular diameter or the area of the puff or 

stack. The units are inches, feet, centimeters, or meters. The puff size 

is required for a user-specified release type.  

 For an evaporating liquid, enter the surface area of the liquid pool. 

For a gas release, enter the diameter of the hole or stack. 

• Enter the temperature of the initial puff in Fahrenheit, Celsius, 

Rankine, or Kelvin units. The puff temperature is required for a user-

specified release type. If selected, CHARM assumes the ambient 

temperature or the boiling point of the species, whichever is lower. 

 For an evaporating liquid release, the puff temperature is the 

temperature just above the liquid pool. For a gas release, it is the 

temperature upon leaving the container or stack. 
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• It is recommended that you allow CHARM to calculate a depth that 

ensures mass conservation. If you enter a value, the prediction may 

be physically unrealistic. 

 

 

 

Velocity Tab 

On the Velocity tab of the folder, CHARM requests the following: 

• Enter the direction of horizontal (not vertical) movement of the initial 

puff. The direction is determined by release conditions, not by 

meteorological conditions such as wind. The puff direction is required 

for a user-specified release type. 

The direction can be entered specifically in degrees or generally in 

points of the compass. Degrees refer to the 360-degree directional 

compass, where North is 0 or 360, East is 90, South is 180, and West 

is 270. Points of the compass refer to North (N), East (E), South (S), 

West (W), and the points between, such as Northeast (NE) and South 

Southeast (SSE). 
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For an evaporating liquid pool, the direction of horizontal movement 

has little meaning, since there should be no inherent horizontal 

movement. For a gas release, the direction should be the same as the 

direction that the hole or stack is facing. If the hole faces directly 

upward or downward, any value entered for the horizontal direction 

is ignored by CHARM. 

This entry can be left blank. If selected CHARM will assume the puff 

is moving in the same direction that the wind is blowing toward. Note 

that wind direction is specified as the direction the wind is blowing 

from. This reduces the turbulence that may occur as the release 

enters the atmosphere. Reduced turbulence generally leads to higher 

concentrations reaching further downwind. 

• Enter the horizontal puff speed in miles/hour, knots, meters/second, 

or kilometers/hour. An entry is required. 

For an evaporating liquid pool, the horizontal speed is zero. For a gas 

release, it represents the horizontal component of the exit velocity 

from the hole or stack. If the hole faces directly upward or downward, 

enter 0 (zero) for the horizontal speed.  

Use the following procedure to obtain the value for the Horizontal 

Puff Speed field: 

1. Complete the entries for the Main CHARM Input Window. Let the 

Vertical Puff Speed be calculated and enter values for the Molar Air 

Fraction and Emission Rate fields. 

2. Press the Apply button. 

3. Find the value for the vertical speed (VERT SPD) on the Puff 

Description output, and enter this value in the Horizontal Puff Speed 

field. 

4. Enter 0 (zero) for the Vertical Puff Speed in the same window. 
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• Enter the vertical speed and direction of the puff. The number 

indicates the speed. A positive (+) number indicates an upward 

direction. A negative (-) number indicates a downward direction. If 

selected and values for the Molar Air Fraction and Emission Rate 

have been entered, CHARM may calculate the Vertical Puff Speed.  

However, the user must specify whether the material exists as a 

liquid or a vapor. 

For an evaporating liquid, the vertical speed is zero. For a gas release, 

the vertical speed represents the vertical component of the exit 

velocity from the hole or stack. For a puff that is directed 

horizontally, the vertical speed is zero. 

 

 

 

Makeup Tab 

On the Makeup tab of the folder, CHARM requests the following: 

• Enter the fraction of the total mass released that is assumed to be 

suspended as droplets.  This number is the mass fraction of droplets 

for each puff during the emission. An entry is required. 

• Enter the molar fraction of water vapor in the emission. It should not 

be higher than approximately 0.04, unless you are describing an 

extremely hot, saturated emission. An entry is required. 
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• Enter the molar fraction of air in the emission. This number allows 

the initial concentration of the gas to be specified. If you select 

“CHARM will calculate (emission rate and vertical velocity give)” and 

enter values for the vertical puff speed on the Velocity tab and the 

emission rate on the Emission Rate tab, then CHARM calculates the 

Molar Air Fraction. 

 

 

 

Met Dialog Input Command 

Use this command as an alternative means to view/modify 

meteorological input data rather than displaying the information from 

the single Main Input Window.  The required data is categorized by main 

information, stability class, solar radiation, and wind data. 

Main Tab 

On the Main tab of the folder, CHARM requests the following:  

• % Relative Humidity; 

• Ambient Temperature; 

• Ambient Pressure; 

• Surface Roughness if it exists; 

• Wind measurement height if a surface roughness is specified; 

• An inversion layer height. 
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Stability Class Tab 

On the Stability Class tab of the folder, CHARM requests the following:  

• Select an atmospheric stability classification (A through F), or enter 

the amount sunshine. If you specify the stability class, you can not 

make entries for the sunshine, cloud cover, or solar radiation unless 

you allow CHARM to calculate the stability class for. If you want 

CHARM to calculate the stability class, select the appropriate 

checkbox and then specify the sunshine, the cloud cover, and solar 

radiation checkbox.   If the ‘Use Solar Radiation‘ checkbox is selected, 

CHARM determines the amount of sunshine based on a Solar 

Radiation Worksheet located under the Solar tab. 
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Solar Tab 

Solar radiation is used as a source for heat transfer when calculating the 

evaporation of a liquid pool.  The user may simply specify a value or use 

the worksheet provided on the  Solar tab which will aid in CHARM’s 

estimation of solar radiation. 

Solar radiation is a function of latitude/longitude, cloud cover, time of 

day, and the day of the year.  You must also specify the +/- offset from 

your local time to Greenwich Mean Time (GMT).  CHARM will use the 

calculated solar radiation value to aid in the determination of the 

stability class if so desired.  Likewise, if the user elects to let CHARM 

calculate the solar radiation value, it will be displayed in the meteorology 

conditions at the bottom of the Main CHARM Input Window. 
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Winds Tab 

Enter sets of wind times, speeds, and directions. Each set represents the 

conditions at a specific time. At least one wind is required. If you leave 

one of the wind values blank, that wind is deleted.  The maximum 

number of wind entries is only restricted by memory. 

The time is the time since release in hours and minutes, up to 24 hours. 

The wind speed units are miles/hour, meters/second, knots, or 

kilometers/hour. Wind direction is the direction from which the wind is 

coming. The direction can be entered in degrees or in points of the 

compass. Degrees refer to the 360-degree directional compass, where 

North is 0 or 360, East is 90, South is 180, and West is 270. Points of 

the compass refer to North (N), East (E), South (S), West (W), and the 

points between, such as Northeast (NE) and South Southeast (SSE). 

CHARM performs a linear interpolation between wind times to determine 

a wind speed and direction. Therefore, there are no instantaneous wind 

shifts. To model a quick wind shift, you can enter two winds that are one 

minute apart. 
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Displays Menu 

The available commands on the Displays menu vary according to the 

input window.  Refer to Chapter 6, “Understanding CHARM Displays,” for 

display samples and more information.  The Displays menu of the Main 

CHARM Input Window provides the following displays. 

 

COMMAND SUMMARY 
Site 
Information 

Displays a text file window 

containing site-specific information.  

The text is created using the 

CHARM editor.  
Chemical Data 

Displays thermodynamic data and 

default plot concentrations from the 

chemical database for the selected 

species.  The chemical database 

can be edited using the CHARM 

editor.  

Chemical 
Response 

Displays a text window containing 

the emergency response 

information for the selected 

chemical species.  The text can be 

edited using the CHARM editor.  
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The following displays start calculations for the numerical portion of CHARM. 

Source/Puff 
Description 

Display numerical results of 

different aspects of a release 

associated with the current input 

and met data.   
 

Emission Rate Displays a plot of the emission rate 

as a function of time for the 

variables in the Main CHARM Input 

Window throughout the release.  

The following displays are available for the appropriate species and release 

types. 

BLEVE Displays a footprint of thermal 

radiation resulting from a 

fireball/BLEVE.  

Pool Fire 
(Radiation) 

Display thermal radiation of a 

Liquid Pool Fire associated with the 

current input scenario. 

Pool Fire 
(Plume) 

Display the plume of a Liquid Pool 

Fire associated with the current 

input scenario 

Jet Fire 
Radiation 

Display thermal radiation of a Jet 

Fire associated with the current 

input scenario.  

Mechanical 
Overpressures 

Display mechanical overpressures 

of a pressurized vessel associated 

with the current input scenario.  

Plume Displays a snapshot view of the plume at 

the specified time after release.  You can 

also generate a concentration history plot 

at selected points, change the position of 

the plume, and zoom any map location 

icons that are shown. 

Release Description Input 

The upper portion of the Main CHARM Input Window contains input 

fields that describe the release.  Figure 5.1 shows these fields.  The 

release description requires the name of the chemical species, a 
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release type, and other pertinent information describing the release.  For 

most release types, you can specify the proximity to a building downwind 

of the release, and CHARM will calculate a building wake.  

The selected chemical species and release type determine which release 

description fields are displayed.  On-line help is available for each input 

field on the Main CHARM Input Window. 

Version 

The version number is displayed on the most hardcopy output and is not 

an editable field. 

Title 

The run title displays on CHARM output and in the selection list for the 

Scenarios command.  Enter the title of the current run.  

 

Species 

This field requires the name of the chemical whose effects you are 

assessing.  When you select this field, CHARM displays the Chemical 

Selection window.  You can select a species from the chemical database, 

which contains data for over 100 chemical compounds.  The chemical 

database can be expanded or modified with the Chemical Database 

command in the CHARM editor (CHARMED.EXE).  See Chapter 4, "Using 

the CHARM Editor," for a list of all the chemicals in the CHARM database 

and information on modifying the chemical database. 
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The search and scroll functions are available in the selection window.  To 

perform a search through the chemical database, select Set String in the 

Chemical Selection window, enter the character string for which you 

want to search, and select OK or press <Enter>.  Then, specify whether 

the search is Up (backward) or Down (forward).  You can use the wild 

cards, * (asterisk) and ? (question mark) in the search string.  The * wild 

card represents zero or more characters. The ? wild card represents a 

character position, rather than a special character.  

Release Type 

The release type describes the conditions of the initial chemical release.  

A release type must be selected for each CHARM run. 

 

The release types provided by CHARM are defined according to the 

conditions right at and before release, or conditions right at and after 

release. 
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The release types available in CHARM are: 

Container/Surface Description 

A Container/Surface description requires that the user specify conditions 

at and before the release.  The Main CHARM Input Window will change 

to reflect only that input which is required.  Usually for a liquid release, 

the species escapes from a container and the generated pool is regulated 

by dikes or terrain.  For this reason, the user must specify a maximum 

pool size, whereby CHARM will allow the pool to expand up to this 

maximum size, and then assume that the pool only becomes deeper.  The 

remaining material of the species enters the air either as vapor or liquid 

droplets. 

Pool/Lagoon Description 

A Pool/Lagoon Description requires that the user specify conditions 

associated with a pool or lagoon of liquid.  The Main CHARM Input 

Window will change to reflect only that input which is required.  The 

release rate that the species enters the air is controlled by the rate at 

which the liquid materials evaporates from the pool.  Depending on the 

chemical data, the pool may be lit on fire. 

User-Specified After Release Conditions 

A User-Specified After Release Conditions type requires you to specify a 

detailed description of the conditions following a release.  You must 

supply the emission rate as well as the temperature, dimensions, 

direction, speed, and makeup of the initial puff.  CHARM will calculate 

one of three of the following inputs: initial emission rate, exit velocity, or 

molar air fraction.  Before you run a user-specified release, it is 

recommended that you perform a standard CHARM run using a release 

type that closely resembles the release you want to define.  The standard 

run will provide some of the necessary data to facilitate running the 

user-specified release.  This release type is useful when assessing stack 

emissions. 

The figures on the following pages show the different input fields for 

various sample releases. 

 

Figure 5.3 
Container/ 
Surface 
Description 
(top) 
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Figure 5.4 
Container/ 
Surface 
Description 
(Bottom) 
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Emergency Response Output 

Select from the type of output available from the drop-down list.  The list is 

dynamic and changes depending on other scenario input.  This field indicates to 

CHARM the type of output to generate when running from emergency response 

mode. 

The six following choices may be available to the user: 

Plume Shows concentration footprints of 

the released chemical. 

Pool Fire Plume Shows the unburned portion of 

species emanating from a pool 

fire. 

Figure 5.5 
Pool/Lagoon 
Description 

Figure 5.6 
User-
Specified 
After Release 
Conditions 
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Pool Fire Radiation Shows thermal radiation 

footprints from a liquid pool fire. 

Mechanical 

Overpressures 

Shows the overpressure or 

shockwave footprints from a 

pressurized vessel failure. 

Jet Fire Radiation Shows thermal radiation 

footprints from a jet fire release. 

BLEVE Shows thermal radiation 

footprints from a fireball/BLEVE. 

 

 

X and Y Locations 

The X and Y Locations are the East/West and North/South coordinates 

of the source location.  To ensure proper placement, the point of origin 

should be the same as that of each map or population polygon you 

intend to use.  Positive (+) X numbers are to the east (right) of the origin, 

and negative(-) X numbers are to the west (left).  Positive Y numbers are 

to the north of the origin, and negative Y numbers are to the south. 

 

Isopleth Concentrations 

Isopleths are the species concentrations that are plotted on the output 

display screens and on hard-copy graphs.  CHARM uses isopleth 

concentrations for creating a plume plot.  You can enter up to three 

isopleth concentrations.  At least one concentration is required.  The 

units of concentration are parts per million (ppm) or micrograms per 

cubic meter (ug/m3).  The default values are specified in the 

chemical database for the selected chemical.  The default isopleth 
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values for a species can be changed using the Chemical Database 

command of the CHARM editor. 

 

Building Wake Input 

The following information is required for CHARM to calculate a building 

wake. 

Building Height and Width 

Enter the height and width of a building that is upwind of the release 

site.  The units are feet or meters.  CHARM uses these dimensions to 

calculate building wake.  If either the height  or width field is 0 (zero), no 

building is assumed to be present.  

 
 

Source to Building Direction and Distance 

Enter the direction you would be facing if you were at the release site 

looking at the building.  The direction can be entered in degrees or points 

of the compass.  Degrees refer to the 360° directional compass, where 

North is 0 or 360, East is 90, South is 180, and West is 270.  Points of 

the compass refer to North (N), East (E), South (S), West (W), and the 

points between, such as Northeast (NE) and South Southeast (SSE).  
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The direction is required for the Huber-Snyder building wake effect 

calculations.  If the release site is not downwind of the building, the 

building is ignored.  

The distance from the release site to the building should be calculated 

from the release site to the center of the building.  The units are feet or 

meters.  CHARM uses the distance and direction to calculate a building 

wake. 

If the distance to the release site is more than ten times the minimum 

dimension of the building (height or width), the Huber-Snyder building 

wake is not used in the dispersion calculation. 

Release Height Above Ground 

Use this field to enter the height of the release above ground.  The units 

are feet or meters.  This field can be used to describe elevated tanks. 

 

For a liquid release, enter the height of the liquid-air interface.  Normally 

a released liquid falls to the ground.  For a gas release, enter the height 

where the gas enters the atmosphere.  For most heavier-than-air 

releases, where the release height is less than 50 feet, the release height 

can be set to 0 (zero) without loss of accuracy.  For a container release 

both hole height and pool height will be requested.   
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Fraction of Liquid mass Suspended as Droplets 

This field specifies the fraction of the total released mass that is assumed 

to be suspended as droplets.  For a liquid release from a container, the 

mechanism for droplet creation is assumed to be turbulence and 

splashing during the release.  This number is the mass fraction of 

droplets for each puff during the emission.  For container/surface 

release, if this field is left blank, CHARM assumes that the droplet 

fraction of mass is the same as the flash fraction. 

 

Amount Released 

The amount released can be either the volume of the container or the 

total amount of the species released.  If you enter the volume, CHARM 

calculates the mass amount released.  The units are cubic feet, cubic 

meters, pounds, kilograms, gallons, or liters.  For a Pool/Lagoon release, 

CHARM will calculate the amount released if given the pool 

diameter/area and pool depth. 

 

For a liquid release from a container, some fraction of the total amount 

may be released as droplets.  

Maximum Pool Diameter (Pool/Lagoon Description) 
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The size of the pool can be either the total area or equivalent circular 

diameter of the pool.  The units are inches, feet, centimeters, or meters.  

If you enter the diameter, CHARM calculates the surface area from which 

the liquid will evaporate.  Larger areas tend to evaporate more rapidly 

than smaller areas.  For a Pool/Lagoon release, CHARM will calculate the 

pool diameter/area if given the amount released and the pool depth. 

 

Maximum Pool Diameter (Container/Surface Description) 

Usually for a liquid release from a container, the species escapes from a 

container and the size of the generated pool is regulated by dikes or 

terrain, whereby the user must specify a maximum pool size.  CHARM 

will allow the pool to expand up to this maximum size, and then assume 

that the pool only becomes deeper. 

 

Wetted Tank Surface Area 

CHARM allows venting for two of the three release types: 

Container/Surface and Pool/Lagoon releases.  When the scenario 

involves a container and a liquid pool fire, CHARM will inquire as to 

whether or not venting from the tank will occur.  Specifying that the tank 

will vent during pool fire signals CHARM to use 50% of the wetted tank 

surface area to calculate heat transfer to the stored liquid that may be 

released due to an increase in tank pressure and venting.  The Liquid 

Pool Fire release type provides the information for heat calculation.  

Specifying that the tank will NOT vent merely signals CHARM that no 

additional mass will be added to the primary source. 
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Likewise, if the scenario involves a liquid pool fire and a pool/lagoon of 

liquid, CHARM will inquire as to the area of a nearby tank that is wetted 

by the species.  The units are square feet or square meters.  CHARM 

uses this area to calculate heat transfer to the stored liquid that may be 

released because of an increase in tank pressure and venting.  The heat 

is calculated from the value entered for liquid pool fires and the tank is 

assumed to be surrounded by fire. 

 

Storage Temperature 

The storage temperature is the temperature of the container just prior to 

the release.  The temperature can be specified in Fahrenheit, Celsius, 

Rankine, or Kelvin units.  The storage temperature should be greater 

than the melting point of the chemical released.  The user can specify a 

value for the temperature, use the ambient condition specified in the 

meteorological conditions, or let CHARM calculate the temperature if the 

storage pressure is NOT calculated. 

Storage Pressure 

The storage pressure is the pressure of the container just prior to 

release.  This pressure can be either gauge or absolute.  An absolute 

pressure of less than one atmosphere is treated as one atmosphere for 

the release calculation.  The user can specify a value for the pressure, 

use the ambient condition specified in the meteorological conditions, or 

let CHARM calculate the pressure if the storage temperature is NOT 

calculated. 
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CHARM will inform the user if the temperature and pressure indicate 

that the phase is solid or if no liquid should be present but a liquid depth 

is specified.  However, this is only a warning, and the user may proceed 

with the non-equilibrium input. 

BLEVE Burn Efficiency 

Enter the efficiency or fraction of material burned in the Boiling Liquid 

Expanding Vapor Explosion (BLEVE).  If the field is left blank, CHARM 

calculates an efficiency based on the vapor pressure of the material.  

Calculating a BLEVE burn efficiency is only available when describing a 

container/surface release.  

 

Water Fraction of Spill Surface 

This field specifies the fraction (by volume) of the spill surface that is 

water, or the amount of water in the surface soil of the area that 

immediately surrounds the release site.  A value less than 0.1 is dry.  A 

value of 0.6 indicates mud.  A value of 1.0 is water.  The suggested 

average value is 0.15.  The water fraction is used to determine whether 

freezing ground water may alter the heat flow into the spill.  An entry is 

required. 
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Surface Description Input 

The following information is required to describe the surface on which 

the spill occurred. 

Surface Type 

Enter the type of surface on which the spill occurred.  If you select dirt, 

asphalt, or concrete, CHARM assigns default values for the surface 

characteristics.  You can accept or change the default values. 

 

If you select the user-defined surface type, you must enter the surface 

characteristics for specific heat, thermal conductivity, density, relative 

pore volume, and the Darcy constant. 

Surface Specific Heat 

Enter the specific heat of the surface on which the spill occurred.  The 

units are Joules/kilogram, BTU/pound °F, or calories/gram.  CHARM 

uses the surface specific heat for heat transfer calculations. 

 

Surface Thermal Conductivity 
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Enter the conductivity of the surface on which the spill occurred.  The 

units are watts/meter per degree Celsius, calories/second/centimeter 

per degree Celsius, or BTU/hour/foot °F per degree Fahrenheit.  CHARM 

uses the surface thermal conductivity for heat transfer calculations.  

 

Surface Density 

Enter the density of the surface on which the spill occurred.  The units 

are kilograms/cubic meter, grams/cubic centimeter, pounds/cubic foot, 

or pounds/cubic inch.  CHARM uses the surface density for heat transfer 

calculations.  An entry is required.  

 

Relative Pore Volume of Surface 

Enter the porosity or relative pore volume of the surface on which the 

spill occurred.  The unit is a fraction.  CHARM uses the relative pore 

volume to calculate the amount of liquid that can be percolated through 

the spill surface.  
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Darcy Constant of Surface 

Enter the Darcy constant to use for calculating the amount of liquid that 

can be absorbed into the spill surface.  The units are feet or meters.  

 

Tank Description Input 

The tank description fields that appear in the window are determined by 

the tank type.  The following fields describe the tank from which the 

chemical was released. 

Tank Type 

Select the type of container from which the species was released.  The 

three choices are a vertical cylinder tank, horizontal cylinder tank or 

pipeline, and a spherical tank. 

 

The tank dimensions are used to determine the amount of species 

released.  A vertical cylinder has horizontal bases and requires an entry 

for the tank height and diameter.  A horizontal cylinder requires an entry 

for the tank length and diameter.  A railroad tank car is an example of a 

horizontal cylinder. A spherical tank requires an entry only for tank 

diameter. 

Tank Height 

Enter the height of a vertical tank.  The units are inches, feet, 

centimeters, or meters.  The tank height is used to determine the 

amount of species released. 
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Tank height refers to the physical dimension of the tank, rather than 

tank elevation.  The calculations for elevated tanks are handled by the 

entry in the field named Release Height.   

Tank Diameter 

Enter the diameter of the spherical container, or the cylindrical portion of 

a vertical tank or horizontal pipeline.  The units are inches, feet, 

centimeters, or meters.  

 

Tank Length 

Enter the length of a horizontal tank or the distance between closed 

valves of a pipeline.  The units are inches, feet, miles, centimeters, 

meters, or kilometers.  

 

Liquid Depth in Container 

If there is liquid inside the storage container, this field requires a value 
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for the depth of the liquid.  The units are inches, feet, centimeters, or 

meters.  The liquid depth is used to determine the amount and rate of 

liquid released. 

 
 

For a vertical tank, the liquid depth must be less than the tank height.  

For a horizontal tank or pipeline, the liquid depth must be less than the 

tank diameter.  For spherical tanks, the liquid depth must be less than 

the tank diameter.  If you change the liquid depth to a value that is 

inconsistent with the values for the tank height or diameter, CHARM 

adjusts the tank height or diameter to accommodate the liquid depth 

value. 

If liquid exists in the container, some may escape through the hole or 

some may be left in the container.  Liquid left in the container may boil 

off after any pressurized gas escapes from the container. 

Hole Diameter 

Enter the equivalent area or circular diameter of the hole.  The units are 

inches, feet, centimeters, or meters.  An entry with a value greater than 

zero is required.  
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Hole is Facing 

Enter the direction you would be facing if you were inside the tank 

looking out of the hole.  The direction can be entered specifically in 

degrees or generally in points of the compass. 

 

Degrees refer to the 360° directional compass, where North is 0 or 360, 

East is 90, South is 180, and West is 270.  Points of the compass refer to 

North (N), East (E), South (S), West (W), and the points between, such as 

Northeast (NE) and South Southeast (SSE).  

For a gas release, the hole direction determines the initial direction that 

the plume takes. It is possible for the plume to travel upwind for some 

period of time.  

Vertical Angle of Hole 

Enter the vertical angle (in degrees) that your line of sight would make 

with the horizon if you were inside the tank looking out through the hole.  

A hole that is parallel to the horizon has a value of 0 (zero). 
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For example, if you are looking straight up, the value is 90.  If you are 

looking straight down, the value is -90.  The vertical angle of the hole can 

effect the plume rise of a gas release.  An entry is required.  

Height of Hole From Container Bottom 

Enter the height of the hole from the bottom of the container.  The units 

are inches, feet, centimeters, or meters.  The hole height is used to 

determine when the liquid release may stop and the pressurized gas 

release begin.  It is also used to determine the amount of liquid that can 

be left in the tank for boil-off at a later time.  

 

Liquid Pool Surface Height Above Ground 

Enter the height above ground of the liquid-air interface.  The units are 

feet or meters.  Normally a released liquid falls to the ground. 
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Connecting Pipe 

If the release occurs within piping connected to a vessel, CHARM will 

account for the piping and any piping system components in the release 

calculation.  Entries for the pipe length, diameter, relative roughness 

factor, and components will affect the flow rate due to pressure loss 

characteristics of the pipe, and therefore affect the release rate calculated 

by CHARM. 

Connecting Pipe Length 

When specifying the pipe length, include all piping and piping 

components that describe the connecting pipe from the source vessel to 

the release point. 

 

Connecting Pipe Diameter 

When specifying the pipe diameter, CHARM will assume the diameter is 

uniform throughout the length of the pipe; that is, multiple piping 

components with varying diameters is not considered. 

 

Relative Roughness Factor (e/D) (0-1) 

Relative Roughness Factor (e/D) (0-1) 

The Relative Roughness Factor (e/D) is a measure of the resistance to 

flow by friction from the interior surface of the cylindrical pipe where the 

Roughness Factor e is a function of the piping material, and D is the 

diameter of the pipe.  Some examples of the Roughness Factor e  are 

given below. 
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Material           Roughness Factor e(mm) 

Drawn Tubing 0.0015 

Commercial Steel or Wrought Iron 0.045 

Asphalted Cast Iron 0.12 

Galvanized Iron 0.15 

Cast Iron 0.26 

Wood Stave 0.3 

Concrete 0.9 

Riveted Steel 3 

NOTE: Remember, the above Roughness Factors (e) must be divided by the 

diameter of the pipe to determine the Relative Roughness Factor. 

 

Piping System Components 

CHARM allows the user to specify any number of typical components 

within the piping system between the source vessel and the release point.  

These entries will affect flow rate due to pressure loss characteristics of 

the pipe, and therefore affect the release rate calculated by CHARM. 

Example diagrams of each component type identified by CHARM are 

shown below: 

Piping System Components 

CHARM allows the user to specify any number of typical components 

within the piping system between the source vessel and the release point.  

This entry will affect flow rate due to pressure loss characteristics of the 

pipe, and therefore affect the release rate calculated by CHARM. 
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Example diagrams of each component type identified by CHARM are 

shown below. 

 

 
 

Globe Valve (100% Open) Gate Valve (50% Open) 

 

 

 

 

90° Elbow 45° Elbow 

  

Tee Elbow-entering stem Tee Elbow-entering side 

  

Tee Straight Through Flush Pipe-Vessel Connection 
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Borda Pipe-Vessel Connection Round Pipe-Vessel Connection 

 

User-Specified Release Description Input 

If User-Specified After-Release Conditions is selected as the release type, 

CHARM requires additional release information. The following 

information is required for a user-specified release type. 

User-Specified Release Type 

An instantaneous release requires you to specify the total amount of 

material emitted.  A continuous release requires you to specify an initial 

emission rate and whether the rate is constant or decreasing.  A 

decreasing continuous release rate can be exponential or linear. 

 

Selecting User-Specified Rate allows the user to define an emission rate 

schedule.  Enter the time schedule for the emission rate from a source.  

CHARM will use this schedule for the emission for the duration of the 

release.  If release duration is longer than the schedule the last emission 

rate is extended unless it is zero.  Schedule entries can only be added if 

valid numbers are in the entry boxes.  Two times can not both be the 

same.  To delete an entry select it and press “Delete.”  To change an 

entry select it and press “Change.” 

When done changing press “Save Change.” “Clear” deletes all entries. 
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Emission Rate 

Enter the mass rate of emission of the species alone or the volume 

emission rate, which includes the species, air, and water vapor being 

emitted.  The units are pounds per hour, grams per second, standard 

cubic feet per minute, standard cubic meters per second, cubic feet per 

minute, or cubic meters per second.   

 

If you leave the Emission Rate field blank, and enter values for the 

Vertical Puff Speed and the Molar Air Fraction fields, CHARM will 

calculate the emission rate. 

Release Time 

For a constant or linearly decreasing release, the release time is the 

amount of time that lapsed during the release.  For an exponentially 

decreasing release, the release time represents the amount of time before 

the emission rate equals one percent (.01) of the initial emission rate.  

The units are hours, minutes, and seconds. 
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However, for linearly and exponentially decreasing releases, you should 

enter actual times. 

Puff Temperature 

The puff temperature is the temperature of the initial puff in Fahrenheit, 

Celsius, Rankine, or Kelvin units.  If this field is left blank, CHARM 

assumes the ambient temperature or the boiling point of the selected 

species, whichever is lower. 

 

For an evaporating liquid release, this is the temperature just above the 

liquid pool.  For a gas release, this is the temperature upon leaving the 

container or stack.    

Puff Diameter 

Enter the equivalent circular diameter or area of the puff or stack.  The 

units are inches, feet, centimeters, or meters.  For an evaporating liquid, 

enter the surface area of the liquid pool.  For a gas release, enter the 

diameter of the hole or stack.  
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Puff Depth 

The Puff Depth field can be left blank, and CHARM will calculate a depth 

to ensure mass conservation.  You can enter a value, but the prediction 

may be physically unrealistic.  

 

Puff Is Moving Toward 

Enter the direction of horizontal movement of the initial puff.  The 

direction is determined by release conditions, not by meteorological 

conditions such as wind. 

 

The direction can be entered in degrees or points of the compass.  

Degrees refer to the 360° directional compass, where North is 0 or 360, 

East is 90, South is 180, and West is 270.  Points of the compass refer to 

North (N), East (E), South (S), West (W), and the points between, such as 

Northeast (NE) and South Southeast (SSE).   

If the hole faces directly upward or downward, any value entered for 

the horizontal direction is ignored by CHARM.  For an evaporating 
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liquid pool, the direction of horizontal movement has little meaning, 

because there should be no inherent horizontal movement.  For a gas 

release, the direction should be the same as the direction that the hole or 

stack is facing. 

This entry can be left blank. If it is left blank CHARM will assume the 

puff is moving in the same direction that the wind is blowing toward. 

Note that wind direction is specified as the direction the wind is blowing 

from. This reduces the turbulence that may occur as the release enters 

the atmosphere. Reduced turbulence generally leads to higher 

concentrations reaching further downwind. 

Horizontal Puff Speed 

This field requires a value for the horizontal puff speed in miles per hour, 

knots, meters per second, or kilometers per hour. 

 

For an evaporating liquid pool, the horizontal speed is 0 (zero).  For a gas 

release, it represents the horizontal component of the exit velocity from 

the hole or stack.  If the hole faces directly upward or downward, enter 0 

(zero) for the horizontal speed.  See the following section for instructions 

on obtaining the horizontal speed. 

Obtaining the Horizontal Speed 

To obtain the horizontal speed, use the following procedure: 

1. Complete the entries for the Main CHARM Input Window.  Leave the 

Vertical Puff Speed field blank and enter values for the Molar Air 

Fraction and Emission Rate fields.  CHARM will calculate the 

vertical puff speed. 

2. Find the calculated vertical speed (VERT SPD) in the Main CHARM 

Input Window, and enter this value in the Horizontal Puff Speed 

field in the Main CHARM Input Window. 

3. Enter 0 (zero) for the Vertical Puff Speed field in the same 

window.  
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Vertical Puff Speed 

Enter the speed and direction of the puff.  The number indicates the 

speed.  A positive (+) number indicates an upward direction.  A negative 

(-) number indicates a downward direction. 

 

For an evaporating liquid, the vertical speed is 0 (zero).  For a gas 

release, the vertical speed represents the vertical component of the exit 

velocity from the hole or stack.  For a puff that is directed horizontally, 

the vertical speed is 0 (zero).   

If you leave this field blank and enter values for the Molar Air Fraction 

and Emission Rate fields, CHARM will calculate the Vertical Puff 

Speed.  Also, the user must specify the physical state (liquid or vapor) in 

the CHARM Main Input Window.  the state is required to determine 

whether the liquid or vapor density should be used in the calculation.  

Molar Water Vapor Fraction 

Enter the molar fraction of water vapor in the emission.  It should not be 

higher than approximately 0.04, unless you are describing an extremely 

hot, saturated emission. 

 

Molar Air Fraction 

Enter the molar fraction of air in the emission.  This value allows the 

initial concentration of the gas to be calculated.  If you leave this field 

blank and enter values for the Vertical Puff Speed and the Emission 

Rate, CHARM calculates the Molar Air Fraction.  
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Meteorological Data Input 

The lower portion of the Main CHARM Input Window contains the 

meteorological data fields for the current scenario.  Figure 5.2 shows the 

Met Data input fields. 

Relative Humidity 

This field requires the ambient relative humidity in percent.  Acceptable 

values are greater than 0 and less than 99.  

 

Ambient Temperature 

The ambient temperature is the air temperature at the release site.  The 

temperature can be specified in Fahrenheit, Celsius, Rankine, or Kelvin 

units.  If the ambient temperature is higher than the boiling point of the 

material released, the impact may become much greater. 
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Ambient Pressure 

The ambient pressure is the atmospheric pressure at ground level at the 

release site.  The pressure can be entered in atmospheres (atm), pounds 

per square inch, inches of Mercury, millimeters of Mercury, or millibars. 

 

Normal atmospheric pressure at sea level has the following equivalents: 

1 atmosphere (atm); 
14.7 pounds per square inch (psi); 
1013.25 millibars (mb); 
29.92 inches of Mercury (in Hg); and 
760 millimeters of Mercury (mm Hg). 

Cloud Cover 

Specify the amount of cloud cover in tenths of sky coverage.  CHARM will 

use the amount of cloud cover if the user wants CHARM to determine the 

stability class and/or solar radiation. 

 

Stability Class 

Select an atmospheric stability classification (A through F), or enter the 

amount of sunshine.  If you want CHARM to calculate the stability class, 

select the appropriate checkbox and then specify the sunshine.  CHARM 

can also determine the amount of sunshine based on a Solar Radiation 

Worksheet located under the MetFile menu. 
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CHARM calculates the stability classification from the wind speed, cloud 

cover, and amount of sunshine. Sunshine is strong if the skies are clear 

and the sun is at least 60 degrees above the horizon.  A 75% middle-level 

cloud cover reduces strong sunshine to moderate.  Sunshine is slight, if 

the sun is less than 35 degrees above the horizon or a 75% low cloud 

cover exists. 

The atmospheric stability class indicates how much mixing occurs in the 

air.  An unstable condition (such as class A, B, or C) tends to mix the 

plume quickly with the ambient air, thereby reducing concentrations 

quickly.  Conditions are unstable if there is a layer of warm air near the 

ground with cooler air above it.  An unstable condition is promoted by 

bright sun with no cloud cover and low wind.  Unstable conditions rarely 

exist at night. 

Conditions are neutral if there is little or no temperature gradient 

between the lower atmosphere and the upper atmosphere.  A neutral 

condition (such as class D) exists when the sky is overcast. 

A stable condition mixes the plume more slowly and allows higher 

concentrations to reach farther downwind.  Conditions are stable if there 

is a layer of cool air near the ground with warmer air above it.  A stable 

condition (such as class E or F) can exist on a clear night with low wind 

speed. 

For ground releases, an extremely stable condition (such as class F) 

generates the greatest ground-level impacts.  For elevated releases, it is 

not as clear which stability will create the greatest ground-level impacts.  

A stable condition tends to maintain an elevated emission aloft, unless it 

is heavier than air.  However, more unstable conditions allow mixing 

downward to the ground. 
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If an automatic meteorological interface is available and the standard 

deviation of the horizontal wind direction (also known as sigma theta) is 

one of the available data values, it will be used to determine stability 

class.  

Solar Radiation  

Solar radiation is used as a source for heat transfer when calculating the 

evaporation of off a liquid pool.  A worksheet provided in the MetFile 

menu will aid in the estimation of solar radiation. 

 

Inversion Height 

The Inversion Height is the altitude above ground at which a temperature 

inversion makes it difficult or impossible for a plume to traverse 

vertically.  The units are feel, miles, meters, or kilometers.  The inversion 

height is difficult to estimate without some form of measurement above 

the surface.  

 

If a height is specified, a plume is not allowed to pass through it (except 

for a jet).  If the release height is above the inversion, the plume will 

remain above.  If the release height is below the inversion, the plume will 

remain below.  If this field is left blank, no inversion will be assumed. 

Surface Roughness 

Surface roughness is a measure of the interaction between the wind and 

the surface.  It affects wind speed with altitude and thus the amount of 
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mixing that can occur.  The units are inches, feet, centimeters, or 

meters.  If the field is left blank, no surface roughness is assumed and 

the wind is assumed to be constant with height. 

 

The following table shows some examples of surface roughnesses: 

Surface type Roughness 
(cm) 

Smooth mud flats; ice 0.001 
Smooth snow 0.005 
Smooth sea 0.02 
Level desert 0.03 
Snow surface; lawn to 1 cm high 0.1 
Lawn, grass to 60 cm high 4-9 
Fully grown root crops 14 
Parkland, bushes 50 
Large obstacles (suburb, forest) 50-100 

 

Wind Measurement Height 

The wind Measurement Height is the height above ground at which the 

wind speed and direction were measured.  It is used along with surface 

roughness to calculate the wind profile with altitude.  The units are feet 

or meters.  A value is required if a surface roughness has been entered. 

 

 

Winds 

Use this field to describe wind speeds and directions that represent 

the conditions at specific times.  At least one wind pair is required.  If 
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you leave a wind time, direction, or speed blank, that wind will be 

deleted.   

 

Time The time since release in hours and 

minutes, up to 24 hours.   

Direction The direction from which the wind is 

coming.  The direction can be entered 

specifically in degrees or generally in 

points of the compass.  Degrees refer to 

the 360° directional compass, where North 

is 0 or 360, East is 90, South is 180, and 

West is 270.  Points of the compass refer 

to North (N), East (E), South (S), West (W), 

and the points between, such as Northeast 

(NE) and South Southeast (SSE).  

Speed The wind speed in knots (kts), miles per 

hour (mph), meters per second (m/s), or 

kilometers per hour (kph).  

Add Winds  

Use this field to describe additional winds.  You can enter wind speeds 

and their directions representing the conditions at a specific time.  The 

description is the same as described in the previous section.  CHARM 

performs a linear interpolation between wind times to determine a wind 

speed and direction.  Thus there are no instantaneous wind shifts.  If 

you want to model a quick wind shift, you can enter two winds that are 

one minute apart. 
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Chapter 6:  Understanding CHARM Displays 

CHARM provides various text and graphic displays to simulate a release 

from data entered in the Main CHARM Input Window.  All CHARM 

displays are accessible through the Displays menus of the Main CHARM 

Input Window or footprint displays.  The displays available for selection 

depend on the species and release type specified in the current input 

window.  The Options menu provides various options for altering the 

CHARM displays. 

Map displays are available for maps that have been read, defined, and 

stored with the Map Definition command of the CHARM Editor.  CHARM 

superimposes plume, thermal radiation and overpressure displays 

(graphics) on a map display.  If the map display has map or release 

location icons, you can select an icon to display the map or the release 

scenario list.  The cursor is represented with cross hairs instead of an 

arrow on graphic displays.   

Main CHARM Input Window Displays 

The Displays menu of the Main CHARM Input Window permits access to 

a variety of text and graphic displays, some of which require CHARM 

calculations.  The Basemap command displays maps that have been 

predefined using the CHARM Editor (CHARMED).  These maps may 

contain release icons that are associated with prestored data file 

information, whereby CHARM may be used in an emergency response 

mode of operation.  The Site Information, Chemical Data, Chemical 

Response, and Source/Puff Calculation commands invoke text displays.  

The Emission Rate command generates a plot.  The BLEVE Radiation, 

Pool Fire Radiation and Plume, and Mechanical Overpressures 

commands invoke graphic displays.  When selecting the Displays menu 

from the Main CHARM Input Window, the cursor changes momentarily 

to an hourglass while CHARM performs source term calculations.   

During these calculations and before the menu is displayed, CHARM 

decides which types of output are valid for the current input scenario.  

For example, if the chemical being modeled, say Chlorine, does not have 

any flammable characteristics associated with it in the Chemical 

Database, then those options involving thermal radiation output (BLEVE, 

Pool Fire, and Jet Fire) are grayed and cannot be modeled. 

Basemap Display 
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Use the Basemap command on the Displays menu when the Main 

CHARM Input Window is activated to display a new map for use in 

emergency response mode.  All maps used with CHARM must first be 

defined with the Map Definition command of the CHARM editor.  Refer to 

Chapter 4, “Using the CHARM Editor,” for details on defining maps.  

When you select the Basemap command, CHARM displays a selection list 

of map files having the default map file name extension.  Initially, this 

default extension is .MAP.  For more information about changing this 

default map extension, refer to Chapter 3,  “CHARM.INI File Description”.  

When a map is selected, CHARM displays the map and a point of 

reference associated with the cross hair location in the status bar at the 

bottom of the CHARM MDI window. 

When a map is displayed, the menu bar on the CHARM MDI frame 

changes to reflect only those menus that are to be used with the active 

window; in this case, the Basemap Window.  These menu items include a 

file menu to open and close other map files, an options menu to zoom 

and unzoom an area, or display a larger-scaled map, and other standard 

windows menus.  Figure 6.0 shows a sample map from a Basemap 

display. 

 

 

Site Information Display 

The Site Information command on the Displays menu shows a text file 

window created with the CHARM Editor.  The text file contains 

information that is specific to the release site.  It may contain useful 

information such as general response procedures, telephone 

numbers, and evacuation exits.  Site information text can be printed 

Figure 6.0  
Basemap 
Display 
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or copied to the clipboard using the File and Edit menu commands 

respectively.  Figure 6.1 shows sample text for a Site Information display. 

 

Chemical Data Display 

The Chemical Data command on the Displays menu shows a text window 

containing the thermodynamic data and default isopleth concentrations 

stored in the chemical database for the selected species.  Figures 6.2, 

6.3, and 6.4 show the chemical data display for Chlorine.  Chemical data 

can be printed or copied to the clipboard using the File and Edit menu 

commands respectively.  It can be modified using the CHARM Editor. 

 

 

 

Figure 6.1  
Site Informa-
tion Display 

Figure 6.2 
Chemical 
Data Display 
(top) 

Figure 6.3 
Chemical 
Data Display 
(Temperature
Dependent 
Equations) 
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Chemical Response Display 

The Chemical Response command on the Displays menu shows the 

emergency response information stored in the chemical database for the 

selected  species.  Figure 6.5 shows a sample Chemical Response 

display.  Chemical response text can be printed or copied to the 

clipboard using the File and Edit menu commands respectively.  It can 

be modified using the CHARM Editor. 

 

Figure 6.4 
Chemical 
Data Display 
(bottom) 
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Source/Puff Calculation Display 

The Source/Puff Calculation command on the Displays menu shows the 

output of the source term calculation for a CHARM run.  The 

Source/Puff Calculation display can be printed or copied using the File 

and Edit menu commands respectively.  This output contains a detailed 

description of each portion of a release.  The data consists mainly of the 

numbers used to describe the source term, emission out of the container, 

emission of each puff into the atmosphere during the release, etc. 

During calculations, the release is divided into a number of puffs.  The 

display contains, near the end of the display, the data used to describe 

each puff during the release.  You can display the puff descriptions for 

several CHARM runs at the same time.  Figures 6.6 through 6.9 show a 

sample Source/Puff Calculation display. 

 

 

Figure 6.5 
Chemical 
Response 
Display 

Figure 6.6 
Source/Puff 
Description 
Display 
(Liquid 
Release from 
Tank) 
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Using the Source/Puff Calculation for Input 

Information from the Source/Puff Calculation display can be used as 

input for a user-specified after release scenario, which requires a 

complete puff description.  First, using a release type similar to the 

Figure 6.7 
Source/Puff 
Description 
Display 
(Vapor 
Release From 
Tank) 

Figure 6.8 
Source/Puff 
Description 
Display (Pool 
Evaporation) 

Figure 6.9 
Source/Puff 
Description 
Display (Puff 
Description) 
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one you want to define, enter the required data in the input window.  

Next, display or print the Source/Puff Calculation.  Then, using the 

User-Specified After-Release Conditions release type, perform another 

CHARM run using the data from the Source/Puff Calculation output as 

input.  The data cannot be automatically inserted by the program; they 

must be manually entered into the Main CHARM Input Window.  

Emission Rate Display 

The Emission Rate command on the Displays menu shows a plot of the 

emission rate as a function of time throughout the release.  The Emission 

Rate display can be printed or copied using the File and Edit menu 

commands respectively. 

The Emission Rate is calculated by using values from the input window.  

The maximum emission rate for the release is also specified.  Figure 6.10 

shows a sample Emission Rate display.  If the emission is out of a 

container, CHARM displays only the emission rate of the species into the 

air.  During a liquid release some of the liquid may fall to the ground to 

form a pool.  If a pool is present during the release, its evaporation rate 

will be shown separately from the container emission rate. 

 

 

Thermal Radiation Displays 

BLEVE Radiation, Pool Fire Radiation, and Jet Fire Radiation commands 

on the Displays menu presents three ways to generate thermal radiation 

displays.  A BLEVE Radiation display generates a Single Point Energy 

Flux window as shown in Figure 6.11.  This display shows the footprint 

of thermal radiation due to a fireball/BLEVE.  The thermal radiation 

footprint can be repositioned within the display.   

Since the display is a point source, it can be altered using the 

Figure 6.10 
Emission 
Rate Display 
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Options commands to change the energy flux values and/or the 

distances from the source.  Use the File menu to print the graphics in 

the window or copy visible graphics to the clipboard. 

 

Repositioning the Radiation Footprint 

To change the position of the thermal radiation footprint in the view port, 

press and hold <Ctrl> while you press the appropriate arrow key one or 

more times.  Each time you press an arrow key, the footprint moves one-

sixteenth of the dimension of the display area.  The view port is actually 

the object being moved.  Therefore, if you want to move the footprint 

down, use the <Ctrl-Up arrow> to move the view port up with respect to 

the footprint. 

 

Setting the Energy Flux Values 

To change the energy flux values for the thermal radiation display, select 

Figure 6.11 
Thermal 
Radiation 
Display 



CHARM Displays   

 

168 

the Energy Fluxes command on the Options menu.  You can enter up to 

three energy flux values in BTU/hour/square foot or kilowatts/square 

meter.  

 

Setting the Radiation Distances 

To change the thermal radiation distances from the source on the 

display, select the Distances command from the Options menu.  You can 

enter up to three distance values in feet, miles, meters, or kilometers. 

 

Displaying a Radiation Footprint Vertical Cross-Section 

The Vertical X-section command on the Displays menu shows a vertical 

cross-section of the thermal radiation footprint (See Figure 6.12).  The 

maximum vertical extent may differ from the maximum horizontal extent 

if the source is not at ground level.  

 

Figure 6.12 
Thermal 
Radiation 
Vertical X-
Section 
Display 
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Pool Fire and Jet Fire Displays 

The Pool Fire and Jet Fire commands on the Displays menu presents a 

Pool or Jet Fire Energy Flux window as shown in Figure 6.13.  This 

display is the footprint of thermal radiation due to a pool or jet fire.  The 

jet fire footprint can be repositioned within the display.   

Use the File menu to print the graphics in the window or copy visible 

graphics to the clipboard. 
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Plotting Thermal Radiation Versus Time 

To generate a plot of thermal radiation as a function of time at a selected 

point, move the cursor to the desired location.  Then double-click the left 

mouse button or press <Enter>.  The plot shows a time history of the 

thermal radiation at the specified location.  The radiation values are 

determined only once a minute (or once a second if CHARM is operating 

in Minutes-Seconds Mode). 

 

Repositioning a Thermal Radiation Footprint 

To change the position of the thermal radiation footprint in the view port, 

press and hold <Ctrl> while you press the appropriate arrow key one or 

more times.  The footprint is repositioned.  Each time you press an arrow 

key, the footprint moves one-sixteenth of the dimension of the display 

area.  The view port is actually the object being moved.  Therefore, if you 

want to move the footprint down, use <Ctrl-Up arrow> to move the view 

port up with respect to the footprint. 

Figure 6.13 
Jet Fire 
Display 
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Setting the Energy Flux Values 

To set the energy flux values for the pool or jet fire radiation display, 

select the Energy Fluxes command from the Options menu.  You can 

enter up to three energy flux values in BTU/hour/square foot or 

kilowatts/square meter.  

 

Displaying a Thermal Radiation Footprint Cross-Section 

The Vertical X-section command on the Displays menu shows a plot 

representing the vertical cross-section of the thermal radiation footprint.  

The view is along the centerline of the flame as it exits the container. 
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Mechanical Overpressures Display 

The Mechanical Overpressures command on the Displays menu presents 

the Sphere Burst Overpressure window shown in Figure 6.14.  This 

display is a footprint of the overpressures expected from a pressurized 

bursting sphere.  The overpressures footprint can be repositioned within 

the display.   

 

 

Since the display is a point source, it can be altered using the Options 

commands to change the overpressure values and/or the distances from 

the source.  Use the File menu commands to save the release description 

Figure 6.14 
Mechanical 
Over-
pressures 
Display 
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input or met data in separate files, and to print the window.  Use the 

Copy command on the Edit menu to copy the footprint to the clipboard. 

Since the sphere burst is instantaneous, no time plot can be generated.  

However, overpressures due to vapor cloud explosion can be plotted as a 

function of time. 

Repositioning the Overpressures Footprint 

To change the position of the footprint in the view port, press and hold 

<Ctrl> while you press the appropriate arrow key one or more times.  The 

footprint is repositioned.  Each time you press an arrow key, the 

footprint moves one-sixteenth of the dimension of the display area.  The 

view port is actually the object being moved.  Therefore, if you want to 

move the footprint down, use <Ctrl> and the up arrow key to move the 

view port up with respect to the footprint. 

 

Setting the Overpressure Values 

To change the overpressure values for the display, select the 

Overpressures command from the Options menu.  You can enter up to 

three overpressures in pounds per square inch or bars. 
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Setting the Overpressure Distances 

You can set the overpressure distances from the source for sphere burst 

overpressures display.  To set the distances, select the Distances 

command from the Options menu.  You can enter up to three distance 

values in feet, miles, meters, or kilometers. 

 

Displaying an Overpressures Footprint Vertical Cross-Section 

The Vertical X-section command on the Displays menu presents the 

Vertical Sphere Burst Overpressure window, which is a vertical cross-

section of the overpressures footprint.  The maximum vertical extent may 

differ from the maximum horizontal extent if the sphere is not at ground 

level. 

 

 

Plume Display 

The Plume command on the Displays menu of the Main CHARM Input 

Window presents a Snapshot Plan Plume View display, which is shown in 

Figure 6.15.  This display is an instantaneous view of the plume at a 

specified time.   In Figure 6.15, the display represents a snapshot of the 

plume 15 minutes after the release began. 
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Generating a Plume Display 

To generate a plume display, select the Plume or Pool Fire (Plume) 

command from the Displays menu of the main CHARM Input Window.  

CHARM prompts the user to enter the desired time of the Snapshot Plan 

Plume View in hours and minutes since the release.  This time is used as 

the maximum time plotted for displays such as the Dose Display, 

Integrated Plume View, and Maximum Distance.   

 

After the plot time is entered, a message box appears momentarily while 

CHARM performs the necessary calculations for creating the plume.  

Select the Cancel button to abort the dispersion calculations and return 

to the Main CHARM Input Window.  Select the Stop button to stop the 

dispersion calculation at the next calculated time interval.  For example, 

if the user requested 15 minutes of dispersion calculation, and the user 

opted to press the Stop button before the calculation was complete, 

CHARM would only display dispersion calculations up to, perhaps, 

minute 11. 

Figure 6.15 
Plume 
Display 
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If calculations have been run with the current input for a previous 

display, the are not run again.  Once the calculations have been 

completed or stopped, a plume display is generated similar to the display 

in Figure 6.15. 

As the cross hair cursor is moved across the plume display, the 

concentration, distance, and angle from the source are reported at each 

point in the status bar at the bottom of the display.  The plan plume view 

window does not scroll.  If the legend at the right or bottom of the 

window is not visible, the window can be maximized.  CHARM can show 

more than one plume display at a time. 

Use the File menu commands to save the release description input or the 

met data in separate files, or plot the display to a printer or plotter.  Since 

the Options and Displays menus of the Snapshot Plan Plume View and 

the Integrated Plan Plume View are very similar, these menus are 

discussed in detail in the following section titled "Plan Plume View 

Displays." 

Repositioning the Source 

To reposition the source within the viewport of a plume display, press 

<Ctrl> and the appropriate arrow key.  Each press of an arrow key moves 

the plume one sixteenth of the distance across the area in which the 

plume is displayed.  When you release the arrow key, the screen is 

updated.  

The direction of the selected arrow key is the direction in which the view 

port (solid circle) is moved.  For example, <Ctrl-Up arrow> moves the 

view port up, thereby moving the plume and map display (if any) down.  

When the source is not at the center of the view port, automatic scaling 

is turned off.   
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To reset the position of the source to the center of the view port, use the 

Reset Source command on the Options menu. 

Generating a Dose Display Plot 

The Dose Display shows a plot of the concentration versus time at a 

selected location.  Figure 6.16 shows a sample Dose Display.  The plot is 

initially one of instantaneous concentrations calculated at each minute 

versus time.   

To generate a Dose Display plot, move the cursor to a desired location, 

and double-click the left mouse button or press <Enter>.  You can 

generate dose plots for multiple locations by repeating this procedure. 

The default averaging time is one minute, but the time can be changed 

using the Averaging option on the File menu from the Dose Display plot.   

Use the File and Edit menu commands to print and copy the Dose Display 

respectively.  You can also display the dose information in tabular form 

using the Table command on the File menu. 

Since the concentration at a location is calculated only once a minute, 

short duration releases (single puffs) may not be represented correctly.  

For a point near the source, the maximum concentration of a puff may 

move over the point not on the minute, but perhaps on a half minute.  

The maximum is then lost.  As a puff moves further downwind, it 

spreads out and the problem is reduced.  A single spike display is often 

an indication that this problem occurred. With single puffs or short 

duration releases, it may be better to use the Maximum Concentration 

command on the Displays menu and interpolate the actual maximum 
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concentration at the selected location, or use the Minutes-Seconds mode 

from the Options menu of the Main CHARM Input Window.  

 

 

Generating a Dose Display Table 

To generate a Dose Display table, first generate a Dose Display plot and 

then select the Table command on the File menu.  The Dose Display 

table shown in Figure 6.17 is a tabular time history of the concentration 

at the selected location.  The averaging time for the dose display is the 

number of minutes that are averaged to determine the display.  Since the 

concentrations are calculated at the specified location only once a 

minute, the default is one minute.  To change the averaging time, use the 

Averaging option from the File menu.  

Figure 6.16 
Dose Display 

 

Figure 6.17 
Dose Display 
Table 
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Setting the Averaging Time for a Dose Display 

To reset the averaging time, select the Averaging menu from the File 

menu of the Dose Display window, and enter the averaging time in 

minutes from 1 to the present plot time.  The default time is 1 minute.  

The average taken is the running average.  The concentrations at a 

specific point are averaged over time to determine a time-weighted 

average.  For example, if the averaging time is 5 minutes the 

concentration given at time 0 minutes is the average for minutes 0, 1, 2, 

3, and 4.  For minute 1, the average is for minutes 1 through 5.  For 

minute 2 the average is for minutes 2 through 6.  The averages result 

from summing instantaneous minute predictions, not averages over each 

minute.  
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Plan Plume View Displays 

The plan plume view displays are the Snapshot Plan Plume View (Figure 

6.15) , the Integrated Plan Plume View (Figure 6.30), the Grid Averaged 

Plume View (Figure 6.31), Mechanical/Explosion Overpressure Views 

(Figure 6.35), and the Population Visual Verify (Figure 6.32).  A Snapshot 

Plan Plume View display is an instantaneous view of the plume at a 

specified time. The Plume command on the Displays menu of the Main 

CHARM Input Window generates the snapshot view.  An Integrated Area 

Plan Plume View is a minute by minute calculation of the plume display 

that shows all areas affected by the plume. The Integrated Area 

command on the Displays menu of the Snapshot Plan Plume View 

window generates the integrated plume.  Selecting the Time-Averaged 

Plume command from the Displays menu of the Snapshot Plume 

generates a time-averaged plume based on a user-defined averaging 

interval and a user-defined grid size. The Mechanical Overpressures  

option shows a footprint of the overpressures expected from a 

pressurized bursting sphere.  It is only available if the release type is 

Container/Surface Description.  On the other hand, if flammability 

characteristics are right and concentration levels are sufficient, a plume 

may be ignited from the Explosion Overpressures command on the 

Displays menu from a Snapshot Plume View.  Finally, the user may 

visually verify how a footprint (plume, overpressures, or thermal 

radiation) impact population tracts.  This option is only available after 

the population impacts have been calculated from the Displays menu of 

any type of footprint. 

Use the Options menu on the plan plume views to alter the appearance 

of a display.  The Options menu and the Displays menu of the integrated 

view are similar to those of the snapshot view.  The selections for both 

menus are discussed in the following sections. 

Plume View Options Menu 

The Options menu of the Snapshot Plan Plume View provides selections 

for altering the appearance of the plume display, showing a new map, 

setting and resetting the source location, and specifying a new release 

time.  The Options menus for the Snapshot Plan Plume View and the 

Integrated Plume View have many of the same selections. 

Isopleths Option (Plume Footprint Display) 

Use the Isopleths command on the Options menu to change the species 

concentrations that are plotted on plume displays and graphs.  Enter the 

isopleths in parts per million or microgram per cubic meter.  At least 

on concentration is required. 
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Overpressures Option (Mechanical/Explosion Overpressures 
Display) 

Use the Overpressures command on the Options menu to change the 

desired overpressures that are plotted on the displays and graphs.  Enter 

the overpressures in psi or bar.  At least one overpressure is required. 

 

Distances Option (Explosion Overpressures Display) 

Enter up to three distances from the source. The units are feet, meters, 

miles, or kilometers. CHARM displays the default values. You can accept 

or change the default values. A value is required for at least one distance. 

CHARM uses the distances to calculate overpressures to create the 

footprint display. 

 

Averaging Time Option (Time-Averaged Footprint Display) 

You may change the averaging time associated with a Time-Averaged 

Footprint.  Enter the averaging time in minutes from 1 to the present 

plot time. The average taken is the running average. The 
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concentrations at a specific point are averaged over time to determine a 

time-weighted average. 

For example, if the averaging time is 5 minutes, the concentration given 

at time 0 minutes is the average for minutes 0, 1, 2, 3, and 4. For minute 

1, the average is for minutes 1 through 5. For minute 2 the average is for 

minutes 2 through 6. The averages result from summing instantaneous 

minute predictions, not averages over each minute. 

 

Grid Size Option (Time-Averaged Footprint Display) 

You may change the grid size associated with a Time-Averaged Footprint.  

Enter the number of points to be used in the grid when generating a 

Time-Averaged Plume.  The grid is 2-dimensional and, therefore, the user 

must enter the number of points in the X direction (East/West) and the Y 

direction (North/South). 

 

Show Grid Option (Time-Averaged Footprint Display) 

This option simply turns on or off the currently defined grid for a Time-

Averaged Footprint.  A check mark by the option indicates the grid is 

shown, while no check mark indicates that the grid is not shown. 

Grid Display Option (Time-Averaged Footprint Display) 

If the Show Grid option is on, this option displays the user-defined 

grid for the Time-Averaged Plume as a series of points or a wire 

mesh, whichever submenu item is selected.  A check by the menu 
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item indicates this option is turned on, whereas no check by the menu 

item indicates the option is not active and the grid points are not visible. 

Text Size Option (Population Impact Visual Verify Display) 

From the Population View, the user may adjust the size of the text 

describing the population number for each tract.  Increasing the number 

enlarges the current size of the text, and decreasing the number reduces 

the current size of the text.  Each population tract is described by two 

numbers, one on top of the other.  The top number is usually lower if any 

type of impact was encountered in the tract.  This number indicates the 

number of people impacted in the tract.  The lower number is the total 

number of people located in that particular tract. 

 

Line Width Option (Population Impact Visual Verify Display) 

From the Population View, the user may adjust the line width describing 

the population tracts.  This is helpful when differentiating the population 

tracts from lines drawn by overlaying maps.  Increasing the number 

enlarges the current line width, and decreasing the number reduces the 

current size of the line width. 

 

Monochrome Option (3D Plume Display) 

Use this option in the 3D Plume Display to remove the color from the 

concentration being viewed.  This menu item is switched either on or off.  

A check mark beside the menu item indicates that no color is used with 

the plume and no check mark indicates the plume is filled with color. 

Scale Radius Option (Any Footprint Display) 



CHARM Displays   

 

184 

Use the Scale Radius command on the Options menu to change the 

radius of the view port (solid circle) on the plume display.  A scale change 

alters the overall display area.  Enter the radius of the view port in feet, 

miles, kilometers, or meters.  A value greater than 0 (zero) must be 

entered.   If you want CHARM to determine the radius of the view port, 

you can specify the scale ratio using the Scale Ratio command on the 

Options menu. 

 

Scale Ratio Option (Any Footprint Display) 

Use the Scale Ratio command on the Options menu to enter a ratio for 

which CHARM will determine the view port radius on the plume display.  

When you set the scale ratio, the plume display will approximate the plot 

that will be sent to the printer/plotter.  The display itself will not be set 

to scale, but the output of a plot sent to the printer/plotter will be scaled.   

Enter the scale ratio of the current plume display.  Assume a 1:scale 

relationship. The center of the plot will be at the center of the view port. 

The total area plotted is determined by the scale specified, not 

necessarily by what is visible on the screen.   

 

Distance Circles (Any Footprint Display) 

To supplement the displays of the plan view, additional circles can be 

drawn within the large circle with tick marks.  Enter the radius 

increment to use. 
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Receptor Height Option (Any Footprint Display) 

Use the Receptor Height command on the Options menu to change the 

height of the display above the ground.  The plan plume view represents 

a horizontal slice through the atmosphere.  Enter the height above 

ground in feet or meters.  This value is used for all calculations and 

displays that require a receptor height.  

 

Transparency Option (Any Footprint Display) 

The Transparency command on the Options menu is a toggle that 

changes the display between a colored, opaque plume and a "ghost" 

plume that is denoted only by concentration hatch marks.  When a map 

and plume are displayed, this feature allows the map areas beneath the 

plume to be seen.  The transparency option was used to create the plume 

figures shown in this chapter. 

No Hatch Option (Any Footprint Display) 

Use the No Hatch command to remove the hatch marks from the legend 

and the footprint so that only color may be seen.   The command is 

merely a switch.  A checkmark next to the command indicates that No 

Hatch is active.   Alternatively, no checkmark by the command indicates 

the No Hatch is inactive. 

NOTE: The No Hatch command does not work in accordance with the 

Transparency command selected. 
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Use Auto Scale Option (Any Footprint Display) 

Use Auto Scale command works in accordance with selecting an option 

(e.g. New Time, Receptor Height, etc.) for generating a new display.  If the 

Use Auto Scale command is checked and active, then CHARM will 

automatically rescale the current display so that the resulting footprint is 

completely described in the viewport (i.e. large circle).  On the other 

hand, if the Use Auto Scale command is unchecked and inactive, then 

the resulting display will remain at the current scale just before the user 

requests a option for display. 

Decay Option (Plume Footprint Display) 

Use the Decay command on the Options menu to specify the time (half-

life) required for half of the emitted material to decay into neutral 

products.  This option simulates the decay of the material in the air.  

Enter the decay time in hours, minutes, or seconds.  Any previous 

windows produced for the current scenario are not updated with the 

effects of the half-life data, but all subsequent windows are. 

 

If you enter a decay time, the downwind concentrations will be 

decreased.   

NOTE:  Use this option with caution, because the predicted concentrations 

will be lower than they would be with no decay.  

Map Option (Any Footprint Display) 

The Map command on the Options menu opens a dialog box in which 

you can select a map for display.  Any maps that have been edited with 

the CHARM Editor and stored with the default .MAP file name extension 

are displayed.  The default map name is BASEMAP.MAP.  Select the 

name of the map to display.  For more information on map displays, see 

the section of this chapter titled "Map Displays." 
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No Map Option (Any Footprint Display) 

The No Map command on the Options menu quickly and easily removes 

the current map from the display when selected. 

Location Option (Any Footprint Display) 

Use the Location command on the Options menu to relocate the source 

of the release on the current map.  This option displays the map on a 

separate screen where the source location can be changed. 

 

To change the source location, first select the new location on the map 

display.  If you are using a mouse, move the cursor to the new location 

and double-click the left mouse button.  With a mouse, you can achieve 

the same result by selecting the Define Point option in the Define menu, 

moving the cursor to the new location, and then clicking the left mouse 

button.  If you are using the keyboard, select the Define Point option in 
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the Define menu of the map display, move the cursor to the new location 

by holding down <Shift> while pressing the arrow keys, and then press 

<Enter>. 

To scroll the map display with a mouse, use the scroll bars.  To scroll the 

map with the keyboard, use <Page Up> or <Page Down>. 

Map Description (Any Footprint Display) 

Selecting this option allows the user to view pertinent information 

describing the currently displayed map.  This text is defined in the Map 

Definition Editor within CHARMED.  For more information, refer to “Map 

Description” in Chapter 3. 

 

Reset Source Option (Any Footprint Display) 

If the plume has been repositioned within the view port, the Reset Source 

command on the Options menu resets the position of the source to the 

center of the view port. 

Auto Map Change Option (Any Footprint Display) 

Use the Auto Map Change command on the Options menu to enable 

CHARM to automatically display a larger-scaled map when the scale of 

the current map display is not large enough to cover a significant portion 

of the plot area (defined by the Auto Map Fraction command).  In order 

for CHARM to identify and automatically display a larger-scaled map, the 

map must be edited with the CHARM Editor and assigned an Expand 

Map Name.  The Auto Map Change command is a toggle. 

Auto Map Fraction Option (Any Footprint Display) 

Use the Auto Map Fraction command to define the fraction of the 

footprint display area which must be covered by a map to preclude 

CHARM from trying to go to a larger scale map.  The rectangular area 

used for comparison is the area in which the viewport circle is inscribed.  

If the current map covers less than the Auto Map Fraction of the 

rectangular area, CHARM will try to go to the larger scale map defined for 

the map.  The value must be between 0.05 and 0.95.  The default is 

0.25.   
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Larger Scale Map Option (Any Footprint Display) 

Use the Larger Scale Map command on the Options menu to display a 

larger-scaled map when the scale of the current map display does not 

cover a significant portion of the plot area.  The larger-scaled map must 

be edited with the CHARM Editor.   

New Time Option 

Use the New Time command on the Options menu to change the time 

since release for the Plan Plume View.  If the requested time has already 

been calculated, the display is immediately updated.  This dialog box is 

also requested when first generating the plume or footprint from the 

Plume command of the Main CHARM Input Window. 

 

Time Circles Option (Any Concentration Footprint Display) 

The Time Circles command on the Options menu draws dashed circles 

around the source, the radii of which are determined by the time 

specified in the dialog box.  Time circles indicate the locations to which 

the current wind speed can move a parcel of air from the source in the 

number of minutes specified.  

 

Enter the time in minutes.  A time greater than 0 (zero) is required to 

display time circles.  If you enter 0 or leave the field blank, CHARM 
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does not display time circles.  Figure 6.18 shows a sample Time Circles 

display. 

 

The wind speed at the release site, current height, and the time of the 

Snapshot Plan Plume View are used to determine the radii of the circles.  

Spatial and temporal variations of the wind speed are not used.  As the 

wind speed changes, the radii change.  Wind speed changes with time 

also affect the radii of time circles. 

Create ASCII File Option (Any Footprint Display) 

Create ASCII File command on the Options menu enables the user to 

generate a file to hold a description of a footprint that can be transferred 

to other programs.  CHARM requests the name of the file through a 

standard windows Save As dialog box.  Select the drive, the directory, 

and the file name to store the text file.  The default ASCII file extension 

(.PLM) is defined by the AsciiExt variable in CHARM.INI. 

 

Figure 6.18 
Time Circles 
Display 
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This option was designed to be used with the other programs, such as 

Computer Aided Design software (CAD), which should have options to 

import the data. 

ASCII File Format 

The ASCII file contains the real world coordinated (in meters from source) 

of the currently displayed footprint.  The file contains what is envisioned 

as the minimum required for the general case.  The points given 

describing the location of an isopleth are not necessarily close enough to 

give a smooth display of an isopleth. 

RECORD VARIABLES MEANING FORTRAN 
FORMAT 

1  
HRO 
MINSO 
SECO 

Time of release: 
hours 
minutes 
seconds 

315 

2  
HRP 
MINP 
SECP 

Time of plot: hours 
minutes 
seconds 

 

3 HEIGHT Height above 
ground of plot 
(meters) 

E15.4 

4 NCON 
 
 
IUNITS 
 
ITYPE 

Number of isopleth 
values following; 
Units of isopleths; 
Type of calculation 

315 

5 CONV (1 TO 
NCON) 

Isopleth values 3E15.4 

In the above if IUNITS is 0 or mission the isopleth values are in ppm.  If 

IUNITS is 1, the isopleths are in kilowatts per square meter (thermal 

radiation). If IUNITS is 2 the isopleths are in pounds per square inch 

(overpressures). 

The type of calculation indicated how the isopleths were generated: 

ITYPE Source 

1 Snapshot Plume concentration. 

2 Pool fire or BLEVE radiation. 

3 Thermal Radiation. 

4 Overpressures from a failure of a pressurized 

vessel. 

5 Overpressures from a vapor cloud explosion. 

6 Integrated Plume concentration. 

7 Time-Averaged Plume 
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These first five records will be followed by NCON groups of records.  Each 

group will consist of: first, a record containing the number of isopleths 

for one of the CONV values (NISO, format I5), followed by up to three 

subgroups of records.  Each subgroup will have the following format: 

 

SUB-

GROUP 

RECORD 

 

VARIABLES 

 

MEANING 

FORTRAN 

FORMAT 

1 NPTS Number of X/Y 

pairs following 

15 

2 - NPTS+1 X,Y,R Points 

describing an 

isopleth; 

R is always 0. 

R is never used 

and is only 

present for 

backward 

compatibility. 

 

 

An example of records 6 and onward may help.  Assume NCON is three 

and that the three isopleths following are 1, 10, and 100 ppm.  Further 

assume there are two distinct and separate isopleths for the 100 ppm 

concentration.  This can happen if the emission rate has varied over 

time.  The other concentrations will be assumed to only have a single 

isopleth each. 

 
Record Value 
7 1 (only one isopleth for 1 ppm 

conc.) 
8 NPTS1 
9 to 8 + NPTS1 NPTS1 pairs of X/Y points 

describing 1 ppm isopleth 
9 + NPTS1 1 (one isopleth for 10 ppm 

conc). 
10 + NPTS1 NPTS10 
11 + NPTS1 to NPTS10 points pairs describing 

10 ppm 
10 + NPTS1 + 
NPTS10 

isopleth 

11 + NPTS1 
+NPTS10  

2(two isopleths for 100 ppm 
conc.) 

12 + NPTS1 + 
NPTS10 

NPTS100A 
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... NPTS100A  point pairs for first 
100 ppm isopleth 

... NPTS100B 

... NPTS100B point pairs for 
second 100 ppm isopleth 

Minimum and maximum numbers that can be expected for each of the 

variables which may dictate the use of arrays are: 

• NCON (1 to 3) 

• NISO (0 to 3) 

• NPTS (unlimited) 
 

Transferring Footprints via DDE to other Windows Programs 
A (Dynamic Data Exchange) DDE interface is available to send a footprint 
of impact (concentration, thermal radiation, or overpressure) data in a 
real-time manner to other Windows programs while CHARM is running.  
To set up the DDE a client program must initialize a conversation with 
the server, CHARM.  The following values are needed to set up the 
communication. 
 
Server Name: CHARM 
 
Topic: EISI 
 
Item: PLUME_CHARM 
 
CHARM only performs Advise services (use XTYP_ADVSTART).  After a 
conversation has been established, whenever a plan view is created or 
changed it will be sent out to all clients.  Changing receptor heights, 
isopleth values, time, etc. change the plume.  The block of data sent out 
is identical to creating an ASCIIFile except that a line is added to the 
beginning of the block.  This first line is to be used as a scenario 
indicator.  The first line is to be used as a scenario indicator.  The first 
line will look like: 
   
  CHXXXXXX 
 
where XXXXXX is a six digit number from 0 on up (leading 0s are used).  
Every data block sent with the same first line where created from the 
same input.  This is actually only true if CHARM is not stopped and the 
re-started.  Whenever CHARM begins the value of XXXXXX starts at 0.  If 
the value of CHXXXXXX is identical to that in a previous data block and 
ITYPEs are the same the new data block is an update to the previous 
footprint (possibly at a new time, height, etc.). 
 

Create Shape File Option (Any Footprint Display) 

This command enables the user to generate a file that describes a 

footprint of impact (concentration, thermal radiation, or overpressure) 

which can be transferred to ArcView for display.  Whenever a plan view of 

an impact is displayed, this option becomes available on the Options 

menu.  The default shape file extension (.SHP)  is defined by the 
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ShapeFileExt variable in CHARM.INI.  It is set to SHP and should not be 

changed since ArcView expects that extension. 

 

An ArcView shape file is actually three files: the main file, an index file, 

and a dBase file with attributes.  These three files all have the same 

names and locations except for their extensions.  The main file extension 

is .SHP. The index file extension is .SHX.  The dBase file extension is 

.DBF. 

The main file contains the real world coordinates (in meters from source) 

of the currently displayed footprint. The file contains what is envisioned 

as the minimum required for the general case. The points given 

describing the location of an isopleth are not necessarily close enough to 

give a smooth display of an isopleth.  The index file has pointers to the 

footprints in the main file so that ArcView can find the data properly.  

The dBase file has the following attributes for each isopleth of the 

footprint: REL_TIME, PLOT_TIME, X_SRC, Y_SRC, HEIGHT, 

CONT_VALUE, UNITS, and SOURCE. 

REL_TIME is the time of release.  Usually 00:00 except for emergency 

response.  Then it is clocktime of release. 

PLOT_TIME is the display time which is given as time since release. 

X_SRC, Y_SRC define the location of the source in meters.  The footprints 

vertices are given in meters from the source. 

HEIGHT is the height above ground of the footprint. 

CONT_VALUE is the numeric value defining the isopleth. 

UNITS is a flag for the units of CONT_VALUE 
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If UNITS is 0 the isopleth values are in ppm. If UNITS is 1, the isopleths 

are in kilowatts per square meter (thermal radiation). If UNITS is 2 the 

isopleths are in pounds per square inch (overpressures). 

The type of calculation used to generate the isopleths is indicated by the 

SOURCE attribute: 

SOURCE Source 

1 Snapshot Plume concentration. 

2 Pool fire or BLEVE radiation. 

3 Jet fire radiation. 

4 Overpressures from a failure of a pressurized vessel. 

5 Overpressures from a vapor cloud explosion. 

6 Integrated Plume concentration. 

7 Time-Averaged Plume 

 

Plume View Displays Menu 

The Displays menu of the Snapshot Plan Plume View window provides 

selections for plotting maximum distances, vertical cross-sections, 

centerline concentrations, explosion overpressures, population impacts, 

Time-Averaged plumes, and integrated area plumes.  CHARM also 

creates table displays for maximum distances and concentrations.  Met 

data, release data, puff description, and emission rate displays are also 

available from the plan plume view.    

The Displays menu of the other Plan Displays have selections that are 

similar to the snapshot plume displays menu. The Displays menu for an 

integrated plume does not provide a vertical cross-section, centerline 

concentration, or meteorological data.  The integrated plume has 

additional menu selections for recalculating a plume or continuing the 

current calculation. 

Maximum Distance Display 

The Maximum Distance command on the Displays menu plots the 

maximum distance downwind of the specified concentration as a 

function of time. 
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Enter the concentration in parts per million or micrograms per cubic 

meter.  The time interval for the plot depends on the time specified for 

the current Snapshot Plan View Plume view display.   Figure 6.19 shows 

a sample Maximum Distance Plot. 

 

Use the Copy command from the Edit menu to copy the contents of the 

window to the clipboard.  Use the File menu commands to print the 

Maximum Distance plot, or display the maximum distance information in 

the form of a table. 

Figure 6.19 
Maximum 
Distance Plot 
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Maximum Distance Table   

To display the maximum distance information in tabular form, first 

display the Maximum Distance plot and then select the Table command 

from the File menu.  The table shows the distance downwind that a 

concentration has reached as a function of time.  The distance is 

reported in feet, miles, meters, and kilometers for each minute since the 

release time specified for the plume.  Figure 6.20 shows a sample 

Maximum Distance table. 

 

Maximum Width Display 

The Maximum Width command on the Displays menu plots maximum 

crosswind width of a user-specified concentration as a function of time. 

 

Enter the concentration in parts per million or micrograms per cubic 

meter.  The time interval for the plot depends on the time specified for 

the current Snapshot Plan View Plume view display.  Figure 6.21 shows 

a sample Maximum Width Plot. 

 

Figure 6.20 
Maximum 
Distance 
Table 
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Use the Copy command from the Edit menu to copy the contents of the 

window to the clipboard.  Use the File menu commands to print the 

Maximum Width plot, or display the maximum width information in the 

form of a table. 

Maximum Width Table 

To display the maximum width information in tabular form, first display 

the Maximum Width plot and then select the Table command from the 

File menu.  The table shows the crosswind width of a user specified 

concentration as a function of time.  The distance is reported in feet, 

miles, meters, and kilometers for each minute since the release time 

specified for the plume.  Figure 6.22 shows a sample Maximum Width 

table. 

Figure 6.21 
Maximum 
Distance 
Table 

Figure 6.22 
Maximum 
Width Table 
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Maximum Concentration Display 

Use the Maximum Concentration command on the Displays menu to 

enter a minimum distance from the release source beyond which CHARM 

will tabulate and display all maximum concentrations as a function of 

time. 

 

Enter the distance in feet, miles, meters, or kilometers.  Figure 6.23 

shows a sample Maximum Concentration Table.  Use the File menu 

commands to print or copy the table. 
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The table shows the maximum concentration of the species in parts per 

million and micrograms per cubic meter as a function of time.  A 

maximum concentration is calculated for every minute since release.  

The X and Y locations and the downwind distance of the maximum 

concentrations are also reported.  Use the File and Edit menu commands 

to print or copy the Maximum Distance table respectively. 

Vertical Cross-Section 

The Vertical X-section command on the Displays menu plots a vertical 

cross-section through the middle of the plume.  The view is from the 

source through the middle of the first puff released.  Since this display 

involves one of the longest calculations in the model, it may take some 

time before the cross-section is displayed.  Figure 6.24 shows a sample 

Vertical Cross-Section display.  Use the File menu commands to print, 

plot, or copy the cross-section display.  The Monochrome command on 

the File menu creates a colorless vertical cross-section whose isopleth 

concentrations can be printed or plotted. 

Figure 6.23 
Maximum 
Concentra-
tion Table 

Figure 6.24 
Vertical 
Cross-Section 
Display 
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Centerline Concentrations Display 

The Centerline Concentrations command on the Displays menu plots the 

concentrations down the centerline of the plume as a function of 

distance.  The concentrations are listed for the specified height and may 

not include the maximum concentration. 

 

Enter the beginning and ending points of the line to lie along the 

centerline of the plume.  You can also specify the concentration interval 

by which to show  concentrations along the centerline.  Figure 6.25 

shows a sample Centerline Concentrations display.  Use the File and Edit 

menu commands to print or copy the display respectively. 

 

Figure 6.25 
Centerline 
Concentra-
tion Plot 
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To display a centerline concentration table instead of a graph, select the 

Table command from the File Menu.  To plot the log concentration 

instead of the actual value check the Log Plot option in the dialog box 

that contains the line and interval information.  Figure 6.26 shows a 

sample Centerline Concentrations Table.  Use the File and Edit menu 

commands to print, or copy the display respectively. 
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If the concentrations are expected to vary over orders of magnitude, a 

centerline concentration table of values or log plot for the actual 

concentrations may be more informative than a linear graph.   The 

centerline concentration table lists the concentrations (parts per million 

and micrograms per cubic meter) down the centerline of the plume as a 

function of distance (feet or meters).  The table lists the X and Y 

positions, the distance from the source, and the concentration at each 

point.  A positive X value indicates East and a negative X value indicates 

West.  Similarly, a positive Y value indicates North a negative Y value 

indicates South.  The concentration units are parts per million and 

micrograms per cubic meter.  The concentrations are listed for the 

specified receptor height and do not necessarily include the maximum 

concentration.  

Plume Half-Widths Display 

The Plume Half-Widths command on the Displays menu determines the 

crosswind half-width down the centerline of plume as a function of 

concentration.  The user will be prompted for the downwind spacing of 

the points along the centerline for the half-width calculations. 

 

Figure 6.26 
Centerline 
Concentra-
tions Table 
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Enter the desired concentration in parts per million or micrograms per 

cubic meter. 

 

Enter the beginning and ending points of the line to lie along the 

centerline of the plume.  Figure 6.27 shows a sample Plume Half-Width 

plot.  Use the File or Edit menu commands to print or copy the graph. 
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To display a plume half-width table instead of a graph, select the Table 

option from the File menu.  Figure 6.28 shows a sample Plume Half-

Width Table.  Use the File and Edit menu commands to print or copy the 

display respectively. 

Figure 6.27 
Plume Half-
Width Plot 
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Met Data Display 

The Met Data command on the Displays menu shows the meteorological 

data at the source location.  The values for the current receptor height 

and the time since release specified for the Snapshot Plan Plume View 

display are used.  Figure 6.29 shows a sample Met Data display.  Use the 

File and Edit menu commands to print or copy the display respectively. 

 

 

Integrated Area Display 

The Integrated Area command on the Displays menu starts a minute by 

minute calculation of the snapshot plume and displays the 

Integrated Plan Plume View.  The integrated plume display shows all 

Figure 6.28 
Plume Half-
Width Table 

Figure 6.29 
Met Data 
Display 
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areas affected by the plume.   

The integrated display looks similar to the Snapshot Plume View and has 

most of the same menus and commands.  Refer to the previous section 

titled "Plan Plume View Displays" for descriptions of the commands on 

the Options and Displays menus. 

The current isopleth concentrations are used for plotting at any time 

during the release and up to the most recent time requested.  The time 

shown on the integrated plume display is the time currently being 

calculated.  The calculation of area impacts are performed for every 

minute of the simulation.  If the changes in the plume are much more 

rapid than every minute, the display may not be a smooth 

representation.  Figure 6.30 shows a sample integrated plume. 

 

 

Since the calculation requires time, you can stop the calculation by 

selecting the Cancel button that appears in the plume window.  A cancel 

takes effect after the latest minute's calculations are complete.  

Therefore, there may be some lag time before you see a cancel response. 

The maximum concentrations at each area are displayed.  If the wind 

shifts or the emission rate varies, the areas impacted can also vary.  

Once an integration calculation has been performed, moving between the 

Snapshot and Integrated Area plumes does not require new time 

calculations. 

To continue the integration using the same time, select the Continue 

menu item from the Options menu.  To create an integrated plume 

Figure 6.30 
Integrated 
Plan Plume 
View 
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using a different time, select the Recalculate menu item from the Options 

menu. 

To generate a Dose Display plot (concentration history) at a specific 

point, move the cursor to the desired location.  Then, double-click the left 

mouse button or press <Enter>. 

To reposition the source within the view port, hold <Ctrl> while you press 

the appropriate arrow key one or more times. When you release <Ctrl>, 

the plume is repositioned.  Each time you press an arrow key, the plume 

moves one-sixteenth of the dimension of the display area.   

Use the File menu commands to save the release description input or 

met data in separate files, print the window, or plot the plume.  Use the 

Copy command on the Edit menu to copy the display to the clipboard. 

Time-Averaged Footprint 

The Time-Averaged Footprint command on the Displays menu shows a 

view of averaged concentrations at the specified time. The plume is a 

result of the source term and transport/dispersion calculations averaged 

over a user-specified time within a user-defined grid (see Averaging Time 

and Grid Resolution). The isopleth concentrations are represented by 

differing hatch marks and colors.  The user has the option of selecting 

the entire plume for averaging or a user-defined area of the plume for 

averaging. 
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Selected Area of a Time-Averaged Footprint  

Selecting the Selected Area submenu on the Time-Averaged Footprint 

command of the Displays menu changes the cursor to a magnifying glass 

and requires the user to draw a rubberband box around the area of 

interest.  To do this, find a point on the plume display, click and hold 

down the left mouse button, drag the mouse to create a rubberband box, 

and then release the left mouse button.  CHARM will only consider those 

concentrations within the extents of the rubberband box for averaging. 
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Averaging Time and Grid Resolution for a Time-Averaged 
Footprint 

Selecting the Entire Plume Area or Select Area command from the Time-

Averaged Footprint command requires the user to input the desired 

averaging time and the desired grid size. 

 

The resulting display is a Time-Averaged plume based on this user-

defined averaging interval and the user-defined grid size.  See Figure 

6.31 for example output of a Grid Averaged Plume. 

 

 

Circular Population Impact 

This command calculates the number of people affected by the listed 

concentrations, radiation fluxes, or overpressures within a user-

Figure 6.31 
Grid 
Averaged 
Plume View 
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specified radius from the source.  The user is initially prompted for the 

desired radius.   

 

The number of people is normally determined from the population 

information available on US Census Bureau Tiger/Line™ 1992 Data. 

If a population number is enclosed in brackets, that means that a failure 

occurred during calculation and the number given is a lower limit of the 

number of people impacted.  This calculation failure occurs when 

CHARM can not resolve the intersection between the plume outline and a 

population tract.  Often, however, it can be alleviated by changing the 

source location minutely.  If the population number is -1 this indicates 

that only one population tract was impacted but an error was 

encountered. 

The resulting display is independent of the footprint and only described 

by the population impacts within the user-specified radius from the 

source. 

 

Visual Verify (Population Impact) 



CHARM Displays   

 

212 

From a Population Impact display, use the Visual Verify command on the 

Displays menu to illustrate overlaying the radius or footprint on to the 

population tracts that have been preprocessed in the TigerMap Utility 

and defined in the CHARM Editor (see Figure 6.32). 

 

 

Population Impact 

Use the Population Impact command to calculate the number of people 

affected by the listed concentrations, thermal radiation, or overpressures.  

The number of people is normally determined from the population 

information available on U.S. Census Bureau Tiger/Line
TM

 1992 Data 

(see CHAPTER 8: Using the TIGERMAP Utility). 

If a population number is enclosed in brackets, that means that a failure 

occurred during calculation and the calculated value is a conservative 

estimate of the number of people impacted.  If the population is -1 then 

this indicates that only one population tract was impacted but a failure 

in the calculation was encountered.  This failure occurs when CHARM 

can not resolve the intersection between the plume outline and a 

population tract.  Often, however, the failure can be alleviated by slightly 

changing the source location.  CHARM breaks down the impacted 

population by age, race, families, households, owners, and renters.  

Figure 6.33 show the results of a population calculation impact. 

 

Figure 6.32 
Population 
Visual Verify 
View 

Figure 6.33 
Population 
Impact 
Display 
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The method of calculation can be changed be selecting the Population 

Calculation command from the Displays menu.  Likewise, you can 

visually verify overlaying the footprint on to the population tracts that 

were preprocessed in the TigerMap Utility and defined in the CHARM 

Editor. 

Population Calculation 

The method of calculating the population impacts can be selected from 

the Population Calculation command from the Displays menu.  There are 

three methods of calculation. 

 

I. Actual footprint and population tract boundaries used 

Both the footprint and population tract boundaries will be used in the 

calculation.  The calculated area of impact is the intersection of the 

footprint and the tract.  This is the most accurate method.  It can take 

the longest time and is the most prone to a failure in the calculation to 

determine intersection between the plume outline and the population 

tracts. 
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II. Footprint rectangle and actual population tract boundaries 
used 

The footprint is represented as its bounding rectangle.  The tract 

boundary is used as determined from the Tiger/Line
TM

 data.  The 

calculated area of impact is the intersection of the footprint rectangle and 

the tract.  This is the second most accurate method.  It is designed to 

take less calculation time than the actual plume boundary being used.  

However, this is not always the case.  It can also produce a failure in the 

calculation when determining the intersection between the rectangle 

inscribing the footprint and the population tract. 

III. Footprint and population tract rectangles used 

Both the footprint and population tract are represented by their 

bounding rectangles.  The calculated area of impact is the intersection of 

the footprint and tract rectangles.  This is the least accurate method.  It 

is the fastest calculation for determining population impacts and will 

never fail when determining the intersection between the rectangle 

inscribing the footprint and the rectangles inscribing the population 

tracts. 

To invoke the selected population calculation method, select Population 

Impacts command in the Displays menu. 

Explosion Overpressures Display 

The initial step in generating an explosion overpressure display is to first 

generate a plume containing sufficient lower explosive concentration 

limits to allow for deflagration or detonation of the plume.  Deflagration 

occurs when the flame speed is slower than mach 1.  Detonation occurs 

when flame speed is mach 1 or greater. 

Displaying Explosion Overpressures 

Once a plume has been generated, selecting the Explosion Overpressures 

command on the Displays menu of the Snapshot Plan Plume View 

window shows the overpressure footprint resulting from ignition at the 

specified release time.  It is an instantaneous view.   Figure 6.34 

illustrates a propane plume calculated by CHARM.  Figure 6.35 shows 

the explosion overpressures resulting from the ignition of the plume. 

 

Figure 6.34  
Plume View 
prior to 
Ignition 
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Changing Potential Overpressures 

This command is similar to modifying the isopleths from a Snaphot Plan 

Plume Display.   However, in this case, the user has the option of 

modifying those potential overpressures which are displayed from the 

resulting explosion.  Select Overpressures from the Options menu and 

the following dialog box appears. 

Figure 6.35   
Explosion 
Overpressure 
after Ignition 
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Changing Flame Speed 

This command allows the user to use the default flame speed defined in 

the chemical database, modify that flame speed, or specify explosion 

characteristics from a table by specifying the Expansion Dimension, 

Mixture Reactivity, and Obstacle Density.  If changes are made, the user 

has the option to reset the flame speed to the default in the chemical 

database. 

 

Plotting Potential Explosion Overpressures Versus Time 

To generate a plot of potential overpressures as a function of time at a 

specific location, move the cursor to the desired location.  Then double-

click the left mouse button or press <Enter>.  An example is illustrated 

in Figure 6.36. 

 

Figure 6.36   
Explosion 
Overpressure 
Potential 
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Maximum Distance Overpressure Display 

From the Explosion Overpressures display, you can display a maximum 

distance for an overpressure as a function of time.  From the Displays 

menu, select Max Distance and CHARM will request a single 

overpressure value and unit for plotting. 

 

Figure 6.37 shows the resulting Maximum Distance Overpressure Plot.  

The plot is also a function of the time calculated since release. 

Figure 6.37   
Maximum 
Distance plot 
for Explosion 
Overpressures 
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Displaying an Explosion Overpressures Footprint Cross-
Section 

From the Explosion Overpressures display, you can display a cross-

section of the potential overpressures by selecting the Vertical X-section 

command from the Displays menu.  Figure 6.38 shows the resulting X-

section. 

 

 

Overpressure Damage Estimates 

The following are the peak pressures formed in excess of normal 

atmospheric pressure by blast and shock waves: 

Figure 6.38   
Vertical 
Xsection of 
Explosion 
Overpressures 
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Overpressure (psi) 

Note:1 bar = 14.5 psi 

 

Expected Damage 

0.03 Occasional breaking of large 

windows already under 

stress. 

0.04 Loud noise (143 dB); sonic 

boom glass failures. 

0.10 Breakage of small windows 

under strain. 

0.15 Typical pressure for glass 

failure. 

0.30 Some damage to house 

ceilings; 10% window glass 

breakage. 

0.40 Limited minor structural 

damage. 

0.50-1.0 Windows usually shattered; 

some window frame damage. 

0.7 Minor damage to house 

structures. 

1.0 Partial Demolition of houses; 

made uninhabitable. 

1.0-2.0 Corrugated metal panels fail 

and buckle.  Housing wood 

panels blown in. 

1.0-8.0 Range for slight to serious 

injuries due to skin 

lacerations from flying glass 

and other missiles. 

1.3 Steel frame of clad building 

slightly distorted. 

2.0 Partial collapse of walls and 
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Overpressure (psi) 

Note:1 bar = 14.5 psi 

 

Expected Damage 

roofs of houses. 

2.0-3.0 Non-reinforced concrete of 

cinder block walls shattered. 

2.3 Lower limit of serious 

structural damage. 

2.4-12.2 Range for 1-90% eardrum 

rupture among exposed 

populations. 

2.5 50% destruction of home 

brickwork. 

3.0 Steel frame building distorted 

and pulled away from 

foundation. 

3.0-4.0 Frameless steel panel 

building ruined. 

4.0 Cladding of light industrial 

buildings ruptured. 

5.0 Wooded utility poles snapped. 

5.0-7.0 Nearly complete destruction 

of houses. 

7.0 Loaded train wagons 

overturned. 

7.0-8.0  8-12 in. thick non-reinforced 

brick fail by shearing of 

flexure. 

9.0 Loaded train box cars 

demolished. 

10.0 Probable total building 

destruction. 

15.5-29.0 Range for 1-99% fatalities 

among exposed populations 
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Overpressure (psi) 

Note:1 bar = 14.5 psi 

 

Expected Damage 

due to direct blast effects. 

Source: Lees, F.P, Loss Prevention in the Process Industries, Vo,. 1, 

Butterworths, London and Boston, 1980. 

Input Display 

The Input command on the Displays menu shows the input data for the 

current CHARM run just as it appears in the Main CHARM Input 

Window.  This display is for viewing only and no changes can be made.  

Use the File menu commands to print or copy the display.  This menu 

item becomes very important when viewing or comparing different sets of 

output for different input parameters.  An Input command under the 

Displays menu of many output displays will yield those input parameters 

used to obtain the given calculations. 

Source/Puff Description Display 

The Source/Puff Description command on the Displays menu shows the 

output of the source term calculation for the current CHARM run.  This 

output contains a detailed description of each portion of a release.  See 

Figures 6.6, 6.7, 6.8, and 6.9 for illustrations of the Source/Puff 

Description output. 

During calculations, the release is divided into a number of puffs.  The 

display includes the data used to describe each puff during the release.  

You can display the puff descriptions for several CHARM runs at the 

same time.  use the File menu commands to print or copy the display. 

Information from the Source/Puff Description display can be used as 

input for a user-specified release scenario, which requires a complete 

puff description.  First, using a release type similar to the one you want 

to define, enter the required data in the input window.  Next, display or 

print the Source/Puff Description.  Then, using the User Specified After-

Release Conditions release type, perform another CHARM run using the 

data from the Source/Puff Description printout as input.  The data 

cannot be automatically inserted by the program; they must be manually 

entered into the Main CHARM Input Window.  

Emission Rate Display 

The Emission Rate command on the Displays menu shows a plot of the 

emission rate as a function of time throughout the release.  The plot 

results from calculations using values from the CHARM run that created 

the current plan plume view.  The Emission Rate display is the same 

as the display shown in the Main CHARM Input Window with the 

command of the same name. (see Figure 6.6 earlier in this chapter).  
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Use the File and Edit menu commands to print or copy the display 

respectively. 

Site Information Display 

The Site Information command on the Displays menu shows a text file 

window created with the CHARM Editor.  The text file contains 

information that is specific to the release site.  It may contain useful 

information such as general response procedures, telephone numbers, 

and evacuation exits.   The Site Information display is the same as the 

display shown in the Main CHARM Input Window (see Figure 6.1 earlier 

in this chapter).  Site information text can be printed or copied to the 

clipboard using the File and Edit menu commands respectively.  

Chemical Data Display 

The Chemical Data command on the Displays menu shows a text window 

containing the thermodynamic data and default isopleth concentrations 

stored in the chemical database for the selected species.  The Chemical 

Data display is the same as the display shown in the Main CHARM Input 

Window with the command of the same name (see Figures 6.2, 6.3, and 

6.4 earlier in this chapter).  Chemical data can be printed or copied to 

the clipboard using the File and Edit menu commands respectively.  It 

can be modified using the CHARM Editor. 

Chemical Response Display 

The Chemical Response command on the Displays menu shows the 

emergency response information stored in the chemical database for the 

selected  species.  The Chemical Response display is the same as the 

display shown in the Main CHARM Input Window with the command of 

the same name (see Figure 6.5 earlier in this chapter).  Chemical 

response text can be printed or copied to the clipboard using the File and 

Edit menu commands respectively.  It can be modified using the CHARM 

Editor. 

Displaying a Map 

The Basemap command on the Displays menu of the Main CHARM Input 

Window offers one way to display a map.  When you select the Basemap 

command, CHARM displays a dialog box in which you can select the map 

to display.  Press F1 or press the ‘Help’ button to display the on-line help 

screen. 

To scroll a map display with a mouse, use the scroll bars.  To scroll a 

map with the keyboard, use <Page Up>, <Page Down>, and arrow keys.   

The Basemap display has menus that provides commands for 

zooming and unzooming a specified area, displaying another map, 
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displaying a larger scale map (if one is available), and displaying a map 

description.   

File Menu 

The File menu for a map displayed with the Basemap command of the 

Main CHARM Input Window provides additional commands to those 

provided by the Options menu of the input window.     

The commands available on the File menu for a map display are: 

COMMAND SUMMARY 

Open Displays a selection list of 
maps for display. 

Close Closes the Basemap display 
window. 

Larger Scale 
Map 

Displays a larger-scaled map that 
has been defined with the Map 
Definition command and named with 
the Expand map name command of 
the CHARM Editor. 

Exit Exits CHARM. 

 

Options Menu 

The Options menu for a map displayed with the Basemap command of 

the Main CHARM Input Window provides additional commands to those 

provided by the File menu.     

The commands available on the Options menu for a map display are: 

COMMAND SUMMARY 

Zoom Displays an enlargement of a  
specified map area. 

Unzoom Returns a zoomed map 
display to its original size 
when the window was 
opened. 

Map 
Description 

Displays a text description 
associated with the current map 
display.  This text is for display only 
as it is editable from within the 
CHARM Editor. 
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Zooming a Map Area 

To zoom a portion of a map display, you must mark the area to be 

zoomed.  First, select the Zoom option on the Options menu.  The cursor 

changes from a pointer to a magnifying glass.  Next, move the cursor to 

one corner of the area to be zoomed.  If you are using a mouse, hold the 

left mouse button down, move the cursor to the opposite corner of the 

area to be zoomed, and release the button.   

If you are not using a mouse, press <Enter> to mark the first corner of 

the zoom box, expand the box with the arrow keys, and press <Enter> 

again to complete the zoom box.  The zoom display may not have a one-

to-one correlation to the marked area.  To return to the initial map 

display, select the Unzoom command from the Options menu. 

Displaying a Map From the Plan View Displays 

Plumes, thermal radiation footprints, and overpressure footprints are 

considered plan view displays.  The Map command on the Options menu 

of a plan view offers another way to display a map.   

When the Auto Map Change command on the Options menu is selected, 

and the map display covers less than the fraction  of the display area 

defined by the Auto Map Fraction command, CHARM automatically 

switches to a larger-scaled map (if one is defined).  To turn off this 

feature, deselect Auto Map Change in the Options menu by clicking on it. 

When the Auto Map Change command is not selected, you decide when 

to display the larger-scaled map.  Use the Larger Scale Map command on 

the File menu to manually display the expanded map.  In this case, the 

map must be defined and assigned an expanded map name using the 

CHARMED editor.  Use the Expand Map Name command in the Map 

Definition editor to identify the larger-scaled map.  

Selecting an Icon on a Map 

The map display may show icons that represent other map locations or 

possible release locations.  These icons are positioned and defined with 

the Map Definition command of the CHARM editor.  A map location icon 

looks like boxes within boxes.  

 

A release location icon looks like a plume within a box. 
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Selecting an icon displays another map of the location or a selection list of 

releases at the location.  To select an icon on a map in the Basemap 

display, move the cursor over the icon.  If you are using a mouse, click 

either button.  If you are not using a mouse, press <Enter>.  To select an 

icon on a map in a footprint display, press and hold <Shift> while you 

move the cursor over the icon, and select the icon by double-clicking the 

left mouse button or pressing <Enter>. 

When you select a map location icon, CHARM displays the map that has 

been defined for that location.  This map may also have selectable icons 

representing other maps and releases. 

When you select a release location icon on a map in the Basemap 

display, CHARM checks for automatic meteorological data from the time 

of the release to the present time.  If no met data are available, CHARM 

displays a message that allows you to stop the run.  If the run continues, 

CHARM performs calculations in one of two ways, depending on the 

mode of operation defined by the EmergencyMode variable in the 

CHARM.INI file.  If EmergencyMode = 1 or is not defined, then CHARM 

will display a real-time footprint, updating the display minute by minute.  

If EmergencyMode = 0, CHARM calculations continue for the duration of 

the emission plus 30 minutes.  Then the time used for the footprint 

display is the time at which the lowest value of interest (e.g. 

concentration) has maximum aerial extent. 

3-Dimensional Plume 

The 3D Plume command on the Displays menu of the Plan Plume View 

offers a method to view a concentration in 3 dimensions.  CHARM 

initially requests a single concentration to display. 
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Once the concentration of interest has been entered, press the OK button 

and CHARM displays the 3D Plume Window.  Figure 6.39 illustrates the 

3D Plume Display 

 

 
This windows presents a three-dimensional view of a concentration 

plume.  Only one concentration may by viewed at a time.  The observer 

location and observed location may be changed.  The observed location is 

the point at the center of the observer’s view.  Tools can be used to move 

the observer around or away and towards the observed location.  The 

observer can also go up and down.  The tools are available either as icons 

on the toolbar or keystrokes. 

Moving the Observer 

The observer can be moved with respect to the observed location.  The 

observer can be moved around the point, closer to the point, and farther 

from the point.  The observer can also move up and down.  The observer 

can not move below surface level (z=0).  The observer can be moved via 

the mouse or keyboard. 

Moving via the Mouse 

Press the button icons on the toolbar.  The tools represent up, down, 

near, far, left, and right. 

Moving via the Keyboard 

Direction Key 

Up <Ctrl> + Up Arrow 

Down <Ctrl> + Down Arrow 

Figure 6.39 
3D Plume 
Display 
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Left Left Arrow 

Right Right Arrow 

Near Up Arrow 

Far Down Arrow 

Setting the Observer Location 

This dialog box allows you to change the location of the observer.  The 

observer will continue to look at the same observed location from a 

different position.  The observer’s location can be specified in either 

Cartesian or cylindrical coordinates.  Select the appropriate button for 

the desired coordinate system.  When one coordinate system is selected, 

the other ignores user input although it will update as new coordinates 

are entered. 

 

The x,y coordinate system is with respect to the release location.  That is, 

the release location is (0,0) in Cartesian coordinates.  The release 

location is at zero distance in cylindrical coordinates.  The z or altitude 

value is with respect to ground level.  The azimuth is given in the 

meteorological sense from the release location.   The direction can be 

entered in degrees or in points of the compass.  Degrees refer to the 360-

degree directional compass, where North is 0 or 360, East is 90, South is 

180, and West is 270.  Points of the compass refer to North (N), East (E), 

South (S), West (W), and the points between, such as Northeast (NE) and 

South Southeast (SSE). 

If you want to reset the location to what it was when the plume was 

initially drawn press the “Reset to Default” button. 

Setting the Observed Point 

This dialog box allows you to change the location of the observed 

point.  The observer will stay at the current position  and look at this 

new  observed location.  The observed location can be specified in 
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either Cartesian or cylindrical coordinates.  Select the appropriate button 

for the desired coordinate system.  When one coordinate system is 

selected, the other ignores user input although it will update as new 

coordinates are entered. 

 

The x,y coordinate system is with respect to the release location.  That is, 

the release location is (0,0) in Cartesian coordinates.  The release 

location is at zero distance in cylindrical coordinates.  The z or altitude 

value is with respect to ground level.  The azimuth is given in the 

meteorological sense  from the release location.   The direction can be 

entered in degrees or in points of the compass.  Degrees refer to the 360-

degree directional compass, where North is 0 or 360, East is 90, South is 

180, and West is 270.  Points of the compass refer to North (N), East (E), 

South (S), West (W), and the points between, such as Northeast (NE) and 

South Southeast (SSE). 

If you want to reset the location to what it was when the plume was 

initially drawn press the “Reset to Default” button. 

Setting the Observer Step Distances 

This dialog box allows you to change the stepsizes of the observer.  There 

are three dimensions the observer can move in.  The observer can move 

vertically (up and down from the ground), radially (closer or farther from 

the observed location), or azimuthally about the observed location.  The 

values given in this dialog box define the increment to be taken every 

time a movement tool or appropriate key is pressed. 
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Setting the Z Scale 

This dialog box allows the user to enter a dimensionless number to scale 

the plume z coordinates.  Normally, a plume is much larger in the 

horizontal than the vertical direction.  To make viewing easier the z 

values of the plume can be increased to make the vertical distribution 

easier to discern.  CHARM attempts to provide a scale factor determined 

on plume dimensions.  This scale will be seen when the scale factor given 

here is 1.0. 

 

Displaying a 2D Map in the 3D Plume View Display 

Use the Map section of the Options menu from the 3D Plume Display to 

display a map.  CHARM allows the user to overlay a 3D plume on a 2D 

map (see Figure 6.40). 
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Figure 6.40 
3D Plume 
Overlayed on 
2D Map 
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Chapter 7: Using CHARM for Emergency Response 

Use CHARM's emergency response mode to quickly display stored maps 

of the release site, input data, plumes or footprints, tables, graphs, and 

other useful information.  The emergency mode displays data resulting 

from input and calculations stored in the planning mode. 

Emergency Response Files 

CHARM's emergency response mode requires a map that has been edited 

with the CHARM Editor (CHARMED) and at least one release scenario 

that has been created and saved with CHARM.  If CHARM was allowed to 

assign file name extensions when the files were stored, the default 

extension for map files is .MAP and the default extension for release 

scenario files is .EMG.  The default extensions may be changed (see 

section ‘CHARM.INI File Description’ in CHAPTER 3: Getting Started).  

However, extensions other than these may have been assigned to the file 

name.  For discussion purposes, this document refers to these files as 

.MAP and .EMG files. 

Map Files 

When the CHARM program starts, it searches for a map file with the 

name BASEMAP.MAP and its corresponding definition file 

BASEMAP.MFD.  If such files exist, the map is displayed immediately 

and the CHARM considers this to be in the Emergency Response Mode.  

If these files do not exist, CHARM automatically displays the Main 

CHARM Input Window in Planning Mode.  From the Main CHARM Input 

Window, you can enter Emergency Response Mode by selecting a map 

display using the Basemap command on the Displays menu. 

Map Requirements 

All maps used in CHARM must first be edited using the Map Definition 

command of the CHARM Editor (CHARMED.EXE). A point and scale 

must be specified for each map.  To be useful in the emergency response 

mode, a map must be defined with at least one release location icon.  

This icon identifies the release scenarios that are defined at the location.  

The map may also have map location icons that point to smaller-scaled 

maps.  A map may also have a larger-scaled map associated with it and 

also text information describing attributes associated with the map(e.g. 

the date that the map was last updated). 
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Release Location Icons 

If the map display has one or more release location icons, you can select 

an icon and display a list of stored scenarios.  A release location icon 

looks like a plume within a box.   

 

The scenario contains the input data.  If the map has no release location 

icons, you can select a release using the Scenarios command on the File 

menu of the input window.  For more information on creating, moving, 

and deleting release location icons, see ‘Defining a Release Location’ in 

CHAPTER 4: Using the CHARM Editor. 

Map Location Icons 

If the map display has map location icons, you can select a map location 

icon and display a smaller-scaled map.  A map location icon looks like 

boxes within a box. 

 

Each map can point to another map.  If the map has no map location 

icons, you can select a map using the New Map command on the 

Basemap menu of the input window.  It is important the user define the 

larger-scale map of the map associated with the map icon such that it 

points back to the map utilizing the map icon.  This will allow the user to 

go back and forth between larger-scaled and detailed maps. For more 

information on creating, moving, and deleting map location icons, see 

‘Defining a Map Location’ in CHAPTER 4: Using the CHARM Editor. 

Release Scenario Files 

The emergency response data files typically have the default .EMG file 

name extension.  Files with the .EMG extension contain stored input 

data from a CHARM run, which is called a release scenario. 

In the emergency response mode, CHARM displays the titles in a  

scenario selection list (.EMG files) when you click on a release icon on a 

map display.  In planning mode, you can display the titles by selecting 

the Scenarios command from the File menu of the Main CHARM Input 

Window.  You can select from the list in the dialog box. 

Emergency Response Mode Procedures 
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CHARM's emergency response mode is useful only when a base map has 

been defined with at least one release location icon.  The emergency 

response mode requires that the input for at least one release has been 

previously stored in a scenario file. 

To use the emergency response mode: 

8. Start the CHARM program.  The method you use to start CHARM depends on the 

system and the version of Windows you are using.  Refer to Chapter 3, "Getting 

Started", for a description of these methods. 

9. CHARM displays a base map (BASEMAP.MAP) if one is defined.  Otherwise, CHARM 

displays the Main CHARM Input Window. 

If the base map is displayed, look for release or map location icons.  If 

the map has a release icon at the release site, select the icon to 

display a list of release scenarios.  Since more than one map may 

define the release area, the base map may not have a release icon.  

Instead, the map may have one or more map location icons that you 

can select to display a smaller-scaled map of the area.  Continue 

selecting map icons and looking for a release icon at the site.  Select 

the icon to display a scenario selection list.  

 

If the base map has no release or map location icons, select the Main 

Input from the Window menu to display the input window.  Then, 

select the Scenarios command from the File menu to display the 

selection list. 

If the Main CHARM Input Window is displayed instead of a map, you 

can select a map using the Basemap command on the Displays 
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menu.  Then follow the procedures described previously, as if a base 

map was initially displayed. 

10. If the Auto Met Polling command on the MetFile menu is not enabled, CHARM 

displays a dialog box indicating that automatic met data are not available. 

 

Select OK or press <Enter> to continue calculations without 

automatic data, or select Cancel to stop.  You may want to go to the 

Main CHARM Input Window and change the default met parameters. 

If automatic met polling is available, CHARM displays a dialog box 

requesting the time of release in 24-hour clock time.  Then CHARM 

begins performing the calculations.  Depending on the mode of 

operation defined by the EmergencyMode variable in CHARM.INI, 

CHARM will proceed to calculate in one of two manners.  If 

EmergencyMode = 1 or is not defined, then CHARM will display a 

real-time footprint, updating the display minute by minute.  If 

EmergencyMode = 0, CHARM calculations continue for the duration 

of the emission plus 30 minutes.  Then, the time used for the 

footprint display is the time at which the lowest value of interest (e.g. 

concentration) has maximum areal extent. 

11. Use the commands on the Options and Displays menus to show the desired 

information.  More than one display can be viewed on the same screen at a time.  

Refer to CHAPTER 6, "Understanding CHARM Displays," for detailed information. 

12. Press the F1 key to access on-line help.  CHARM displays those commands and 

procedures available for the Basemap window.  Refer to Chapter 8, “Menu and 

Command Reference” for detailed information. 

Real-Time Met Data Acquisition (METINTER)  

METINTER.EXE is a separate standalone program which provides the 

interface between external meteorological data and the CHARM 

program.  The program is represented by an icon with the sun, cloud, 

and rain in the CHARM group. 
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Each MetInter program has been customized for the specific 

meteorological data logger of file to be accessed.  There are only a few 

options available in the program. 

CHARMED must be run before MetInter will operate properly.  

CHARMED is used to define the Communications Parameters to be used 

by MetInter.  See section “Setting the Communications Parameters” in 

CHAPTER 4: Using the CHARM Editor for more information. 

MetInter uses the concepts of station and site.  A station is a location 

which can be directly accessed or dialed up.  A station may have data 

for multiple sites.  MetInter can interface to a single station at any one 

time.  The data from all the sites will be collected and stored.  The data 

from only one site will be displayed in the MetInter Data Window.  If the 

User Inverse Square command is selected from the MetFile menu in 

CHARM, then the data from all sites are used to determine the 

meteorological parameters at a specific point.  Otherwise, only the data 

in the MetInter Data Window will be used by CHARM. 

The METINTER Window 

The METINTER window has only two menus:  the Help Menu for 

acquiring on-line help, and the Options menu. 

The Options menu provides a command for each of the following: 

Data Window 

Visible 

Makes the Data Window visible 

or invisible. 

Data Window on 

Top 

Forces the Data Window to 

always be displayed in front of all 

other windows. 

Select Met Station Allows the selection of which 

station MetInter should connect 

to. 

Select Met Site Allows the selection of which site 

at a station will have its data 

displayed in the Data Window. 

Exit Exits Metinter. 

 

Data Window Visible Command 
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This option toggles whether the Data Window is visible or not.  If active 

the Data Window will be visible.  If the Data Window on Top option is 

selected, then the Data Window will always be forced in front of all other 

windows.  Otherwise the Data Window may be hidden by other 

windows.  If the Data Window has been selected to be visible, then this 

option will have a check mark next to it. 

Data Window on Top Command 

This option toggles whether the Data Window is always in front of all 

other windows or not.  If active, the Data Window will be in front of all 

other windows, even those in another application.  The Data Window 

Visible command must also be selected to see the Data Window.  If the 

Data Window has been selected to be on top, then this option will have 

a check mark next to it. 

Select Met Station Command 

Select the station for MetInter to connect to.  See the section “Defining 

Stations ID’s” in CHAPTER 4: Using the CHARM Editor for more 

information on defining stations to be used with MetInter.  Only one 

station can be connected with MetInter at any one time.  The data from 

all other met stations may be lost (depending on the data logger at the 

station). 

A station may have one or more sites connected to it.  If the Use Inverse 

Square command from the MetFile menu has been selected in CHARM, 

the data from all the sites will be used to determine the meteorological 

data at any point.  The data from one site can be displayed in the Data 

Window.  The site which will have its data displayed is selected using 

the Select Met Site command. 

Select Met Site Command 

Select which met site at the current station will have its data displayed 

in the Data Window.  See the section “Defining Site ID’s” in CHAPTER 4: 

Using the CHARM Editor for more information on defining sites to be 

used with MetInter.  Only one station can be connected with MetInter at 

any one time.  Only one site at that station can have it’s data displayed 

in the Data Window.  The station to connect to is selected by the Select 

Met Station command. 

A station may have one or more sites connected to it.  If the Use Inverse 

Square command from the MetFile menu has been selected in CHARM, 
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then the data from all the sites will be used to determine the 

meteorological data at any point.  Otherwise, CHARM will use the data 

in the Data Window.
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Chapter 8: Using the TIGERMAP Utility 

CHARM has the capability of predicting population impacts based on 

U.S. Census Bureau Tiger/Line™ 1992 data.  The TIGERMAP utility is a 

preprocessor which is used to extract only the information necessary for 

use with CHARM.  The program reads U.S. Census Bureau Tiger/Line™ 

1992 data (available on CD-ROM) and creates maps and/or population 

files.  An icon for starting TIGERMAP is in the CHARM Group box. 

 

Contact the U.S. Census Bureau directly for ordering the data files 

needed.  Their number is (301) 457-4100.  Once the TigerLine data has 

been preprocessed, files for use with CHARM must be selected in 

CHARMED (see section “Defining Population Files for Use With CHARM” 

in CHAPTER 4 “Using the CHARM Editor”).  Once the files have been 

selected in CHARMED, select the Population Impacts command from the 

Displays menu on a footprint display in CHARM (see section “Population 

Impacts” in CHAPTER 6 “Understanding CHARM Displays”). 

The TIGERMAP Window 

Like CHARM, the main TIGERMAP window is an MDI frame with several 

menus.  The View and Help menus contain the standard commands 

found in other CHARM related programs.  The File menu contains the 

following commands: 

New Creates a Map or Population 

window. 

Open Opens a preprocessed TigerMap 

Map or Population file. 

Recent File Shows up to the last four files 

used. 

Exit Exits TigerMap. 

 

Selecting the New command will prompt the user for the type data to 

pre-process - geographical information or population data.  Selecting 
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Tiger Map File will process geographical information while selecting Tiger 

Polygon File will process population tracts. 

 

 

Processing Tiger/Line Geographical Data 

File Menu 

Once the New command has been selected or a data file has been opened 

with the Open command on the File menu, the TIGERMAP MDI menu 

bar changes appropriately.  The following menu commands become 

available from the File menu for Tiger Map File: 

New Creates a new map or 

polygon window. 

Open Opens an existing map or 

polygon file.  

Close Closes the active window. 

Save Saves an opened file using 

the same file name. 

Save As Save a file to a specified 

file name. 

Process Tiger Map Requests a state and 

county to process into a 

map. 

Merge Tigers To 

Clipboard 

Requests a number of map 

files to merge and send to 

the clipboard. 

Exit Exits TigerMap 
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Process TigerMap Command 

Use this command to create a map file in TigerMap.  You will be asked to 

select the state and county or district to process.   

 

The Census data is on a county by county basis.  Each county needed 

has to be processed separately.  Later the maps of each county can be 

merged into one map with the use of the Merge Tigers To Clipboard 

command.  The following figure illustrates output from processing the 

geographical information from Tiger/Line data. 

 

Merge Tigers to Clipboard Command 

Use this command to merge a number of county maps into a single map.  

The following example dialog box displays pre-processed Tiger/Line 

map files for selection to be merged. 
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To select multiple files, hold down the <Ctrl> key while left mouse 

clicking on the desired .TGR files.  Select Open and the resulting merged 

map will be sent to the clipboard where it can be accessed by the Map 

Definition Utility in CHARMED or a drawing program capable of 

accessing a Windows Metafile.  You will be asked to select the files to 

process.  When the merging is done the last county read is displayed.  

Each county map processing is done with the Process Tiger Map 

command. 

Edit Menu 

The Edit menu offers the following commands: 

Zoom Displays an enlargement of 

a specified map area. 

Unzoom  Returns a zoomed map 

display to its original size 

when the window was 

created/opened. 

Show Text Display text. 

Set Text Size If text is being displayed, 

set the size of text. 

Set Latitude/ Longitude 

Limits 

Use this command to 

define latitude and 

longitude limits to be used 

when creating a map file. 

Set Tiger Data Directory This dialog box allows you 

to define the location of 

the Census Bureau 
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CDROM data. 

 

Zoom/Unzoom Commands 

Use this command to zoom a portion of the map display.  Select the 

Zoom command from the Edit menu.  The cursor changes from a pointer 

to a magnifying glass.  Next, move the cursor to one corner of the area to 

be zoomed.  If you are using a mouse, hold the left mouse button down, 

move the cursor to the opposite corner of the area to be zoomed , and 

release the button.  During this process, notice that a rubberband box is 

drawn around the area that you intend to zoom until you release the left 

mouse button. 

If you are not using a mouse, press <ENTER> to mark the first corner of 

the zoom box, expand the box with the arrow keys, and press < Enter> 

again to complete the zoom box.  The zoom display may not have a one-

to-one correlation to the marked area.  To return to the initial map 

display, select the Unzoom command from the Edit menu. 

Show Text Command 

Use this command to have the text drawn with the map file.  The text is 

the label for each object.  The amount of text for a map can be quite large 

and take a long time for a redraw. 

Note:  If this option is set, then text will be sent to the clipboard along with 

the rest of a map or polygon drawing.  Sending text along with a map can 

make redrawing very slow. 

The text will not be drawn regardless if this option is selected or not if the 

drawn text would be too small to be seen legibly.  The text size can be set 

by the Set Text Size command. 

Set Text Size Command 

Use this command to set relative map text size.  When a map file is first 

displayed a default text size is assumed.  The default text size depends 

on the areal coverage of the map file.  This option can be selected to 

change the size.  The default size is 1.0.  To double the text size use 2.0.  

To halve the text size use 0.5.  Whether text is displayed at all can be 

controlled by the Show Text command. 
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Set Latitude/Longitude Limits Command 

Use this command to define latitude and longitude limits to be used 

when creating a map file.  If a feature lies completely outside of the limits 

it is not made part of the map.  If part of a feature (e.g. street segment) is 

inside the limits it will be drawn. 

 

Set Tiger Directory Command 

This dialog box allows you to define the location of the Census Bureau 

CDROM data.  For example, if your CD is on drive D the directory would 

be D:\.  Use the Browse button to search and set the drive and directory 

where the Tiger/Line data exists. 
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Processing Tiger/Line Population Files 

File Menu 

Once the New command has been selected or a data file has been opened 

with the Open command on the File menu, the TIGERMAP MDI menu 

bar changes appropriately.  The following menu commands become 

available from the File menu for Tiger Map File: 

New Creates a new map or polygon 

window. 

Open Opens an existing map or polygon 

file.  

Close Closes the active window. 

Save Saves an opened file using the 

same file name. 

Save As Save a file to a specified file name. 

Process Population 

File 

Requests a state and county to 

process into a population polygon 

file. 

Merge Pop Files To 

Clipboard 

Requests a number of population 

files to merge and send to the 

clipboard. 

Import Landview II 

Data 

Use this command to create a 

population polygon file in 

TigerMap.  You will be asked to 

select the state and county or 

district to process.  The Landview 

II data is on a county by county 
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basis. 

Exit Exits TigerMap 

 

Process Population File Command 

Use this command to create a population polygon file in TigerMap.  You 

will be asked to select the state or county or district to process.   

 

The Census data is on a county by county basis.  Each county needed 

has to be processed separately.  Later the polygon files of each county 

can be merged into a map with the use of the Merge Pop. Files To 

Clipboard command.  More importantly these population files can be 

declared in CHARMED so that CHARM may use them to determine 

calculation impacts from a concentration, thermal radiation, or 

overpressure footprint. The following figure illustrates the results of 

processing the data. 
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The TigerMap Utility associates total number of people with each tract, 

along with some other data including age, race, home owners, and 

renters.  Later in CHARM when determining population impacts, CHARM 

assumes that the total number of people in a tract is uniformly dispersed 

throughout the tract. 

Merge Pop. Files To Clipboard Command 

Use this command to merge a number of county polygon population files 

into a map.  The resulting map will be sent to the clipboard where it can 

be accessed by CHARMED or a drawing program capable of accessing a 

Windows Metafile.  You will be asked to select the files to process.  When 

the merging is done the last county read is displayed.  Each county 

needs to be processed into a population file separately.  County 

population processing is done with the Process Population File 

command. 

Import Landview II Data Command 

Use this command to create a population polygon file in TigerMap.  You 

will be asked to select the state and county or district to process.  The 

Landview II data is on a county by county basis.  Each county needed 

has to be processed separately.  Later the polygon files of each county 

can be merged into a map with the use of the Merge Pop. Files To 

Clipboard command.  More importantly these population files can be 

declared in CHARMED so that CHARM may use them to determine 

calculation impacts from a concentration, thermal radiation, or 

overpressure footprint. 

The Landview II data can be put on your hard disk after purchasing a 

Landview CDROM by following the instructions provided.  You can also 

download the data from the Internet.  Simple instructions are: 
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1.  Go to site http://www.RTK.NET/landview. 

2.  Select the desired County and State and press the Submit Query 

button. 

3.  If you want the complete Landview system download all the files and 

follow instructions. 

4.  If you only need the data for inclusion into CHARM you only need to 

download the Dbase files, the MARPLOT files, and the installation script. 

5.  Put the downloaded files into a directory for expansion. 

6.  Run the batch file lvinstal.  Ignore any error messages. 

7.  Define the Data Directory in Tigermap as the directory where the files 

were expanded. 

The batch file lvinstal will write over any files of the same names already 

in the directory. 

For Tigermap to work the only files required are: 

In the directory where the expansion occurred - states.dbf, counties.dbf, 

and cen_blkg.dbf. 

Two subdirectories down (the county subdirectory) - censusb.sum and 

censusb.obj 

Edit Menu 

The Edit menu offers the following commands: 

Zoom Displays an enlargement of a 

specified map area. 

 

Unzoom  Returns a zoomed map display to its 

original size when the window was 

created/opened. 

Show Text Display text. 

Set Text Size If text is being displayed, set the size 

of text. 

Set Latitude/ 

Longitude 

Point 

Defines a Latitude/Longitude point 

in the x/y Cartesian coordinate 

system to be used in CHARMED. 

Set Tiger 

Data 

Directory 

This dialog box allows you to define 

the location of the Census Bureau 

CDROM data. 
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Zoom/Unzoom Commands 

Use this command to zoom a portion of the map display.  Select the 

Zoom command from the Edit menu.  The cursor changes from a pointer 

to a magnifying glass.  Next, move the cursor to one corner of the area to 

be zoomed.  If you are using a mouse, hold the left mouse button down, 

move the cursor to the opposite corner of the area to be zoomed , and 

release the button.  During this process, notice that a rubberband box is 

drawn around the area that you intend to zoom until you release the left 

mouse button. 

If you are not using a mouse, press <ENTER> to mark the first corner of 

the zoom box, expand the box with the arrow keys, and press < Enter> 

again to complete the zoom box.  The zoom display may not have a one-

to-one correlation to the marked area.  To return to the initial map 

display, select the Unzoom command from the Edit menu. 

Show Text Command 

Use this command to have the text drawn with the tract data.  The text is 

the population for each tract. 

Note:  If this option is set, then text will be sent to the clipboard 

along with the rest of a map or polygon drawing. 

The text will not be drawn regardless if this option is selected or not if the 

drawn text would be too small to be seen legibly.  The text size can be set 

by the Set Text Size command. 

Set Text Size Command 

Use this command to set relative map text size.  When a map file is first 

displayed a default text size is assumed.  The default text size depends 

on the areal coverage of the map file.  This option can be selected to 

change the size.  The default size is 1.0.  To double the text size use 2.0.  

To halve the text size use 0.5.  Whether text is displayed at all can be 

controlled by the Show Text command. 
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Set Latitude/Longitude Point Command 

Use this command to define latitude and longitude point which 

corresponds to a Cartesian coordinate in the reference frame used for 

defining the location of maps and release sites.  This is required so that 

CHARM knows where the population polygons are with respect to a 

footprint. 

 

Set Tiger Directory Command 

This dialog box allows you to define the location of the Census Bureau 

CDROM data.  For example, if your CD is on drive D the directory would 

be D:\.  Use the Browse button to search and set the drive and directory 

where the Tiger/Line data exists. 
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Creating a Map File for Use With CHARM 

To create a map for use with CHARM using U.S. Census Bureau 

Tiger/Line™ 1992 data, follow these steps: 

1. Upon selecting New from the File menu, select TigerMap File from the 

New window. 

 

 

2. Select the Process Tiger Map command in the File menu and press 

<OK>. 

3. In the dialog boxes with follow, select the state and county to process.  

If only one state is available for selection, the state selection will be 

skipped. 

4. Wait for the processing to be complete.  This can take a very long 

time.  Pressing cancel on the progress dialog box will stop the 

processing and all information will be lost. 

5. Save the map file with the Save As command in the File menu. 

6. Select the Merge Tigers To Clipboard command. 

7. Run CHARMED
©
. 
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8. Select Map Definition in CHARMED. 

9. Paste the map in the clipboard into CHARMED.  See ‘Defining Maps 

for Use with CHARM’ in CHAPTER 4: Using  the CHARM Editor for 

more information on defining the map. 

Once you have created and defined those files for use with CHARM using 

TIGERMAP and CHARMED, you can display the map two different ways 

in CHARM.  For more information on displaying a map in CHARM, see 

CHAPTER 6 :CHARM Displays. 

Creating a Population File for Use With CHARM 

To create a population file for use with CHARM using U.S. Census 

Bureau Tiger/Line™ 1992 data, follow these steps: 

1. Upon selecting New from the File menu, select Tiger Polygon from the 

New window. 

 

 

2. Select the Process Population command in the file menu. 

3. In the dialog boxes which follow select the state and county to 

process.  If only one state is available for selection, the state selection 

will be skipped. 

4. Wait for the processing to be complete.  This can take a very long 

time.  Pressing cancel on the progress dialog box will stop the 

processing and all information will be lost. 

5. Save the population file with the Save As command in the File menu. 

6. Select the Merge Pop. Files To Clipboard command. 

7. Run CHARMED
©
. 

8. Define the population files(s) using the Select Population Files 

command in CHARMED. 
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Once you have created and defined those files for use with CHARM using 

TIGERMAP and CHARMED, you can calculate population impacts from a 

plan footprint display in CHARM. 

For more information on calculating population impacts in CHARM, see 

CHAPTER 6 “CHARM Displays”.
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Chapter 9:  Menu and Command Quick Reference 

The purpose of this reference is to help you quickly find related 

information for CHARM menus and commands in this manual.  The 

menus are listed in alphabetical order.  The commands are listed as close 

as possible to their locations on the menus.  Although this list provides a 

complete command listing, some commands appear only on the menus of 

specific CHARM displays, while other commands appear shaded on the 

menu and are not currently selectable.  If a command is fully described 

in this reference, no page number is given.  The menus will exist in 

CHARM, CHARMED, and/or the TIGERMAP Utility. 

Define Menu (Map Definition Window in CHARMED) 

Zoom  Page 73  

Displays an enlarged map of the specified area of the current map 

display. 

Unzoom  Page 73 

Returns a zoomed map area to its initial size when the window was 

opened. 

Change Default Size  

An unzoomed map size can be changed be entering a scale factor in a 

map window.    

Define Point Page 74 

Define an x,y point of reference for a map you intend to display in 

CHARM. 

Define Scale Page 75 

Display a scale for a map you intend to display in CHARM. 

Define Map Location Page 77 

Place an icon on a map display that points to another map. 

Define Release Location Page 78 

Place an icon on a map display that identifies the location of one or more 

defined release scenarios. 

Define Expand Map Name Page 82 

Specify the name of a larger scaled map than the one being defined. 

Map Description Page 79 



Menu and Command Quick Reference   

 

254 

Allows the user to define pertinent information describing the currently 

displayed map. 

 

Displays Menu (Main CHARM Input Window) 

When the Displays menu is selected, the cursor changes momentarily to 

an hour glass as CHARM calculates the source term. 

Basemap  Page 160 

Displays a map which has been created with third party software and 

defined in the CHARM Editor CHARMED for use in emergency response 

mode. 

Site Information Page 161 

Displays a text file window containing site-specific information. This 

information may contain emergency phone numbers, evacuation routes, 

etc.  

Chemical Data Page 162 

Displays thermodynamic data and plot concentrations from the chemical 

database for the selected species.   

Chemical Response Page 163 

Displays a text window containing the emergency response information 

for the selected chemical species of interest. 

Source/Puff Calculation Page 164 

Displays the description resulting from the source term calculations 

using in the Main CHARM Input Window for data.    

Emission Rate Page 166 

Displays a plot of the emission rate as a function of time for the input 

data in the Main CHARM Input Window. 

BLEVE Radiation Page 166 

Displays a footprint of thermal radiation resulting from a fireball/BLEVE. 

Pool Fire  Page 169 

Displays a submenu for selecting the footprint of the thermal radiation 

associated with the fire, or a plume of the unburned material of interest 

that makes it through the flames. 

Jet Fire Radiation Page 169 
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Displays the footprint of thermal radiation resulting from a jet fire. 

Mechanical Overpressures  Page 172 

Displays a footprint of potential overpressures from a bursting sphere. 

Plume   Page 174 

Displays a snapshot view of the plume at the specified time after release. 

Displays Menu (Plan Footprint View) 

Maximum Distance Page 195 

Plots the maximum distance downwind of the specified concentration as 

a function of time.   

Maximum Width Page 197 

Plots maximum crosswind width of a user specified concentration as a 

function of time.   

Maximum Concentration Page 199 

Displays a table of maximum concentrations as a function of time. 

Vertical Xsection Page 200 

Plots a vertical cross-section through the middle of the plume.  The line 

of sight runs from the release site through the middle of the initial puff. 

3D Plume Page 225 

Presents a three dimensional view of a concentration plume. 

Centerline Concentrations Page 201 

Plots the concentrations down the centerline of the plume as a function 

of distance.  

Plume Half-Widths Page 203 

Determines the crosswind half-width down the centerline of the plume as 

a function of concentration. 

Met Data  Page 206 

Shows the meteorological data at the source location at the present 

receptor height and at the time specified for the Snapshot Plan Plume 

View display. 

Integrated Area Page 206 

Starts a minute by minute calculation of the plume display, showing all 

areas affected by the plume.   
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Time Averaged Footprint Page 208 

Displays a time averaged plume based on the user-defined averaging 

interval and the user-defined grid size.  The user will be prompted for the 

averaging time and grid resolution.  The user has the option of selecting 

an area of the footprint or the entire plume from a submenu. 

Circular Population Impact Page 210 

Predicts population impacts using Census Bureau data.  The impacted 

area is a circular region described by the user by specifying a radius out 

from the source location. 

Population Impact Page 212 

Predicts population impacts using Census Bureau data.  The number of 

people impacted depend on the Population Calculation type. 

Population Calculation Page 213 

Select the type of calculation to use when predicting population impacts. 

Explosion Overpressures Page 214 

Shows a footprint of potential overpressures if the displayed cloud 

ignited. 

Input   

Shows the input data for the current CHARM run just as it appeared in 

the Main CHARM Input Window.  

Source/Puff Calculation Page 164 

Shows the output of the source term calculation for the CHARM run that 

created the current plan plume view.   

Emission Rate Page 166 

Shows a plot of the emission rate as a function of time throughout the 

release. 

Site Information Page 161 

Displays a text file window containing site-specific information. 

Chemical Data Page 162 

Displays thermodynamic data and plot concentrations from the chemical 

database for the selected species. 

Chemical Response Page 163 

Displays a text window containing the emergency response information 

for the selected chemical species. 
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Visual Verify Page 211 

Displays the population tracts relative to the plume in order to visually 

verify that the plume indeed overlays the population tracts appropriately.  

The number of people affected within a tract will be displayed over the 

number representing the total population for that tract.  If it is 

determined that the plume is not correctly overlayed on the population 

tracts, the user may adjust the inaccuracy by repositioning the plume or 

redefining the lat/long point within the TigerMap Utility. 

 

Edit Menu (Plan Footprint Displays) 

Copy  

Sends text and/or graphics in the current window to the Windows 

clipboard where it can be retrieved by other programs.  If the window 

contains text only, all the text (visible or not) is sent to the clipboard.  If 

the window contains graphics, a bitmap and a metafile representation of 

the visible contents of the window is sent to the clipboard. 

Change Run Title 

Changes the title of the CHARM run and all windows that are using the 

same data.   

Edit Menu (TIGERMAP Utility) 

Zoom  Page 242 

Displays an enlarged map of the specified area of the current map 

display. 

Unzoom  Page 242 

Returns a zoomed map area to its initial size when the window was 

opened. 

Show Text Page 242 

Use this command to have the text drawn with the map or polygon file.  

If the drawing is a polygon file the text is the population for each polygon 

drawn at the geometric center of the polygon.  If the drawing is a map file 

the text is the label for each object.  The amount of text for a map can be 

quite large and take a long time for a redraw.  The text will not be drawn 

regardless if this option is selected or not if the drawn text would be too 

small to be seen legibly.  The text size can be set by the Set Text Size 

command. 
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Set Text Size Page 242 

Use this command to set relative map text size.  When a map file is first 

displayed a default text size is assumed.  The default text size depends 

on the areal coverage of the map file.  This option can be selected to 

change the size.  The default size is 1.0.  To double the text size use 2.0.  

To halve the text size use 0.5.  Whether text is displayed at all can be 

controlled by the Show Text command. 

Set Latitude/Longitude Limits Page 243 

Use this command to define latitude and longitude limits to be used 

when creating a map file.  If a feature lies completely outside of the limits 

it is not made part of the map.  If part of a feature (e.g. street segment) is 

inside the limits it will be drawn. 

Set Latitude/Longitude Point Page 249 

Use this command to define a latitude and longitude point which 

corresponds to a Cartesian coordinate in the reference frame used for 

defining the location of maps and release sites.  This is required so that 

CHARM knows where the population polygons are with respect to a 

footprint. 

Set TIGER Data Directory Page 249 

This dialog box allows you to define the location of the Census Bureau 

CDROM data.  For example, if your CD is on drive D the directory would 

be D:\. 

 

 

Edit Menu (CHARM Editor) 

Chemical Database Page 59 

Add, modify, or delete species data in the chemical database. 

Import Previous Database Page 27 

Requests the path to the previous version of the CHARM database.  Once 

the path is entered, CHARM will attempt to update the current database 

from those records in the previous database. 

Update Plot Concentrations Page 27 

Requests the path to the previous version of the CHARM database.  Once 

the path is entered, CHARM will attempt to update the default plot 

concentrations in the current database from those records in the 

previous database.  The user will be prompted for verification. 
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Pack Chemical Database Page 64 

Physically removes logically deleted records from the chemical database. 

Local Met Comm Parameters Page 66 

Sets the parameters for local communications with a meteorological 

tower. 

Network Met Server Location Page 28 

Requests the name/location of the server from which the meteorological 

interface will run. 

File Location Page 28 

Specifies where CHARM can find CHARM system required  files. 

Site Information Page 64 

Allows site-specific information to be entered. 

Map Definition Page 72 

Reads maps to be defined for use in CHARM. 

Select Population Files Page 84 

Requests the names of the population files which were pre-processed 

using 1992 TigerLine Census Bureau data and the CHARM TIGERMAP 

Utility. 

Change Password Page 28 

Defines CHARM/System password to regulate CHARMED entry. 

Undo 

Undo the last text edit. 

Cut 

Remove the currently selected text from the active window and put it on 

the clipboard. 

Copy 

Copy the currently selected data from the active window and put it on 

the clipboard. 

Paste 

Insert a copy of the clipboard contents into the active window at the 

insertion point. 

Copy Data Page 37 

Copy the data in the Chemical Data Sheet to the clipboard in comma 



Menu and Command Quick Reference   

 

260 

delimited format in the order it is displayed in the Chemical Data 

Window. 

Paste Data Page 37 

Paste the comma delimited data from the clipboard into the Chemical 

Data Sheet in the order it is displayed in the Chemical Data Window. 

Import From DIPPR Page 37 

Displays a selection list of all the species in the DIPPR chemical database 

for import into the CHARM database. 

Exit 

Exits CHARMED and closes the main CHARMED MDI window.  If the 

Prompt at Exit command on the Options menu is selected, CHARMED 

will first prompt the user before exiting.  If changes were made, the user 

is prompted as to whether or not the changes should be stored.  The Exit 

command functions the same in CHARMED as it does in other Windows 

programs. 

File Menu 

Emergency Response Text Page 61 

Modifies emergency response text that is specific to the chemical of 

interest in the CHARM Editor. 

Monochrome Page 200 

Remove the color from the vertical cross-section, thereby displaying only 

the hatch marks. 

Table 

View the current plot as records of numbers. 

New  Page 94 

Restores all the values on the Main CHARM Input Window to their 

default values. 

Open  Page 94 

Displays a dialog box requesting the name of an input file to open.   

Copy 

Sends text and/or graphics in the current window to the Windows 

clipboard where it can be retrieved by other programs.  If the window 

contains text only, all the text (visible or not) is sent to the clipboard.  If 

the window contains graphics, a bitmap and a metafile representation of 

the visible contents of the window is sent to the clipboard. 

Scenarios Page 94 
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Displays a selection list of the titles of release scenarios created and 

stored previously in CHARM.  

Save  Page 96 

Saves the input data from the Main CHARM Input Window.   

Save As  Page 96 

Displays a dialog box in which you can enter the name of the file being 

saved. 

Save Input As  

Saves the release description input data for the current plan plume view 

under a different, user-specified file name. 

Save Met As 

Saves the meteorological input data for the current plan plume view 

under a different, user-specified file name. 

Print 

Prints all the text contained in the current window, whether the text is 

visible or not. This is a standard command for most text windows.  For 

graphics windows, this command will print the display in the current 

window. 

Print Preview Page 97 

Prints all the text and graphics contained in the current window.  This is 

a standard command for most text windows. 

Printer Setup Page 97 

Allows the user to change the current printer configuration. 

Save As Default Page 93 

Saves the current scenario described in the CHARM Input Window as the 

default scenario. 

Close 

Closes the active CHARM window in the CHARM MDI.  Select the Exit 

command (described below) to terminate CHARM. 

Larger Scale Map Page 189 

Displays a larger-scaled map that has been defined and assigned an 

expanded map name. 

Process Population File Page 245 

Use this command to create a population polygon file in TigerMap.  

You will be asked to select the state and county or district to process.  
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The Census data is on a county by county basis.  Each county needed 

has to be processed separately. 

Import Landview II Data Page 246 

Use this command to create a population polygon file in TigerMap.  You 

will be asked to select the state and county or district to process.  The 

Landview II data is on a county by county basis.  Each county needed 

has to be processed separately. 

Merge Pop Files to Clipboard Page 246 

Use this command to merge a number of county polygon population files 

into a map.  The resulting map will be sent to the clipboard where it can 

be accessed by CHARMED or a drawing program capable of accessing a 

Windows Metafile.  You will be asked to select the files to process.  When 

the merging is done the last county read is displayed.  Each county 

needs to be processed into a population file separately.  County 

population processing is done with the Process Population File 

command. 

Process Tiger Map Page 250 

Use this command to create a map file in TigerMap.  You will be asked to 

select the state and county or district to process.  The Census data is on 

a county by county basis.  Each county needed has to be processed 

separately. This command has been removed. 

Merge Tigers to Clipboard Page 250 

Use this command to merge a number of county maps into a single map.  

The resulting map will be sent to the clipboard where it can be accessed 

by CHARMED or a drawing program capable of accessing a Windows 

Metafile.  You will be asked to select the files to process.  When the 

merging is done the last county read is displayed.  Each county needs to 

be processed into a map separately.  County map processing is done with 

the Process Tiger Map command. This command has been removed. 
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Exit 

Exits CHARM and closes the main CHARM MDI window.  If the Prompt 

at Exit command on the Options menu is selected, CHARM will first 

prompt the user before exiting.   If changes were made, the user is 

prompted as to whether or not the changes should be stored.  The Exit 

command functions the same in CHARM as it does in other Windows 

programs. 

Help Menu 

Help 

Offers you help on the current task or command. 

Index 

Offers an index to topics on which you can get help. 

Using Help 

Provides general instructions on using help. 

Search for Help On 

Displays a list of keywords used in CHARM from which a list of related 

topics may be displayed. 

About 

Displays the version number and standard information required by 

Windows.  This is a standard Windows command. 

MetFile Menu 

New  Page 99 

Restores all met data fields to their default values. 

Open  Page 100 

Displays a dialog box requesting the name of a met file to open.   

Save  Page 101 

Saves the current met data in a user-specified file.   

Save As  Page 101 

Saves the met data under a different, user-specified file name.  

Save As Default Page 99 

Saves the current met data described in the CHARM Input Window as 

the default met data. 
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Solar Radiation Worksheet Page 101 

Use a worksheet to determine solar radiation value.  Solar radiation is a 

function of latitude/longitude, cloud cover, time of day, and the day of 

the year.  

Automatic Poll Page 101 

Initiates conversation between CHARM and the met interface 

(METINTER.EXE) to automatically read stored meteorological data.    

Stop Poll  Page 100 

Signals CHARM to stop real-time data acquisition. 

Use Inverse Square Page 100 

Invokes inverse square weighting algorithm for use with multiple sites 

when using real-time data acquisition. 

Calculate Solar Radiation Page 100 

Calculates the solar radiation as real-time met data is acquired. 

Options Menu (Main CHARM Input Window) 

Prompt At Exit Page 103 

Switch to prompt the user before exiting CHARM. 

Time is Minutes-Seconds Page 103 

Switch to run CHARM in Minutes/Seconds mode or Hours/Minutes 

mode. 

Options Menu (Basemap Window) 

Zoom  Page 224 

Displays an enlarged map of the specified area of the current map 

display. 

Unzoom  Page 224 

Returns a zoomed map area to its initial size when the window was 

opened. 

Map Description Page 188 

Allows the user to view pertinent information describing the currently 

displayed map. 
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Options Menu (Plan Footprint Displays) 

Recalculate Page 208 

Recalculated the impacted area from the beginning on an Integrated Area 

Display. 

Continue  Page 207 

Continues simulation of the currently displayed plume integration on an 

Integrated Area Display. 

Overpressures Page 173 

Specifies up to three pressure values for the three distances shown on an 

Overpressure footprint display. 

Distances Page 174 

Specifies up to three distances from the source for the pressure and 

energy flux values shown on a BLEVE Thermal Radiation  or Mechanical 

Overpressures footprint display. 

Energy Fluxes Page 167 

Specifies up to three energy flux values for the three distances shown on 

a BLEVE Thermal Radiation display. 

Isopleths  Page 180 

Specifies the concentrations plotted on plume displays, graphs, and 

tables. 

Averaging Time Page 181 

Enter the averaging time in minutes from 1 to the present plot time for a 

time averaged plume. The average taken is the running average. The 

concentrations at a specific point are averaged over time to determine a 

time-weighted average. 

Grid Size  Page 182 

Enter the number of points to be used in the grid when generating a 

Time-Averaged Plume.  The grid is 2-dimensional and, therefore, the user 

must enter the number of points in the X direction (East/West) and the Y 

direction (North/South). 

Time Averaged Footprint  Page 208 

Displays a time averaged plume based on the user-defined averaging 

interval and the user-defined grid size. The user has the option of 

selecting an area of the footprint or the entire plume from a submenu. 
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Show Grid Page 182 

This option removes/shows the user-defined grid for the Time-Averaged 

Plume.  A check by the menu item displays the grid, whereas no check 

by the menu item indicates the option is not active and the grid is not 

visible. 

Grid Display Page 182 

If the Show Grid option is on, this option displays the user-defined grid 

for the Time-Averaged Plume as a series of points or as a wire mesh.  A 

check by either menu item indicates this option is turned on, whereas no 

check by the menu item indicates the option is not active and the grid 

points are not visible. 

Scale Radius Page 183 

Changes the radius of the view port (solid circle) on the plume display 

according to a user-specified scale.  

Scale Ratio Page 184 

Changes the radius of the view port according to a user-specified ratio.  

Distance Circles Page 184 

To supplement the display of a plan view, additional circles can be drawn 

for a given radial increment within the large circle. 

Receptor Height Page 185 

Specifies the height above ground of the display.  

Transparency Page 185 

Changes the display from a colored, opaque plume to a "ghost" plume 

denoted only by concentration hatch marks, thereby allowing the map 

areas beneath the plume to be seen.  

No Hatch  Page 185 

A toggle indicating whether or not the hatch marks on a footprint display 

and in the legend are displayed.  A check by the menu item indicates this 

option is turned on, whereas no check by the menu item indicates the 

option is not active and the hatch marks are visible. 

Use Auto Scale Page 186 

A toggle switch indicating that CHARM will automatically scale the 

display to show the entire footprint whenever aspect changes are made to 

the display. A check by the menu item indicates this option is turned on, 

whereas no check by the menu item indicates the option is not active 

and that CHARM will automatically scale the display. 
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Decay  Page 186 

Specifies the time (half-life) required for half of the emitted material to 

decay into neutral products.    

Map  Page 186 

Displays a dialog box in which you can select a map to display.   

No Map  Page 187 

Removes current map from display. 

Location  Page 187 

Relocates the source of the release on the current map display. 

Map Description Page 187 

Displays pertinent information describing the currently displayed map. 

Reset Source Page 188 

Resets the position of the source to the center of the view port. 

Auto Map Change Page 188 

Enables CHARM to automatically display a larger-scaled map when the 

scale of the current map display is not large enough to cover a significant 

portion of the plot area.  If checked, CHARM will attempt to select the 

map with best coverage. 

Auto Map Fraction Page 188 

Defines the fraction of the footprint display area which must be covered 

by a map to preclude CHARM from trying to go to a larger scale map. 

Larger Scale Map Page 189 

Displays the larger-scaled map associated with the current map. 

New Time Page 189 

Specifies the time since release for the footprint display.   

Time Circles Page 189 

Draws dashed circles around the source that indicate the location to 

which the current wind speed can move a parcel of air from the source in 

the number of minutes specified.  

Replay 

Once a Snapshot Plan Plume View display has been generated, the user 

may display the plume at every minute (or every second if Time mode is 

Minutes-Seconds) up to the current time since release.  The user may 

cancel the automation at any time before the current time since 

release by hitting the <Cancel> button in the display window..  
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Create ASCII File Page 190 

Generates a file to hold a description of a footprint of impact 

(concentration, thermal radiation, or overpressure) which can be 

transferred to other programs. 

Create Shape File Page 193 

This command enables the user to generate a file which describes a 

footprint of impact (concentration, thermal radiation, or overpressure) 

which can be transferred to ArcView for display. 

Observer Location Page 227 

Change the location of the observer in a 3-dimensional display of a 

plume. 

Observed Point Page 227 

Change the location of the observed point in a 3-dimensional display of a 

plume. 

Observer Step Distances Page 228 

Change the incremental stepsizes of the observer when altering the 

location of the observer in a 3-dimensional display of a plume. 

Z Scale  Page 229 

Enter a dimensionless number to scale the plume z coordinates in the 3-

dimensional plume display. 

Monochrome Page 183 

Remove the color from the 3D Plume view, thereby displaying only the 3D 

frame. 

View Menu 

Status Bar 

The status bar is displayed at the bottom of the CHARM window.  To 

display or hide the status bar, use the Status Bar command in the View 

menu. 

The left area of the status bar describes actions of menu items as you 

use the arrow keys to navigate through menus.  This area similarly 

shows messages that describe the actions of toolbar buttons as you 

depress them, before releasing them.  If after viewing the description of 

the toolbar button command you wish not to execute the command, then 

release the mouse button while the pointer is off the toolbar button. 
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The right areas of the status bar indicate which of the following keys are 

latched down: 

Indicator Description 

CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

 

 

Window Menu 

Cascade 

Arranges multiple opened windows in an overlapped fashion. 

Tile 

Vertically arranges multiple opened windows in a non-overlapped 

fashion. 

Arrange Icons 

Use this command to arrange the icons for minimized windows at the 

bottom of the main window.  If there is an open window at the bottom of 

the main window, then some or all of the icons may not be visible 

because they will be underneath this window. 

1, 2, … 

CHARM displays a list of currently open windows at the bottom of the 

Window menu.  A check mark appears in front of the name of the active 

window.  Choose a window from this list to make it the active window.
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Appendix A: Enhancements in CHARM Ver. 9.1 

Functional software changes in CHARM Version 9.1 that are not found in 

CHARM Version 9.0 include the following: 

• RMP distance is calculated for thermal radiation displays. 

• For (x,y) plot displays, the user may toggle a mesh grid on or off. 

• CHARM now supplies the user with container information as a species exits the 

container. 

• CHARM displays a list of the five most recently opened scenario files in the File 

menu in the Main CHARM Input. 

• CHARM displays a list of the five most recently opened meteorological files in the 

Met File menu in the Main CHARM Input Window. 

• When using a Container/Surface Release Type, CHARM will calculate the pool 

diameter/area using a depth of 1 cm to comply with RMP specifications. 

• Depending on the chemical, the solar radiation used for liquid evaporation may not 

be used completely for evaporation purposes. 

• You may define a time schedule for user-defined stability classes under the 

meteorological parameters. 

• You can execute the MS Windows Calculator program from within CHARM to do 

necessary calculations quickly and easily. 

• CHARM version 9.1 comes with documentation inserts into the version 9.0 User’s 

Manual, and updated on-line help, which includes information taken from quarterly 

training sessions. 

RMP Distance 

Risk Management Planning (RMP) dictates that flammables must be 

modeled and a distance determined at which 5 KW/m
2
 is attained for 40 

seconds. RMP distance is calculated in Fireball/BLEVE, Jet Fire, and 

Pool Fire Thermal Radiation displays.  Figures A-1 - A-3 illustrate where 

the RMP distance is displayed in each output. 
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Figure A-1 
BLEVE 
Display 
Illustrating 
RMP 
Distance 
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Grid Plots 

For all (x,y) plot displays, the user may toggle a mesh grid on or off by 

selecting/deselecting the 'Grid Plot' menu item under the 'File' menu.  

Figures A-4 and A-5 illustrate the mesh grid as it is (not) displayed on a 

plot. 

Figure A-2 
Jet Fire 
Display 
Illustrating 
RMP 
Distance 

Figure A-3 
Pool Fire 
Display 
Illustrating 
RMP 
Distance 
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Figure A-4 
Example of 
Plot with 
Grid OFF 

Figure A-2 
Example of 
Plot with 
Grid ON 
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Container Information 

CHARM now supplies the user with container information as a species 

exits the container.  The output may be displayed in graphical or tabular 

format. 

To generate a Mass Rate vs. Time Plot, select the 'Container Info' menu 

item from the 'Displays' menu located on the Main CHARM Input 

Window menu bar, or on any footprint display menu bar.  Select the sub-

menu item labeled 'Mass Rate'.  Figure A-6 illustrates a plot of the mass 

rate exiting from a container as a function of time. 

 

To generate a Mass Amount vs. Time Plot, select the 'Container Info' 

menu item from the 'Displays' menu located on the Main CHARM Input 

Window menu bar, or on any footprint display menu bar.  Select the sub-

menu item labeled 'Mass Amount'.  Figure A-7 illustrates a plot of the 

mass amount exiting from a container as a function of time. 

 

Figure A-6 
Mass Rate 
vs. Time Plot 

Figure A-7 
Mass Amt 
vs. Time Plot 
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To generate a Liquid Depth vs. Time Plot, select the 'Container Info' 

menu item from the 'Displays' menu located on the Main CHARM Input 

Window menu bar, or on any footprint display menu bar.  Select the sub-

menu item labeled 'Liquid Depth'.  Figure A-8 illustrates a plot of the 

liquid remaining in the container as a function of time. 

 

Figure A-8 
Liquid 
Depth vs. 
Time Plot 
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To generate a Pressure vs. Time Plot, select the 'Container Info' menu 

item from the 'Displays' menu located on the Main CHARM Input 

Window menu bar, or on any footprint display menu bar. Select the sub-

menu item labeled 'Pressure'.  Figure A-9 illustrates a plot of the 

pressure in a container as a function of time. 

 

Figure A-9 
Pressure vs. 
Time Plot 
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Recent Scenario Files 

CHARM displays a list of the five most recently opened scenario files in 

the 'File' menu in the Main CHARM Input Window.  Choosing a file from 

this list makes it the current scenario in the Main CHARM Input 

Window. 

 Recent Meteorological Files 

CHARM displays a list of the five most recently opened meteorological 

files in the Met File menu in the Main CHARM Input Window.  Choosing 

a met file from this list makes it the current met parameters in the Main 

CHARM Input Window. 

Estimating Pool Diameter In Accordance with RMP 

When using a Container/Surface Release Type, CHARM will calculate the 

pool diameter/area using a depth of 1 cm to comply with RMP 

specifications. 

To access this parameter in CHARM, select the 'Description Dialog Input' 

command from the 'Options' menu in the Main CHARM Input Window.  

With the 'Container/Surface Description' selected as the release type, 

select the 'Pool' tab and locate the radio button labeled 'Estimate with 1 

cm depth'.  Press the 'Apply' button at the bottom of the window and 

CHARM will calculate the pool diameter based on a 1 cm depth. 
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Solar Radiation Pool Evaporation Efficiency 

When using a Container/Surface or Pool/Lagoon release type, the solar 

radiation used for liquid evaporation may not be used completely for 

evaporation purposes.  For instance, some of the solar radiation may not 

be incorporated into the evaporation, depending on the reflectivity of the 

species to light. 

To access this parameter in CHARM, select the 'Description  

Dialog Input' command from the 'Options' menu in the Main CHARM 

Input Window.  With the 'Container/Surface Description' or the 

'Pool/Lagoon'  selected as the release type, select the 'Pool' tab and locate 

the single line edit box labeled 'Solar Radiation Pool Evaporation 

Efficiency'.  You may enter a value 0.0 - 1.0. 
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Stability Class Schedule 

You may define a time schedule for user-defined stability classes under 

the meteorological parameters. CHARM will use this schedule for 

dispersion calculations and calculation of wind profiles if a surface 

roughness is defined.  Linear interpolation will be used to determine 

surface roughness at any given point. 

To access this parameter in CHARM, double-click on Stability Class in 

the meteorological parameters in the Main CHARM Input Window.  The 

following dialog box will appear: 

 

Click on the 'Use Schedule' checkbox and click on the 'Define Schedule' 

button.  The following dialog box will appear: 

 

Enter stability class values in chronological order since release.  Use the 

scroll bar to input additional data. 

Alternatively, the user may define the stability class schedule from 

the 'Met Dialog Input' command under the 'Options' menu in the 
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Main CHARM Input Window.  Select the 'Stability Class' tab after the 

following dialog box is displayed. 

 

Click on the 'Use Schedule' checkbox and click on the 'Define Schedule' 

button.  Once again, the dialog box defining stability class schedule will 

appear. 

 

Enter stability class values in chronological order since release.  Use the 

scroll bar to input additional data. 
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Appendix B: Enhancements in CHARM Ver. 9.3 

NOTE: CHARM Version 9.2 is exclusive to the Japanese version of 

CHARM and was not an update to the English version. 

Functional software changes in CHARM Version 9.3 that are not found in 

CHARM Version 9.1 include the following: 

• From an Emission Rate plot within CHARM proper, the user has the ability to copy 

either the container rate, the pool rate, or the total combined rates of the pool and 

the container into the User Specified Emission Rate Schedule in the User-Specified 

release type.  Once copied from the Edit menu of the Emission Rate plot, the 

selected rates may be pasted into the emission rate schedule with the push of a 

button. 

• The 'Dose at Point' menu item under the Displays Menu for Plan concentration 

views in CHARM proper allows the user to input a specified point to generate a Dose 

Plot (or concentration history plot) rather than double-clicking on the display.   

• CHARM version 9.3 comes with documentation inserts into the version 9 User’s 

Manual, and updated on-line help. 

Copy Container, Pool, Total Rate 

Once a scenario has been modeled using any one or the three release 

types (i.e. Container/Surface, Pool/Lagoon, User-Specifed After Release 

Conditions), the user may view the emission rate as a function of time. 

Figure B-1 
Example 
output of 
Emission 
Rate Plot 
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Select the Edit menu to view the section allowing the user to copy either 

the Container Rate, the Pool Rate, or the Total Rate consisting of both 

the Container Rate and the Pool Rate to the clipboard. 

Once copied, the user may paste the data into the emission rate schedule 

of a User-Specified release.  To do so, change the release type to User-

Specified After Release Conditions and change the emission rate type to 

User-Specified Rate. 

 

If the copied data exists in the clipboard, notice the Paste Data button is 

activated.  Simply press the Paste Data button and the data, which 

Figure B-2 
Emission 
Rate 
Scheduler 
Input 
Window 
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includes both time since release and emission rate, will be loaded into 

the emission rate schedule.  This allows the user the flexibility to modify 

or tweak the data. 

 

Dose At Point 

The Dose Plot (or concentration history) is normally displayed by 

generating a Plot Plan Snapshot view of the isopleths of interest, moving 

the cross-hair to the desired point, and either double-clicking the left 

mouse button or pressing <Enter>.  The desired point is generally 

specified by locating the distance and direction (or angle) from the source 

in the status bar at the bottom of the window 

 

The 'Dose at Point' menu item under the Displays Menu for Plan 

concentration views in CHARM proper allows the user to input a 

specified point to generate a Dose Plot (or concentration history plot) 

rather than double-clicking on the display.  This method allows the user 

to input an exact location by specifying the distance and direction of the 

point of interest from the source. 

Figure B-3 
Example of 
Snapshot 
Plan Plume 
Display from 
which the 
user may 
obtain a 
Dose Plot 
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Figure B-4 
Input 
window 
requesting 
direction 
and distance 
from source 
to generate 
Dose Plot 
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Appendix C: Enhancements in CHARM Ver. 9.4 

Functional software changes in CHARM Version 9.4 that are not found in 

CHARM Version 9.3 include the following: 

• A glitch in the algorithm for estimating the “RMP Distance” for jet fire radiation 

effects has been corrected.  The previous glitch only affected scenarios where the 

time step shown in the release profile of the “source puff” calculation is less than 40 

seconds. 

• The near-field dispersion algorithm has been changed to reduce enhanced 

dispersion at the source.  The effects of this revision are to generally lower 

dispersion impacts as well as lower vapor cloud explosion overpressure impacts in 

the near field.  This change is going back to the approach used prior to Version 9.3. 

• The X-Y plot axes’ labels have been changed to eliminate exponential notation.  

Originally all tick marks were labeled between 1 and 10 and the axis label had the 

multiplier.  Now the tick marks are labeled with their actual values with no 

multiplier notation. 

• The “3D Plume” display shows multiple concentration isopleths corresponding to 

the isopleths shown on the 2D snapshot plume view.  Previously, only one isopleth 

was shown in the 3D view, and the user was prompted to specify the concentration 

when selecting this option. 

• A number of internal changes were made to the code that have no effect on the 

results but make maintenance and expandability of the code easier.  Some changes 

make it easier to input data.  For example, drag and drop input and output has 

been added to all tables (e.g. emission rates, winds, and stability class). 

• CHARM Version 9.41 was released shortly after Version 9.4. An error in the 

calculation of the flame length for a jet fire was corrected. 

• CHARM Version 9.4 comes with updated documentation, including on-line help and 

inserts into the CHARM User's Manual. 
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Appendix D: Enhancements in CHARM Ver. 9.5 

Functional software changes in CHARM Version 9.5 that are not found in 

CHARM Version 9.4 include the following: 

• The color for each isopleth can be user defined. They no longer are restricted to just 

green, yellow, and red. 

• A number of internal changes were made to the code such as some spelling 

corrections and text placement. 
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Appendix E: Enhancements in CHARM Ver. 9.6 

Functional software changes in CHARM Version 9.6 that are not found in 

CHARM Version 9.5 include the following: 

• The number of isopleth values has been increased from 3 to 6. The code has been 

revamped to make further increases, if needed, more easily implemented. The 

isopleth values and colors can be altered in a single screen 

• The 3D display has been enhanced to allow the use of the mouse for moving the 

observer and observed direction. The display has been made to move more 

smoothly. 

• The CHARM version 9.6 help files have been reviewed to make them more useful 

and complete. 

 

 Isopleth Value and Color 

When a plan or 3-D view is in a window the isopleths (concentration, 

thermal radiation, or explosion overpressures) that are plotted can have 

their values and colors changed. 

 

Select the Isopleths… item in the Options menu to view a dialog box 

similar to the one in Figure E-1. 

Figure E-1 
Example 
input screen 
for defining 
isopeth 
value and 
color. 
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You can enter a value directly into column labelled Value. To change the 

color, double click on the color to change and the dialog box shown in 

Figure E-2 will be displayed. A new color can be selected directly from 

the boxes on the left or a custom color can be created by selecting a point 

in the area to the right. 

 

Figure E-2 
Color 
Selection 
Dialog 
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Index 
 
.SHP, 195 
3D Plume, 226 
3D plume on a 2D map, 230 
About This manual, 7 
actual footprint and population tract 
boundaries used, 214 
Add Winds, 160 
Ambient Pressure, 156 
Ambient Temperature, 155 
Amount Released, 135 
ArcView, 195 
ASCII file format, 192 
atmospheric stability class, 157 
Auto Map Change command, 189, 225 
Auto Map Fraction command, 189 
Auto-Ignition Temperature, 54 
Automatic Met Interface Port, 66 
Automatic Poll command, 101 
Averaging menu, 178, 180 
averaging time, 183 
averaging time default, 178 
Averaging Time/Grid Resolution, 211 
Avogadros number, 42 
Basemap command, 162, 223 
BASEMAP.MAP, 84 
baud rate, 66 
bitmaps, 71 
BLEVE Burn Efficiency, 138 
Boltzman constant, 42 
Building Height, 133 
building wake input, 133 
Building Width, 133 
calculations, 3, 4 
Centerline Concentration Table, 203 
Centerline Concentrations command, 
202 
changing flame speed, 217 
changing potential overpressures, 216 
CHARM Calculations, 4 
CHARM conventions, 14 
CHARM Editor 

Chemical Database command, 29 
Communication Parameters 
command, 66 
Edit menu, 26 
File Location command, 28 
Pack Chemical Database command, 
64 
Site Information command, 64 

CHARM Input, 2 

CHARMED, 26 
CHARMED Editor 

Map Definition command, 71 
Chemical Data command, 163, 223 
chemical database, 29 

adding a species, 59 
changing a species name, 60 
deleting a species, 63 
editing, 59 
editing chemical data, 36 
editing emergency response text, 62 
Emergency Response Text 
command, 62 
modifying data, 61 
packing, 64 
saving updates, 36 
searching, 30 
Site Information command, 62 
species names, 31 
thermodynamic data, 35 

Chemical Database command, 29 
Chemical Editor Window, 35 
Chemical Response command, 164, 223 
Chemical Selection window, 29 
circular population impact, 211 
Cloud Cover, 156 
Communications Parameters command, 
66 
communications port, 66 
communications port definition, 66 
concentration vs. time plot, 178 
connecting pipe, 146 
connecting pipe diameter, 146 
Container/Surface Description, 129 
Continue command, 208 
Create ASCII File command, 191 
creating a population file for user with 
CHARM, 252 
creating a TigerMap file for user with 
CHARM, 251 
critical pressure, 40 
Critical Temperature, 39 
critical volume, 40 
Darcy Constant, 141 
Data Window on Top command, 237 
Data Window Visible command, 236 
DDE, 194 
Decay command, 187 
default filename extensions, 15 
default values, 20 
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Define a Map Location command, 77 
Define a Point command, 74 
Define a Release Location command, 
78, 79 
Define a Scale command, 75 
Define menu for map definition, 73 
Define Point option, 188 
Description Dialog Input Command, 
105 
dialog boxes, 19 
directory locations, 28 
Displays menu 

Plume View, 196 
distance option, 182 
Distances command, 169, 175 
Dose Display, 178 
Dose Display Table, 179 
edit menu, 37 
Effective Diameter of Molecule, 42 
elevated tanks, 142 
emergency response files, 232 
emergency response mode, 1, 232 
Emergency Response Mode, 1 
emergency response mode procedures, 
233 
emergency response output, 131 
Emission Rate, 150 
Emission Rate command, 167, 222 
Energy Fluxes command, 169, 172 
Energy of Molecular Interaction, 42 
Expand Map Name command, 82, 225 
Explosion Efficiency, 57 
Explosion Overpressures command, 
215 
explosion overpressures vs. time plot, 
217 
file menu, 37, 224 
File menu 

Main CHARM Input Window, 92 
file names, 15 
Merge Pop, 247 
First Default Concentration, 50 
Flame Speed, 55 
Flame Temperature, 57 
Flash Point Temperature, 53 
footprint and population tract 
rectangles used, 215 
footprint rectangle and actual 
population tract boundaries used, 215 
fraction of mass suspended as droplets, 
135 
Free Energy of Formation, 54 
Gamma, 41 
Gaussian puff model, 4 
generating a plume display, 176 

graphic displays, 4 
Graphic Displays, 4 
grid, 183 
grid display option, 184 
grid size, 183 
half-life, 187 
Halogen Atoms Being Chlorine, 58 
hardware requirements, 6 
heat of vaporization, 40 
Height of Hole, 145 
Hole Diameter, 143 
Hole is Facing, 144 
horizontal cylinder tank, 141 
horizontal puff direction, 152 
horizontal puff speed, 153 
Horizontal Puff Speed, 153 
Huber-Snyder calculations, 134 
icon selection, 225 
Input command, 222 
input values, 19 
installation 

first time, 10 
installing CHARM, 10 
Integrated Area command, 207 
Integrated Area Plan Plume View, 181 
Inversion Height, 158 
isopleth concentrations, 50 
Isopleth Concentrations, 132 
isopleths, 132 
isopleths command, 181 
Jet Fire command, 170 
jet fire radiation vs. time plot, 171 
jet fire vertical cross-section, 172 
keyboard techniques, 24 
Landview II Data, 247 
Larger Scale Map command, 190, 225 
line width, 184 
liquid density equation, 45 
Liquid Density Equation Coefficient A, 
46 
Liquid Density Equation Coefficient B, 
46 
Liquid Density Equation Coefficient C, 
46 
Liquid Density Equation Coefficient D, 
47 
Liquid Density Equation Coefficient E, 
47 
Liquid Depth, 142 
Liquid Head Capacity Coefficient A, 43 
Liquid Head Capacity Coefficient B, 44 
Liquid Head Capacity Coefficient C, 44 
Liquid Head Capacity Coefficient D, 
44 
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Liquid Head Capacity Coefficient E, 45 
liquid heat capacity equation, 43 
Liquid Pool Surface Height Above 
Ground, 145 
Location command, 188 
Lower Flammability Limit, 54 
Main CHARM Input Window, 87 

Displays menu 
Chemical Data command, 125 
Emergency Response Text 
command, 125 
Emission Rate command, 126 
Jet Fire command, 126 
Mechanical Overpressures 
command, 126 
Puff Description command, 126 
Site Information command, 125 
Thermal Radiation command, 126 

Edit menu, 98 
Copy command, 98 

File menu, 91, 92 
New command, 92 
Open command, 93, 94 
Print command, 94 
Save As command, 93 
Save command, 93 
Scenarios command, 93 

Metfile menu 
Automatic Poll command, 100 
New command, 99 
Open command, 99 
Save As command, 99 
Save command, 99 

MetFile menu, 99 
modifying input, 90 
scrolling, 89 
selecting an input field, 89 

Manual Conventions, 8 
Map command, 187, 225 
Map Definition command, 72 
map description, 189 
Map Displays, 3 
map file formats, 71 
map files, 232 
map location icons, 233 
map requirements, 232 
maps 

assigning a file name, 83 
automatic base map display, 84 
defining, 71 
defining a map location, 77 
defining a point, 74 
defining a release location, 78 
deleting an icon, 82 
editing icon information, 81 

map generation programs, 71 
map location icon, 77 
metafile format, 72 
naming a larger scaled map, 83 
reading maps from files, 71 
reading maps from the clipboard, 71 
repositioning icons, 81 
saving a map definition, 83 
scrolling, 72 

Maximum Concentration command, 
200 
Maximum Distance command, 197 
maximum distance overpressure 
display, 218 
Maximum Distance Table, 197 
maximum pool diameter, 136 
Maximum Width command, 198 
Maximum Width Table, 199 
mechanical overpressures command, 
173 
mechanical/explosion overpressures, 
182 
melting point, 38 
memory problems, 11 
menus and commands, 15 
Merge Tigers to Clipboard command, 
241 
Met Data command, 207 
Met Data input, 155 
Met Polling Interval, 66 
met polling interval definition, 66 
metafiles, 71 
meteorological interface program, 66 
MetFile menu, 99 
METINTER, 235 
METINTER window, 236 
METINTER.EXE, 66, 101 
metric units, 105 
Molar Air Fraction, 154 
Molar Water Vapor Fraction, 154 
Molecular Weight, 38 
monochrome command, 184 
Monochrome command, 201 
mouse techniques, 23 
moving the observer, 227 
Net Heat of Combustion, 53 
New command, 94 
New Time command, 190 
No Hatch command, 186 
No Map command, 188 
normal boiling point, 38 
Number of Carbon Atoms, 57 
Number of Halogen Atoms, 58 
Number of Hydrogen Atoms, 57 
Number of Oxygen Atoms, 58 
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observed point, 228 
observer location, 228 
observer step distances, 229 
online help, 19 
open File command, 94 
open MetFile command, 101 
options menu, 224 
Options menu, 181 
overpressure damage estimates, 219 
overpressure vertical cross-section, 219 
Overpressures command, 174 
Pack Chemical Database command, 64 
packing the database, 64 
Parameter B for Concentration Probit 
Equation, 52 
Parameter N for Concentration Probit 
Equation, 52 
picture files, 71 
piping system components, 147 
plan plume view, 177 
plan plume view displays, 181 
planning mode, 1 
Planning Mode, 1 
plot scale, 185 
Plume command, 175 
Plume Half-Widths command, 204 
point definition, 74 
Pool and Jet Fire Energy Flux window, 
170 
Pool/Lagoon Description, 129 
population calculation methods, 214 
Population Impact command, 213 
Population Impacts, 3 
positioning a jet fire footprint, 171 
positioning a thermal footprint, 168 
positioning an overpressures footprint, 
174 
positioning the source, 177 
print preview command, 97 
print setup command, 98 
printer port key, 13 
probit equation, 52 
Process Population File command, 246 
Process TigerMap command, 241 
processing Tiger/Line population files, 
245 
prompt at exit command, 103 
Puff Depth, 152 
puff description as input, 166 
Puff Diameter, 151 
Puff Is Moving Toward, 152 
Puff Temperature, 151 
railroad tank car, 141 
real-time met data acquisition, 235 
Recalculate command, 209 

Receptor Height command, 186 
Relative Humidity, 155 
Relative Pore Volume, 140 
Relative Roughness Factor (e/D), 146 
release description input, 126 
Release Height, 134 
release location icons, 78, 79, 233 
release scenario files, 233 
Release Time, 150 
Release Type, 128 
release types, 128 
reported fraction, 51 
Reset Source command, 178, 189 
running the CHARM editor, 26 
scale definition, 75 
Scale Radius command, 185 
Scale Ratio command, 185 
scenario, 89 
Scenarios command, 95, 107, 109 
scrolling a map, 189 
search function, 23, 30 
Second Default Concentration, 51 
Select Met Site command, 237 
Select Met Station command, 237 
Selected Area command, 210 
selecting menus and commands, 24 
Set Latititude/Longitude Limits 
command, 244 
Set Latitude/Longitude Point command, 
250 
Set Tiger Directory command, 244, 250 
Site Information command, 64, 162, 
223 
Snapshot Plan Plume View display, 181 
Software Requirements, 7 
Solar Radiation, 158 
solar radiation worksheet, 102 
Source to Building Direction field, 133 
Source to Building Distance, 134 
Source/Puff Description command, 
165, 222 
Species, 127 
Sphere Burst Overpressure window, 
173 
Stability Class, 156 
starting CHARM, 14 
starting/stopping CHARM, 14 
stopping CHARM, 14 
Storage Pressure, 137 
Storage Temperature, 137 
supplemental distance circles, 185 
Surface Density, 140 
surface description input 

Darcy Constant, 141 
Density, 140 
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Relative Pore Volume, 140 
Specific Heat, 139 
Surface Type, 139 
Thermal Conductivity, 140 

Surface Roughness, 158 
Surface Specific Heat, 139 
surface tension of liquid phase, 41 
Surface Thermal Conductivity, 139 
Surface Type, 139 
tank description input 

Diameter, 142 
Height, 141 
Height of the Hole, 145 
Hole Diameter, 143 
Hole is Facing, 144 
Length, 142 
Liquid Depth, 142 
Tank Type, 141 
Vertical Angle, 144 

Tank Diameter, 142 
Tank Height, 141 
Tank Length, 142 
Tank Type, 141 
text editor, 62 
text size, 184 
The CHARM Environment, 6 
thermal radiation cross-section, 169 
Third Default Concentration, 51 
TIGERMAP edit menu, 242 
TIGERMAP Edit Menu, 248 
TIGERMAP file menu, 240, 245 
TIGERMAP Set Text Size command, 
243, 249 
TIGERMAP Show Text command, 243, 
249 
TIGERMAP window, 239 
TIGERMAP Zoom/Unzoom commands, 
243, 249 
Time Circles command, 190 
time is minutes-seconds command, 103 
Time-Averaged Footprint command, 209 
Title, 127 
Transparency command, 186 
triple point, 39 
triple point pressure, 39 
U.S. Census Bureau Tiger/Line™ 1992 
data, 239 
unathorized use, 13 
units of measure, 19 
Unzoom command, 74, 224 

Upper Flammability Limit, 53 
Use Auto Scale command, 187 
Use Inverse Square command, 237 
User Specified release input 

Emission Rate, 150 
Horizontal Puff Speed, 153 
Molar Air Fraction, 154 
Molar Water Vapor Fraction, 154 
Puff Depth, 152 
Puff Diameter, 151 
Puff Is Moving Toward, 152 
Puff Temperature, 151 
Release Time, 150 
Vertical Puff Speed, 154 

User-Specified After Release Conditions, 
129 
user-specified puff description, 166 
vapor cloud explosion vs. time plot, 174 
vapor phase heat capacity equation, 48 
Vapor Phase Heat Capacity Equation 
Coefficient A, 48 
Vapor Phase Heat Capacity Equation 
Coefficient B, 49 
Vapor Phase Heat Capacity Equation 
Coefficient C, 49 
Vapor Phase Heat Capacity Equation 
Coefficient D, 49 
Vapor Phase Heat Capacity Equation 
Coefficient E, 50 
Vertical Angle of Hole, 144 
vertical cross-section overpressures 
display, 175 
vertical cylinder tank, 141 
Vertical Puff Speed, 154 
Vertical X-section command, 201 
view port, 185 
viscosity of liquid phase, 41 
Visual Verify command, 213 
Water Fraction of Surface, 138 
wetted tank surface area, 136 
wind direction, 160 
wind measurement height, 159 
wind shifts, 160 
wind speed, 160 
wind time, 160 
Winds, 159 
X/Y Locations, 132 
z scale, 230 
Zoom command, 73, 224 
zooming map area, 225 

 


